
  








<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.clevelandjewishnews.com/content/tncms/live/" />
<meta name="tncms-access-version" content="" />
<meta name="keywords" content="prime minister, yair lapid, benjamin netanyahu, politics, institutes, ministries, israel, naftali bennett, yair golan, arnon milchan" />
<meta name="news_keywords" content="prime minister, yair lapid, benjamin netanyahu, politics, institutes, ministries, israel, naftali bennett, yair golan, arnon milchan" />
<meta name="description" content="Israel has a new prime minister, Yair Lapid, who will serve until after elections Nov. 1. If recent experience is any guide, he will also serve well beyond that, either" />
<meta name="author" content="Cliff Savren | CJN Columnist columnists@cjn.org" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="google-site-verification" content="&lt;script&gt;   (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){   (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),   m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)   })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');    ga('create', 'UA-26323411-3', 'auto');   ga('send', 'pageview');  &lt;/script&gt;" />
<meta name="msvalidate.01" content="5F21ED69D2FEF30FBDC51E99D287C6D5" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.clevelandjewishnews.com/columnists/cliff_savren/israel-needs-to-look-beyond-netanyahu-in-next-election/article_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/d/2d/d2dc9a30-fc54-11ec-bbce-e7560342f71a/62c41f34bd51e.image.jpg?crop=880%2C462%2C0%2C16&amp;resize=880%2C462&amp;order=crop%2Cresize" />
<meta property="og:image:width" content="880" />
<meta property="og:image:height" content="462" />
<meta property="og:title" content="Israel needs to look beyond Netanyahu in next election" />
<meta property="og:description" content="Israel has a new prime minister, Yair Lapid, who will serve until after elections Nov. 1. If recent experience is any guide, he will also serve well beyond that, either" />
<meta property="og:site_name" content="Cleveland Jewish News" />
<meta property="og:section" content="Cliff Savren" />
<meta property="fb:app_id" content="565068060326266" />
<meta property="article:publisher" content="https://www.facebook.com/ClevelandJewishNews" />
<meta name="twitter:image" content="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/d/2d/d2dc9a30-fc54-11ec-bbce-e7560342f71a/62c41f34bd51e.image.jpg?crop=880%2C462%2C0%2C16&amp;resize=438%2C230&amp;order=crop%2Cresize" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@CleveJN" />
<meta name="twitter:image:alt" content="Israeli Prime Minister Yair Lapid" />
<meta property="fb:pages" content="23609471043" />
<meta property="tncms:ads" content="lazyload,refresh" />
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.c58a1beaa3640fa94c3db09673c4d95c.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.3d37e07cfb0394d967fd941c6f98867e.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.6ee2c17f3ef34e32b5fa02524f5978e7.css"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/live/global/resources/styles/site.css?_dc=1450887859"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/styles/owl.carousel.d631cca58a0d014854c4a6c1815f1da3.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-text-promo.945a2efac4892ce469180c513f411107.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"townnews":{"product":{"software":"BLOX","version":"1.62.0"},"crm":{"group_id":null}},"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"boxy","style":"default","syndicated":"false","reaction":"true","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"asset":{"author":"Cliff Savren | CJN Columnist <br \/>columnists@cjn.org","id":"6fb0c844-0214-11ed-8c92-e39f5ec5cd80","app":"editorial","ga_page":"\/columnists\/cliff_savren\/article_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html"},"vendor":{"outbrain":"disabled","taboola":""},"ad":{"vendor":"dfp premium"},"system":{"render_time":366},"client":{"is_bot":"no","is_gdpr":"no"},"google":{"ua":"UA-10028671-1"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="https://tags.crwdcntrl.net/c/10228/cc.js?ns=_cc10228" id="LOTCC_10228"></script>
<script>
	if(document.cookie.indexOf('tncms-dmp-id') != -1) {
		_cc10228.add('tp', 'TNNW');
		_cc10228.add('act', ' User Login');
		_cc10228.add('tpid', document.cookie.split( ';' ).map( function( x ) { return x.trim().split( '=' ); } ).reduce(function( a, b ) { a[ b[ 0 ] ] = b[ 1 ]; return a; }, {} )[ "tncms-dmp-id"]);
		document.cookie = 'tncms-dmp-id=;expires=Thu, 01 Jan 1970 00:00:01 GMT';
		sessionStorage.removeItem('tncms.behaviors');
		sessionStorage.removeItem('tncms.dmp.audiences');
	}
	_cc10228.bcp();
</script>

<script type="module" async="async" src="/shared-content/art/tncms/api/access.js"></script>
<script src="/shared-content/art/tncms/api/access-legacy.js" defer="defer" nomodule="nomodule"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.d6d18fcf88750a16d256e72626e676a6.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.08a61544f369cc43bf02e71b2d10d49f.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.f3739bd4d04bcee9e077d20b4f31f29c.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.cb897187c4718280fd69d2e6d6c3909d.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.navigation.accessibility.7a9170240d21440159b9bd59db72933b.js"></script>
<script src="https://tagan.adlightning.com/townnews/op.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>/*<![CDATA[*/ window.googletag = window.googletag || {cmd: []};
    window.gptAdSlots = window.gptAdSlots || [];

    window.__tnt = window.__tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};
    __tnt.ads.dfp.dmp = __tnt.ads.dfp.dmp || {};
    __tnt.ads.dfp.dmp.audienceCheck = function(settings) {
        if (!__tnt.client.capabilities.supportsLocalStorage() || localStorage.getItem('tncms.dmp.audiences') == null) return false;
        if (settings.block && typeof settings.audience != 'undefined' && settings.audience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), settings.audience.split(','))) return true;
        } else if (typeof __tnt.ads.dfp.dmp.hideAudience != 'undefined' && __tnt.ads.dfp.dmp.hideAudience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), __tnt.ads.dfp.dmp.hideAudience)) return true;
        }
        return false;
    };

    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};

    __tnt.ads.dfp.targeting.asset_id = '6fb0c844-0214-11ed-8c92-e39f5ec5cd80';
    __tnt.ads.dfp.targeting.k = ["prime minister","yair lapid","benjamin netanyahu","politics","institutes","ministries","israel","naftali bennett","yair golan","arnon milchan"];

    __tnt.ads.dfp.targeting.page = ["asset","article","app-editorial"];
    __tnt.ads.dfp.templates = __tnt.ads.dfp.templates || {};
    __tnt.ads.dfp.templates = {
        cube:"https:\/\/bloximages.chicago2.vip.townnews.com\/clevelandjewishnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/cube.d862aac30e9cb24516c7474509403c47.js",
        interstitial:"https:\/\/bloximages.chicago2.vip.townnews.com\/clevelandjewishnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/interstitial.df40f87de692498682823c6773da5459.js",
        nativeArticle:"https:\/\/bloximages.chicago2.vip.townnews.com\/clevelandjewishnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/native-article.9b3cd3bb8591bed71346f4fe429b96dc.js",
        pageCurl:"https:\/\/bloximages.chicago2.vip.townnews.com\/clevelandjewishnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/page-curl.ca0c1a7372c29272ef1ccf504ced01a9.js",
        parallax:"https:\/\/bloximages.chicago2.vip.townnews.com\/clevelandjewishnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/parallax.0ce32932f3b4125f930bea8d431f8f03.js",
        paw:"https:\/\/bloximages.chicago2.vip.townnews.com\/clevelandjewishnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/paw.9ea074ccc913cb273a4b790e1e37460a.js",
        pencil:"https:\/\/bloximages.chicago2.vip.townnews.com\/clevelandjewishnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/pencil.2662e4159cdac4809283c5399d78644b.js",
        reveal:"https:\/\/bloximages.chicago2.vip.townnews.com\/clevelandjewishnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/reveal.e5d561a6b71aa2730a07fa90f5f4f6d6.js",
        roller:"https:\/\/bloximages.chicago2.vip.townnews.com\/clevelandjewishnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/roller.c699c542afb9f08b38613e8473ddf14f.js",
        slider:"https:\/\/bloximages.chicago2.vip.townnews.com\/clevelandjewishnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/slider.015001bff591d1665c6d0ec2a888b1ca.js",
        stickyAnchor:"https:\/\/bloximages.chicago2.vip.townnews.com\/clevelandjewishnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/sticky-anchor.fc1a4213adeec354910108f84bf0e732.js",
        video:"https:\/\/bloximages.chicago2.vip.townnews.com\/clevelandjewishnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/video-inline.9b0997ab77d1d69707d283848faeacdd.js",
        wallpaper:"https:\/\/bloximages.chicago2.vip.townnews.com\/clevelandjewishnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/wallpaper.dc1c1bace62343a130be3589fe0846f9.js"
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22670918608/clevelandjewishnews.com/columnists/cliff_savren';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320,90]).addSize([768, 0], [728,90]).addSize([992, 0], [728,90]).addSize([1200, 0], [728,90]).build();
                gptAdSlots['ad-1543627'] = googletag.defineSlot(adUnit, [[320,90],[728,90]], 'ad-1543627').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1543627'].setTargeting('pos', ['atf','block-leaderboard-top']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22670918608/clevelandjewishnews.com/columnists/cliff_savren';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [200,90]).addSize([1200, 0], [200,90]).build();
                gptAdSlots['ad-1543632'] = googletag.defineSlot(adUnit, [[200,90]], 'ad-1543632').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1543632'].setTargeting('pos', ['atf','block-leaderboard-tile-top']);
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.283bfb49ef55c073fceda15ffbf58de8.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22670918608/clevelandjewishnews.com/columnists/cliff_savren';
            
                gptAdSlots['fixed-big-ad-top-asset'] = googletag.defineSlot(adUnit, [300,250], 'fixed-big-ad-top-asset').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-big-ad-top-asset'].setTargeting('pos', ['fixed-big-ad-top-asset','atf']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22670918608/clevelandjewishnews.com/columnists/cliff_savren';
            
                gptAdSlots['fixed-big-ad-middle-asset'] = googletag.defineSlot(adUnit, [300,250], 'fixed-big-ad-middle-asset').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-big-ad-middle-asset'].setTargeting('pos', ['fixed-big-ad-middle-asset','stf']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22670918608/clevelandjewishnews.com/columnists/cliff_savren';
            
                gptAdSlots['fixed-big-ad-bottom-asset'] = googletag.defineSlot(adUnit, [300,250], 'fixed-big-ad-bottom-asset').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-big-ad-bottom-asset'].setTargeting('pos', ['fixed-big-ad-bottom-asset','btf']);
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/search/resources/scripts/tnt.followed.notifications.6600e99595fd219e961e9882c796e61c.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.facebook.comments.89e3602c68154764e889947868c957c9.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22670918608/clevelandjewishnews.com/columnists/cliff_savren';
            
                gptAdSlots['ad-1543672'] = googletag.defineSlot(adUnit, [[300,250],[300,600]], 'ad-1543672').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1543672'].setTargeting('pos', ['atf','block-big-ad-top']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22670918608/clevelandjewishnews.com/columnists/cliff_savren';
            
                gptAdSlots['ad-1543648'] = googletag.defineSlot(adUnit, [[300,250],[300,600]], 'ad-1543648').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1543648'].setTargeting('pos', ['btf','block-rail-middle']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22670918608/clevelandjewishnews.com/columnists/cliff_savren';
            
                gptAdSlots['ad-1543680'] = googletag.defineSlot(adUnit, [300,250], 'ad-1543680').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1543680'].setTargeting('pos', ['stf','block-big-ad-middle']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22670918608/clevelandjewishnews.com/columnists/cliff_savren';
            
                gptAdSlots['ad-1543681'] = googletag.defineSlot(adUnit, [300,250], 'ad-1543681').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1543681'].setTargeting('pos', ['btf','block-big-ad-bottom']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964,22670918608/clevelandjewishnews.com/columnists/cliff_savren';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320,50]).addSize([768, 0], [728,90]).addSize([992, 0], [728,90]).addSize([1200, 0], [728,90]).build();
                gptAdSlots['ad-1543684'] = googletag.defineSlot(adUnit, [[320,50],[728,90]], 'ad-1543684').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1543684'].setTargeting('pos', ['btf','block-leaderboard-bottom']);
    });
 /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script>/*<![CDATA[*/ 

    googletag.cmd.push(function() {
        googletag.pubads().setTargeting('browser', __tnt.client.browser.name);
        if (__tnt.ads.dfp.targeting) {
            for (var k in __tnt.ads.dfp.targeting) {
                if (__tnt.ads.dfp.targeting.hasOwnProperty(k)) {
                    googletag.pubads().setTargeting(k,__tnt.ads.dfp.targeting[k]);
                }
            }
        }
            googletag.pubads().disableInitialLoad();
            googletag.pubads().addEventListener('impressionViewable', function(event) {
                for (var key in gptAdSlots) {
                    if (gptAdSlots[key] === event.slot && __tnt.ads.slots[key]) {
                        if (!__tnt.ads.slots[key].viewableImpression) __tnt.ads.slots[key].viewableImpression = true;
                    }
                }
            });

        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
    });
 /*]]>*/</script>

            
            <title>Israel needs to look beyond Netanyahu in next election | Cliff Savren | clevelandjewishnews.com</title>
            
    <style>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</style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.clevelandjewishnews.com/content/tncms/site/icon.ico" />
    
        <link rel="apple-touch-icon" href="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/53387046-0cab-11e6-b21d-4f2f1d3b10c9.gif?resize=180%2C180" />
    
        <link rel="amphtml" href="https://www.clevelandjewishnews.com/columnists/cliff_savren/israel-needs-to-look-beyond-netanyahu-in-next-election/article_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.amp.html" />
    
        <link rel="preconnect" href="//www.google.com">
    
        <link rel="preconnect" href="//adservice.google.com">
    
        <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    
        <link rel="preconnect" href="//stats.g.doubleclick.net">
    
        <link rel="preconnect" href="//tpc.googlesyndication.com">
    
        <link rel="preconnect" href="//pagead2.googlesyndication.com">
    
        <link rel="preconnect" href="//tagan.adlightning.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    
        <link rel="preconnect" href="//connect.facebook.net">
    
        <link rel="preconnect" href="//bcp.crwdcntrl.net">
    
        <link rel="preconnect" href="//tags.crwdcntrl.net">
    <link rel="alternate" type="application/rss+xml" title="Israel needs to look beyond Netanyahu in next election | Cliff Savren | clevelandjewishnews.com" href="http://www.clevelandjewishnews.com/search/?f=rss&amp;t=article&amp;c=columnists/cliff_savren&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.clevelandjewishnews.com/columnists/cliff_savren/israel-needs-to-look-beyond-netanyahu-in-next-election/article_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html" />
            <script defer src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.46a248d75dc687aa8d928092f6b77fc7.js"></script>
              

<!-- @apittman #tntracking 607134  Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');

fbq('init', '1006756389441491');
fbq('track', "PageView");</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1006756389441491&ev=PageView&noscript=1";;
/></noscript>
<!-- End Facebook Pixel Code -->

<script type="text/javascript">
$(document).ready(function(){



$('#user-main-menu-wrapper > div > div.col-md-9.col-md-push-3 > div.user-dashboard > div:nth-child(1) > div:nth-child(3) > div > a').attr("href","https://cjn.newzware.com/ss70v2/cjn/common/template.jsp?nwmodule=classified&nwpage=woe");
$('#collapse-classifieds > a:nth-child(1)').attr("href","https://cjn.newzware.com/ss70v2/cjn/common/template.jsp?nwmodule=classified&nwpage=woe");
$('#collapse-classifieds > a:nth-child(2)').attr("href","https://cjn.newzware.com/ss70v2/cjn/common/template.jsp?nwmodule=classified&nwpage=woe");


$('#collapse-subscription > a:nth-child(1)').attr("href","https://cjn.newzware.com/ss70v2/cjn/common/template.jsp");
$('#collapse-subscription > a:nth-child(2)').attr("href","https://cjn.newzware.com/ss70v2/cjn/common/template.jsp");
$('#user-main-menu-wrapper > div > div.col-md-9.col-md-push-3 > div.user-dashboard > div:nth-child(2) > div:nth-child(3) > div > a').attr("href","https://cjn.newzware.com/ss70v2/cjn/common/template.jsp");

});
</script>

<script type="text/javascript">
    $(document).ready(function(){
        $('.related-sidebar.default.subscriber-hide div.asset-related-siblings.inline-asset div.asset-related-article.sibling-article.inline-asset h3.inline-heading.text-muted').text("Related Content");
    });
</script>


<script type="text/javascript">
    $(window).load(function() {
        $('.fb_comments_count_zero').each(function( index ) {
            $(this).parent().parent().css('display', 'none');
        });
    });
</script>

<!-- #tntracking @albohall 615925 -->
<!-- Google Code for Remarketing Tag -->
<!--------------------------------------------------
Remarketing tags may not be associated with personally identifiable information or placed on pages related to sensitive categories. See more information and instructions on how to setup the tag on: http://google.com/ads/remarketingsetup
--------------------------------------------------->
<script type="text/javascript">
/* <![CDATA[ */
var google_conversion_id = 942747443;
var google_custom_params = window.google_tag_params;
var google_remarketing_only = true;
/* ]]> */
</script>
<script type="text/javascript" src="//www.googleadservices.com/pagead/conversion.js">
</script>
<noscript>
<div style="display:inline;">
<img height="1" width="1" style="border-style:none;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/942747443/?guid=ON&amp;script=0"/>
</div>
</noscript>


        </head>
        <body class="fixed-scroll-nav app-editorial grid-boxy blox-asset uuid-6fb0c844-0214-11ed-8c92-e39f5ec5cd80  section-columnists section-cliff-savren type-article infinity-disabled" data-authors='["Cliff Savren"]' data-path="/columnists/cliff_savren">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.clevelandjewishnews.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;townnews.product.software=BLOX&amp;townnews.product.version=1.62.0&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=boxy&amp;tncms.page.style=default&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=true&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=false&amp;tncms.asset.author=Cliff+Savren+%7C+CJN+Columnist+%3Cbr+%2F%3Ecolumnists%40cjn.org&amp;tncms.asset.id=6fb0c844-0214-11ed-8c92-e39f5ec5cd80&amp;tncms.asset.app=editorial&amp;tncms.asset.ga_page=%2Fcolumnists%2Fcliff_savren%2Farticle_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html&amp;tncms.vendor.outbrain=disabled&amp;tncms.vendor.taboola=&amp;tncms.ad.vendor=dfp+premium&amp;tncms.system.render_time=366&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.google.ua=UA-10028671-1&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <a href="#main-page-container" class="sr-only" onclick="document.getElementById('main-page-container').scrollIntoView(); return false">Skip to main content</a><div id="fb-root"></div>
        
        
        
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container"><div id="asset-contribute-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-certificate tnt-fw"></i></div>
                <div class="asset-edit-message">You are the owner of this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" href="https://www.clevelandjewishnews.com/users/admin/contribute/article/?assetid=6fb0c844-0214-11ed-8c92-e39f5ec5cd80&assettype=article"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit Article</a>
                    
                        <a class="btn btn-danger btn-sm" href="https://www.clevelandjewishnews.com/users/admin/contribute/article/?from_section=/columnists/cliff_savren"><i class="fas tnt-plus tnt-fw"></i> Add New Article</a>
                    
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.clevelandjewishnews.com/tncms/admin/editorial-asset/?edit=6fb0c844-0214-11ed-8c92-e39f5ec5cd80"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        
    
        
            <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left visible-sm visible-xs" aria-label="Left Main Menu" aria-expanded="false" tabindex="-1" >
                <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "></div>
                <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist" aria-hidden="true"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-1" data-target="#mobile-nav-left_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/"  class="nav-link tnt-section-span-class-fas-tnt-home-span "><span class="fas tnt-home"></span></a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/about.html"  class="nav-link tnt-section-about-us">About Us</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/advertise"  class="nav-link tnt-section-advertise">Advertise</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/contact.html"  class="nav-link tnt-section-contact-us">Contact Us</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms"  class="nav-link tnt-section-lifecycle-and-subscriber-forms">Lifecycle and Subscriber Forms</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/esignup/"  class="nav-link tnt-section-sign-up-for-email-newsletters">Sign up for Email Newsletters</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/employment/"  class="nav-link tnt-section-employment">Employment</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-2" data-target="#mobile-nav-left_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/news"  class="nav-link tnt-section-news ">News</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/local_news/"  class="nav-link tnt-section-local-news">Local News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/national_news/"  class="nav-link tnt-section-national-news">National News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/world_news/"  class="nav-link tnt-section-world-news">World News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/stronger_than_hate/"  class="nav-link tnt-section-stronger-than-hate">Stronger than hate</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/culture/"  class="nav-link tnt-section-culture">Culture</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/culture/theater/"  class="nav-link tnt-section-theater">Theater</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/sports/"  class="nav-link tnt-section-sports">Sports</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/briefs"  class="nav-link tnt-section-briefs">Briefs</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/differencemakers/"  class="nav-link tnt-section-18-difference-makers">18 Difference Makers</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/12_under_36/"  class="nav-link tnt-section-12-under-36">12 Under 36</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/coronavirus/"  class="nav-link tnt-section-covid-19 ">COVID-19</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-4" data-target="#mobile-nav-left_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/features"  class="nav-link tnt-section-features ">Features</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/features/business"  class="nav-link tnt-section-business">Business</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/features/camps/"  class="nav-link tnt-section-camps">Camps</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/features/multimedia/"  class="nav-link tnt-section-cjn-tv">CJN TV</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/features/special_sections/education/"  class="nav-link tnt-section-education">Education</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/features/health"  class="nav-link tnt-section-health">Health</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/features/holidays/"  class="nav-link tnt-section-holidays">Holidays</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/features/nosh/"  class="nav-link tnt-section-nosh">Nosh</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/features/religious_life/"  class="nav-link tnt-section-religious-life">Religious Life</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/features/silver_linings/"  class="nav-link tnt-section-silver-linings">Silver Linings</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/features/special_sections/"  class="nav-link tnt-section-special-sections">Special Sections</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/unfiltered/"  class="nav-link tnt-section-unfiltered">UNFILTERED</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-5" data-target="#mobile-nav-left_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/opinion"  class="nav-link tnt-section-opinion ">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/columnists/"  class="nav-link tnt-section-cjn-columnists">CJN Columnists</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/guest_columns/"  class="nav-link tnt-section-guest-columns">Guest Columns</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/letters_to_editor/"  class="nav-link tnt-section-letters-to-the-editor">Letters to the Editor</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/op-eds/"  class="nav-link tnt-section-op-eds">Op-Eds</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/polls"  class="nav-link tnt-section-polls">Polls</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-6" data-target="#mobile-nav-left_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/community/"  class="nav-link tnt-section-community ">Community</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/community/lifecycles/"  class="nav-link tnt-section-lifecycles">Lifecycles</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/community/community_scene/"  class="nav-link tnt-section-in-the-community">In the Community</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/community/the_city/"  class="nav-link tnt-section-the-city">The City</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/differencemakers/"  class="nav-link tnt-section-18-difference-makers">18 Difference Makers</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/community/my_israel/"  class="nav-link tnt-section-my-israel">My Israel</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/community/circle_of_life/"  class="nav-link tnt-section-circle-of-life">Circle of Life</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/community/lifecycles/obituaries/"  class="nav-link tnt-section-obituaries ">Obituaries</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-8" data-target="#mobile-nav-left_menu-child-8">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/local-events/"  class="nav-link tnt-section-events ">Events</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-8" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/local-events/"  class="nav-link tnt-section-events-calendar">Events Calendar</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://new.evvnt.com/?with_navbar&amp;force_snap_sell&amp;partner=CLEVELANDJEWISHNEWS&amp;publisher_url:clevelandjewishnews.com#/quick"  target="_blank" rel="noopener" class="nav-link tnt-section-promote-your-event">Promote Your Event</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/differencemakers/"  class="nav-link tnt-section-18-difference-makers">18 Difference Makers</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/wil/"  class="nav-link tnt-section-women-in-leadership">Women in Leadership</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/12under36/"  class="nav-link tnt-section-12-under-36">12 Under 36</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="https://cjn.newzware.com/ss70v2/cjn/common/template.jsp"  target="_blank" rel="noopener" class="nav-link tnt-section-current-issue ">Current Issue</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-10" data-target="#mobile-nav-left_menu-child-10">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/magazines/"  class="nav-link tnt-section-magazines ">Magazines</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-10" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/magazines/bar_bat/"  class="nav-link tnt-section-bar-bat-mitzvah">Bar•Bat Mitzvah</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://jstylemagazine.com"  target="_blank" rel="noopener" class="nav-link tnt-section-jstyle">Jstyle</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://canvascle.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-canvas">Canvas</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://www.balancedmag.com"  target="_blank" rel="noopener" class="nav-link tnt-section-balanced-family">Balanced Family</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/source/"  class="nav-link tnt-section-source">SOURCE</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="http://digital.olivesoftware.com/Olive/APA/ClevelandJewishNewsFree/default.aspx"  target="_blank" rel="noopener" class="nav-link tnt-section-archive ">Archive</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/classifieds"  class="nav-link tnt-section-classifieds ">Classifieds</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/cjn_foundation/"  class="nav-link tnt-section-cjn-foundation ">CJN Foundation</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/site/forms/subscription_services"  class="nav-link tnt-section-subscribe ">Subscribe</a>
                        </div>
                    </div></div></div></div>
                
                
                <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "></div>
            </aside>
        
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    
    
    
    
    <div id="tncms-region-global-skyline" class="tncms-region "></div>
    

    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-1164775" class="tncms-block"><section id="block-1164775" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow"  >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/d8c6efa2-ed88-11ec-81b1-7390a41b3c8e.jpg?resize=150%2C37 150w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/d8c6efa2-ed88-11ec-81b1-7390a41b3c8e.jpg?resize=200%2C49 200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/d8c6efa2-ed88-11ec-81b1-7390a41b3c8e.jpg?resize=225%2C55 225w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/d8c6efa2-ed88-11ec-81b1-7390a41b3c8e.jpg?resize=300%2C73 300w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/d8c6efa2-ed88-11ec-81b1-7390a41b3c8e.jpg?resize=400%2C98 400w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/d8c6efa2-ed88-11ec-81b1-7390a41b3c8e.jpg?resize=540%2C132 540w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/d8c6efa2-ed88-11ec-81b1-7390a41b3c8e.jpg?resize=640%2C156 640w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/d8c6efa2-ed88-11ec-81b1-7390a41b3c8e.jpg?resize=750%2C183 750w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/d8c6efa2-ed88-11ec-81b1-7390a41b3c8e.jpg 990w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="757"
                height="185"
                alt=""
                aria-hidden="true"></a></div></section></div></div></div>
    <div id="masthead-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-1164782" class="tncms-block"><section id="block-1164782" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-1164782" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-1164782" aria-label="Site search" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        <input type="hidden" name="s" value="start_time">
        <input type="hidden" name="sd" value="desc">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div id="site-search-form-1164782" class="site-search-form input-group pull-right normal form-control">
        <label for="site-search-1164782-term" class="sr-only">Site search</label>
        <input id="site-search-1164782-term" name="q" title="Site search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1164782-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
                <span id="site-search-button-1164782" class="hidden-xs hidden-sm sr-only">Search</span>
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section></div></div></div>
    <div id="masthead-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-1304428" class="tncms-block"><section id="block-1304428" class="block emphasis-h3   " ><h4 align=right> <a href="/site/forms/subscription_services/" style="color:red"> Subscribe </h4> </a>
<h4 align=right> <a href="/digital/" style="color:blue"> Sign-in or Register </h4> </a>
<h4 align=right> <a href="/site/contact.html"> Contact Us </h4></a></section></div><div id="tncms-block-1487008" class="tncms-block"><div style="float:right;">
<a href="http://www.chabad.org/calendar/candleLighting_cdo/locationId/125/locationType/1/jewish/Candle-Lighting.htm">
Candlelighting times
</a>
</div></div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" aria-label="Main" class="navbar yamm navbar-default container navbar-static">
                
                
                <div class="navbar-header">
                    
                    
                        <button type="button" class=" visible-sm visible-xs navbar-toggle pull-left" data-toggle="offcanvas" data-target="left" aria-label="Left Main Menu" aria-expanded="false">
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            
                        </button>
                         
                    
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_left_menu_right_search">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-1164776" class="tncms-block"><section id="block-1164776" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow"  >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/c650466e-b303-11e5-b98f-7b1efa83337d.png?resize=150%2C25 150w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/c650466e-b303-11e5-b98f-7b1efa83337d.png?resize=200%2C34 200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/c650466e-b303-11e5-b98f-7b1efa83337d.png?resize=225%2C38 225w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/c650466e-b303-11e5-b98f-7b1efa83337d.png?resize=300%2C51 300w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/c650466e-b303-11e5-b98f-7b1efa83337d.png 400w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="372"
                height="63"
                alt=""
                aria-hidden="true"></a></div></section></div></div>
                            
                        </div>
                    

                    
                        <ul class="hidden-md hidden-lg nav navbar-nav pull-right site-search-full-mobile">
                            <li class="search-form-dropdown dropdown yamm-fw">
                                <a class="dropdown-toggle" data-toggle="dropdown" aria-label="Search">
                                    <span class="fas tnt-search"></span>
                                </a>
                                <ul class="dropdown-menu">
                                    <li>
                                        <form action="/search/" method="GET" class="yamm-content">
                                            <input type="hidden" name="l" value="25">
                                            <input type="hidden" name="sd" value="desc">
                                            <input type="hidden" name="s" value="start_time">
                                            <input type="hidden" name="f" value="html">
                                            <input type="hidden" name="t" value="article,video,youtube,collection">
                                            <div class="input-group">
                                                <input name="q" type="text" placeholder="Search..." title="Site Search" class="form-control" autocomplete="off">
                                                <input type="submit" class="hide" value="Search">
                                                <span class="input-group-btn">
                                                    <button class="btn btn-default site-search-btn" type="submit">
                                                        Search
                                                    </button>
                                                </span>
                                            </div>
                                            <div class="clearfix"></div>
                                        </form>
                                    </li>
                                </ul>
                            </li>
                        </ul>
                        <script>
                            $('.site-search-full-mobile button[type="submit"]').on(__tnt.client.clickEvent, function(){
                                $('.site-search-full-mobile form').submit();
                                return false;
                            });
                        </script>
                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-1164801" class="tncms-block weather-min-height"><div id="weather-1164801" class="weather-current size-small pull-right">
    <ul class="list-unstyled">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=44122" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250" aria-label="Weather">
                <span class="icon pull-left">
                    
                        <span class="pull-left btn btn-xs btn-danger weather-alert-btn" data-toggle="tooltip" data-placement="right" title="Weather Alert"><i class="fas tnt-exclamation-triangle"></i></span>
                    
                    <span class="fas tnt-wi-cloudy"></span>
                </span>
                <span class="pull-left temp-desc small">
                    <span class="temp">77&deg;</span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li role="presentation">
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather Zip Code" value="44122">
                                <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a id="weather_zip_toggle_1164801" class="pull-right zip-update-link" aria-label="weather_zip_toggle"><span class="fas tnt-cog"></span></a><h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Beachwood, OH
                                
                                <small>(44122)</small>
                            </h4><h5>Today</h5>
                                <p>Thunderstorms during the evening will give way to partly cloudy skies after midnight. Gusty winds and small hail are possible. Low 61F. Winds N at 5 to 10 mph. Chance of rain 80%..
                                </p>
                                <h5>Tonight</h5>
                                <p>Thunderstorms during the evening will give way to partly cloudy skies after midnight. Gusty winds and small hail are possible. Low 61F. Winds N at 5 to 10 mph. Chance of rain 80%.</p>
                                <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: July 13, 2022 @ 4:24 pm</small></p></div>
                    </li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem" class="forecast-link text-center">
                        <a href="/weather/?weather_zip=44122"><i class="fas tnt-caret-right"></i> Full Forecast</a>
                    </li>
                </ul>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li class="dropdown yamm-fw span-class-fas-tnt-home-span">
                <a class="dropdown-toggle nav-link tnt-section-span-class-fas-tnt-home-span" data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250" href="/" ><span class="fas tnt-home"></span>
                        
                            <b class="caret"></b>
                        
                    
                </a><ul class="dropdown-menu">
                        <li>
                            <div class="yamm-content"><div id="tncms-region-mega-nav-top" class="tncms-region "></div><div class="row">
                                    <div class="col-sm-2">
                                        <ul class="list-unstyled"><li>
                                                    <a class="nav-link tnt-section-about-us" href="/site/about.html" >About Us</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-advertise" href="/site/advertise" >Advertise</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-contact-us" href="/site/contact.html" >Contact Us</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-lifecycle-and-subscriber-forms" href="/site/forms" >Lifecycle and Subscriber Forms</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-sign-up-for-email-newsletters" href="/esignup/" >Sign up for Email Newsletters</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-employment" href="/employment/" >Employment</a>
                                                </li></ul>
                                    </div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-one" class="tncms-region "></div></div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-two" class="tncms-region "></div></div>
                                </div><div id="tncms-region-mega-nav-bottom" class="tncms-region "></div></div>
                        </li>
                    </ul></li><li class="dropdown yamm-fw news">
                <a class="dropdown-toggle nav-link tnt-section-news" data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250" href="/news" >News
                        
                            <b class="caret"></b>
                        
                    
                </a><ul class="dropdown-menu">
                        <li>
                            <div class="yamm-content"><div id="tncms-region-mega-nav-news-top" class="tncms-region "></div><div class="row">
                                    <div class="col-sm-2">
                                        <ul class="list-unstyled"><li>
                                                    <a class="nav-link tnt-section-local-news" href="/news/local_news/" >Local News</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-national-news" href="/news/national_news/" >National News</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-world-news" href="/news/world_news/" >World News</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-stronger-than-hate" href="/stronger_than_hate/" >Stronger than hate</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-culture" href="/news/culture/" >Culture</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-theater" href="/news/culture/theater/" >Theater</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-sports" href="/news/sports/" >Sports</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-briefs" href="/news/briefs" >Briefs</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-18-difference-makers" href="/differencemakers/" >18 Difference Makers</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-12-under-36" href="/12_under_36/" >12 Under 36</a>
                                                </li></ul>
                                    </div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-news-one" class="tncms-region "><div id="tncms-block-1181303" class="tncms-block"><section id="block-1181303" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1181303 ">
        <div class="block-title-inner">
            <h4>
                
                Top Story
                
            </h4>
        </div>
    </div></div>
    
    <div class="card-img-md card-compact">
        
                
                <article id="card-summary-1181303-e02f325e-3bee-5039-a871-c9ad50a9de80" class="tnt-asset-type-article clearfix card summary has-image image-left inherit letterbox-style-default  tnt-section-news tnt-sub-section-national-news">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-e02f325e-3bee-5039-a871-c9ad50a9de80 media-preview article-asset " data-aspect="original"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/national_news/biden-delivers-tough-talk-on-iran-as-he-opens-mideast-visit/article_e02f325e-3bee-5039-a871-c9ad50a9de80.html" class="tnt-asset-link"  aria-label="Biden delivers tough talk on Iran as he opens Mideast visit">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Biden delivers tough talk on Iran as he opens Mideast visit"
                            class="img-responsive lazyload ap-photo full default"
                            width="1763"
                            height="1175"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/2/25/225db38b-a77e-5426-b165-d2cc50243a4d/62ceeca8a281b.image.jpg?resize=150%2C100 150w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/2/25/225db38b-a77e-5426-b165-d2cc50243a4d/62ceeca8a281b.image.jpg?resize=200%2C133 200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/2/25/225db38b-a77e-5426-b165-d2cc50243a4d/62ceeca8a281b.image.jpg?resize=225%2C150 225w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/2/25/225db38b-a77e-5426-b165-d2cc50243a4d/62ceeca8a281b.image.jpg?resize=300%2C200 300w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/2/25/225db38b-a77e-5426-b165-d2cc50243a4d/62ceeca8a281b.image.jpg?resize=400%2C267 400w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/2/25/225db38b-a77e-5426-b165-d2cc50243a4d/62ceeca8a281b.image.jpg?resize=540%2C360 540w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/2/25/225db38b-a77e-5426-b165-d2cc50243a4d/62ceeca8a281b.image.jpg?resize=640%2C427 640w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/2/25/225db38b-a77e-5426-b165-d2cc50243a4d/62ceeca8a281b.image.jpg?resize=750%2C500 750w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/2/25/225db38b-a77e-5426-b165-d2cc50243a4d/62ceeca8a281b.image.jpg?resize=990%2C660 990w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/2/25/225db38b-a77e-5426-b165-d2cc50243a4d/62ceeca8a281b.image.jpg?resize=1035%2C690 1035w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/2/25/225db38b-a77e-5426-b165-d2cc50243a4d/62ceeca8a281b.image.jpg?resize=1200%2C800 1200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/2/25/225db38b-a77e-5426-b165-d2cc50243a4d/62ceeca8a281b.image.jpg?resize=1333%2C888 1333w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/2/25/225db38b-a77e-5426-b165-d2cc50243a4d/62ceeca8a281b.image.jpg?resize=1476%2C984 1476w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/2/25/225db38b-a77e-5426-b165-d2cc50243a4d/62ceeca8a281b.image.jpg?resize=1763%2C1175 2008w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body">
        <div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/news/national_news/biden-delivers-tough-talk-on-iran-as-he-opens-mideast-visit/article_e02f325e-3bee-5039-a871-c9ad50a9de80.html" class="tnt-asset-link" aria-label="Biden delivers tough talk on Iran as he opens Mideast visit">
        

        
            Biden delivers tough talk on Iran as he opens Mideast visit</a></h3></div>
    
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">President Joe Biden has opened a Mideast visit by offering anxious Israeli leaders strong reassurances of his determination to stop Iran’s nuclear program. Biden said he'd be willing to use force “as a last resort.” The president’s comments came in an interview aired Wednesday with Israel’s Channel 12 as Biden opened a four-day visit to the region. The U.S. and Israel are expected to unveil a joint declaration on Thursday cementing their close military ties and strengthening past calls to take military action against Iran’s growing nuclear program. Israel has said both countries would commit to “using all elements of their national power against the Iranian nuclear threat.”</p>
                            </div>
                        
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div></div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-news-two" class="tncms-region "><div id="tncms-block-1181304" class="tncms-block"><section id="block-1181304" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1181304 ">
        <div class="block-title-inner">
            <h4>
                
                More Headlines
                
            </h4>
        </div>
    </div></div>
    
    <div class="card-img-md card-compact">
        
                
                <article id="card-summary-1181304-9d5f71b2-0d98-52da-8306-8e439205e18d" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-news tnt-sub-section-state">
            <div class="card-container">
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/news/state/man-charged-with-rape-of-girl-10-who-traveled-for-abortion/article_9d5f71b2-0d98-52da-8306-8e439205e18d.html" class="tnt-asset-link" aria-label="Man charged with rape of girl, 10, who traveled for abortion">
        

        
            Man charged with rape of girl, 10, who traveled for abortion</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1181304-06dc80ce-02d7-11ed-9d65-ab1857ccdb4c" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-news tnt-sub-section-local-news">
            <div class="card-container">
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/news/local_news/picketers-seek-higher-wages-safe-staffing-respect-from-menorah-park/article_06dc80ce-02d7-11ed-9d65-ab1857ccdb4c.html" class="tnt-asset-link" aria-label="Picketers seek higher wages, safe staffing, respect from Menorah Park">
        

        
            Picketers seek higher wages, safe staffing, respect from Menorah Park</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1181304-9c5ae6cd-3440-51aa-b4b1-d4b56a75e3d4" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-news tnt-sub-section-local-news">
            <div class="card-container">
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/news/local_news/jayland-walkers-funeral-follows-days-of-protest-in-akron/article_9c5ae6cd-3440-51aa-b4b1-d4b56a75e3d4.html" class="tnt-asset-link" aria-label="Jayland Walker's funeral follows days of protest in Akron">
        

        
            Jayland Walker's funeral follows days of protest in Akron</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1181304-1b212b14-4462-58cc-9d18-a189b257a1bc" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-news tnt-sub-section-national-news">
            <div class="card-container">
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/news/national_news/amid-covid-worries-fist-bumps-for-biden-with-exceptions/article_1b212b14-4462-58cc-9d18-a189b257a1bc.html" class="tnt-asset-link" aria-label="Amid COVID worries, fist bumps for Biden — with exceptions">
        

        
            Amid COVID worries, fist bumps for Biden — with exceptions</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div></div>
                                </div><div id="tncms-region-mega-nav-news-bottom" class="tncms-region "></div></div>
                        </li>
                    </ul></li><li>
                <a href="/coronavirus/" class="nav-link tnt-section-covid-19" >COVID-19
                </a></li><li class="dropdown yamm-fw features">
                <a class="dropdown-toggle nav-link tnt-section-features" data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250" href="/features" >Features
                        
                            <b class="caret"></b>
                        
                    
                </a><ul class="dropdown-menu">
                        <li>
                            <div class="yamm-content"><div id="tncms-region-mega-nav-features-top" class="tncms-region "></div><div class="row">
                                    <div class="col-sm-2">
                                        <ul class="list-unstyled"><li>
                                                    <a class="nav-link tnt-section-business" href="/features/business" >Business</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-camps" href="/features/camps/" >Camps</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-cjn-tv" href="/features/multimedia/" >CJN TV</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-education" href="/features/special_sections/education/" >Education</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-health" href="/features/health" >Health</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-holidays" href="/features/holidays/" >Holidays</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-nosh" href="/features/nosh/" >Nosh</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-religious-life" href="/features/religious_life/" >Religious Life</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-silver-linings" href="/features/silver_linings/" >Silver Linings</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-special-sections" href="/features/special_sections/" >Special Sections</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-unfiltered" href="/unfiltered/" >UNFILTERED</a>
                                                </li></ul>
                                    </div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-features-one" class="tncms-region "><div id="tncms-block-1181305" class="tncms-block"><section id="block-1181305" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1181305 ">
        <div class="block-title-inner">
            <h4>
                
                Top Story
                
            </h4>
        </div>
    </div></div>
    
    <div class="card-img-md card-compact">
        
                
                <article id="card-summary-1181305-b24ec766-020d-11ed-9285-e36ea7069608" class="tnt-asset-type-article clearfix card summary has-image image-left inherit letterbox-style-default  tnt-section-features tnt-sub-section-special-sections tnt-sub-section-destination">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-b24ec766-020d-11ed-9285-e36ea7069608 media-preview article-asset " data-aspect="original"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/features/special_sections/destination/sir-troy-s-toy-kingdom-brings-out-the-child-in-everyone/article_b24ec766-020d-11ed-9285-e36ea7069608.html" class="tnt-asset-link"  aria-label="Sir Troy’s Toy Kingdom brings out the child in everyone">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Sir Troy’s Toy Kingdom brings out the child in everyone"
                            class="img-responsive lazyload full default"
                            width="1144"
                            height="1104"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/a/ad/aad41b44-020d-11ed-bac6-cffe18d7eaa9/62cdb8ac36515.image.jpg?crop=1144%2C1104%2C64%2C21&resize=150%2C145&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/a/ad/aad41b44-020d-11ed-bac6-cffe18d7eaa9/62cdb8ac36515.image.jpg?crop=1144%2C1104%2C64%2C21&resize=200%2C193&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/a/ad/aad41b44-020d-11ed-bac6-cffe18d7eaa9/62cdb8ac36515.image.jpg?crop=1144%2C1104%2C64%2C21&resize=225%2C217&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/a/ad/aad41b44-020d-11ed-bac6-cffe18d7eaa9/62cdb8ac36515.image.jpg?crop=1144%2C1104%2C64%2C21&resize=300%2C290&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/a/ad/aad41b44-020d-11ed-bac6-cffe18d7eaa9/62cdb8ac36515.image.jpg?crop=1144%2C1104%2C64%2C21&resize=400%2C386&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/a/ad/aad41b44-020d-11ed-bac6-cffe18d7eaa9/62cdb8ac36515.image.jpg?crop=1144%2C1104%2C64%2C21&resize=540%2C521&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/a/ad/aad41b44-020d-11ed-bac6-cffe18d7eaa9/62cdb8ac36515.image.jpg?crop=1144%2C1104%2C64%2C21&resize=640%2C618&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/a/ad/aad41b44-020d-11ed-bac6-cffe18d7eaa9/62cdb8ac36515.image.jpg?crop=1144%2C1104%2C64%2C21&resize=750%2C724&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/a/ad/aad41b44-020d-11ed-bac6-cffe18d7eaa9/62cdb8ac36515.image.jpg?crop=1144%2C1104%2C64%2C21&resize=990%2C955&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/a/ad/aad41b44-020d-11ed-bac6-cffe18d7eaa9/62cdb8ac36515.image.jpg?crop=1144%2C1104%2C64%2C21&resize=1035%2C999&order=crop%2Cresize 1035w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/a/ad/aad41b44-020d-11ed-bac6-cffe18d7eaa9/62cdb8ac36515.image.jpg?crop=1144%2C1104%2C64%2C21&resize=1144%2C1104&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body">
        <div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/features/special_sections/destination/sir-troy-s-toy-kingdom-brings-out-the-child-in-everyone/article_b24ec766-020d-11ed-9285-e36ea7069608.html" class="tnt-asset-link" aria-label="Sir Troy’s Toy Kingdom brings out the child in everyone">
        

        
            Sir Troy’s Toy Kingdom brings out the child in everyone</a></h3></div>
    
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">Many people have fond childhood memories of visiting toy stores. After the closing of most corporate toy stores nationwide, many of today’s children have never experienced the rush of running in and finding the perfect item to take home and play with. A new local store came to Solon last yea&hellip;</p>
                            </div>
                        
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div></div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-features-two" class="tncms-region "><div id="tncms-block-1181306" class="tncms-block"><section id="block-1181306" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1181306 ">
        <div class="block-title-inner">
            <h4>
                
                More Headlines
                
            </h4>
        </div>
    </div></div>
    
    <div class="card-img-md card-compact">
        
                
                <article id="card-summary-1181306-987003e4-fe0e-11ec-9350-83b718038793" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-features tnt-sub-section-nosh">
            <div class="card-container">
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/features/nosh/new-starbucks-open-in-south-euclid/article_987003e4-fe0e-11ec-9350-83b718038793.html" class="tnt-asset-link" aria-label="New Starbucks open in South Euclid">
        

        
            New Starbucks open in South Euclid</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1181306-e35750d4-fe12-11ec-a7e2-67c82b21c4ba" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-features tnt-sub-section-special-sections tnt-sub-section-senior-living">
            <div class="card-container">
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/features/special_sections/senior_living/social-security-benefits-key-in-preventing-seniors-from-lacking-enough-quality-food/article_e35750d4-fe12-11ec-a7e2-67c82b21c4ba.html" class="tnt-asset-link" aria-label="Social Security benefits key in preventing seniors from lacking enough quality food">
        

        
            Social Security benefits key in preventing seniors from lacking enough quality food</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1181306-10c9e832-020b-11ed-812c-576aacc49913" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-news tnt-sub-section-local-news">
            <div class="card-container">
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/news/local_news/university-hospitals-awarded-20k-for-music-based-study/article_10c9e832-020b-11ed-812c-576aacc49913.html" class="tnt-asset-link" aria-label="University Hospitals awarded $20K for music-based study">
        

        
            University Hospitals awarded $20K for music-based study</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1181306-4e0b7dcc-0220-11ed-a9f4-73aefed1004b" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-features tnt-sub-section-nosh">
            <div class="card-container">
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/features/nosh/slyman-s-in-pinecrest-closed-no-new-location-currently-planned/article_4e0b7dcc-0220-11ed-a9f4-73aefed1004b.html" class="tnt-asset-link" aria-label="Slyman’s in Pinecrest closed, no new location currently planned">
        

        
            Slyman’s in Pinecrest closed, no new location currently planned</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div></div>
                                </div><div id="tncms-region-mega-nav-features-bottom" class="tncms-region "></div></div>
                        </li>
                    </ul></li><li class="dropdown yamm-fw opinion">
                <a class="dropdown-toggle nav-link tnt-section-opinion" data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250" href="/opinion" >Opinion
                        
                            <b class="caret"></b>
                        
                    
                </a><ul class="dropdown-menu">
                        <li>
                            <div class="yamm-content"><div id="tncms-region-mega-nav-opinion-top" class="tncms-region "></div><div class="row">
                                    <div class="col-sm-2">
                                        <ul class="list-unstyled"><li>
                                                    <a class="nav-link tnt-section-cjn-columnists" href="/columnists/" >CJN Columnists</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-guest-columns" href="/opinion/guest_columns/" >Guest Columns</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-letters-to-the-editor" href="/opinion/letters_to_editor/" >Letters to the Editor</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-op-eds" href="/opinion/op-eds/" >Op-Eds</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-polls" href="/opinion/polls" >Polls</a>
                                                </li></ul>
                                    </div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-opinion-one" class="tncms-region "><div id="tncms-block-1220932" class="tncms-block"><section id="block-1220932" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1220932 ">
        <div class="block-title-inner">
            <h4>
                
                Top Story
                
            </h4>
        </div>
    </div></div>
    
    <div class="card-img-md card-compact">
        
                
                <article id="card-summary-1220932-6fb0c844-0214-11ed-8c92-e39f5ec5cd80" class="tnt-asset-type-article clearfix card summary has-image image-left inherit letterbox-style-default  tnt-section-columnists tnt-sub-section-cliff-savren">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-6fb0c844-0214-11ed-8c92-e39f5ec5cd80 media-preview article-asset " data-aspect="original"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/columnists/cliff_savren/israel-needs-to-look-beyond-netanyahu-in-next-election/article_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html" class="tnt-asset-link"  aria-label="Israel needs to look beyond Netanyahu in next election">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Israel needs to look beyond Netanyahu in next election"
                            class="img-responsive lazyload full default"
                            width="880"
                            height="495"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/d/2d/d2dc9a30-fc54-11ec-bbce-e7560342f71a/62c41f34bd51e.image.jpg?resize=150%2C84 150w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/d/2d/d2dc9a30-fc54-11ec-bbce-e7560342f71a/62c41f34bd51e.image.jpg?resize=200%2C113 200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/d/2d/d2dc9a30-fc54-11ec-bbce-e7560342f71a/62c41f34bd51e.image.jpg?resize=225%2C127 225w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/d/2d/d2dc9a30-fc54-11ec-bbce-e7560342f71a/62c41f34bd51e.image.jpg?resize=300%2C169 300w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/d/2d/d2dc9a30-fc54-11ec-bbce-e7560342f71a/62c41f34bd51e.image.jpg?resize=400%2C225 400w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/d/2d/d2dc9a30-fc54-11ec-bbce-e7560342f71a/62c41f34bd51e.image.jpg?resize=540%2C304 540w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/d/2d/d2dc9a30-fc54-11ec-bbce-e7560342f71a/62c41f34bd51e.image.jpg?resize=640%2C360 640w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/d/2d/d2dc9a30-fc54-11ec-bbce-e7560342f71a/62c41f34bd51e.image.jpg?resize=750%2C422 750w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/d/2d/d2dc9a30-fc54-11ec-bbce-e7560342f71a/62c41f34bd51e.image.jpg?resize=880%2C495 990w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body">
        <div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/columnists/cliff_savren/israel-needs-to-look-beyond-netanyahu-in-next-election/article_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html" class="tnt-asset-link" aria-label="Israel needs to look beyond Netanyahu in next election">
        

        
            Israel needs to look beyond Netanyahu in next election</a></h3></div>
    
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">Israel has a new prime minister, Yair Lapid, who will serve until after elections Nov. 1. If recent experience is any guide, he will also serve well beyond that, either after winning the election or staying in the job if the result is another stalemate. </p>
                            </div>
                        
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div></div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-opinion-two" class="tncms-region "><div id="tncms-block-1220931" class="tncms-block"><section id="block-1220931" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1220931 ">
        <div class="block-title-inner">
            <h4>
                
                More Headlines
                
            </h4>
        </div>
    </div></div>
    
    <div class="card-img-md card-compact">
        
                
                <article id="card-summary-1220931-726718bc-020b-11ed-924a-e3a63e1fc58d" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-columnists tnt-sub-section-ben-cohen">
            <div class="card-container">
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/columnists/ben_cohen/banning-anti-zionism-feasible-desirable/article_726718bc-020b-11ed-924a-e3a63e1fc58d.html" class="tnt-asset-link" aria-label="Banning anti-Zionism: Feasible? Desirable?">
        

        
            Banning anti-Zionism: Feasible? Desirable?</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1220931-f8bfeb56-01f6-11ed-86c4-5b04d11b5819" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-columnists tnt-sub-section-regina-brett">
            <div class="card-container">
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/columnists/regina_brett/supreme-court-should-have-sacked-prayer-on-gridiron/article_f8bfeb56-01f6-11ed-86c4-5b04d11b5819.html" class="tnt-asset-link" aria-label="Supreme Court should have sacked prayer on gridiron">
        

        
            Supreme Court should have sacked prayer on gridiron</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1220931-4bc63d82-0224-11ed-b5cb-9faddd02a33e" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-columnists tnt-sub-section-hal-becker">
            <div class="card-container">
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/columnists/hal_becker/keep-using-zoom-for-business/article_4bc63d82-0224-11ed-b5cb-9faddd02a33e.html" class="tnt-asset-link" aria-label="Keep using Zoom for business">
        

        
            Keep using Zoom for business</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1220931-694d6fba-fe0f-11ec-bb65-e39561a0a776" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-opinion tnt-sub-section-guest-columns tnt-sub-section-matthew-levy">
            <div class="card-container">
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/opinion/guest_columns/matthew_levy/frequent-texting-can-lead-to-thumb-pain-arthritis/article_694d6fba-fe0f-11ec-bb65-e39561a0a776.html" class="tnt-asset-link" aria-label="Frequent texting can lead to thumb pain, arthritis">
        

        
            Frequent texting can lead to thumb pain, arthritis</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div></div>
                                </div><div id="tncms-region-mega-nav-opinion-bottom" class="tncms-region "></div></div>
                        </li>
                    </ul></li><li class="dropdown yamm-fw community">
                <a class="dropdown-toggle nav-link tnt-section-community" data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250" href="/community/" >Community
                        
                            <b class="caret"></b>
                        
                    
                </a><ul class="dropdown-menu">
                        <li>
                            <div class="yamm-content"><div id="tncms-region-mega-nav-community-top" class="tncms-region "></div><div class="row">
                                    <div class="col-sm-2">
                                        <ul class="list-unstyled"><li>
                                                    <a class="nav-link tnt-section-lifecycles" href="/community/lifecycles/" >Lifecycles</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-in-the-community" href="/community/community_scene/" >In the Community</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-the-city" href="/community/the_city/" >The City</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-18-difference-makers" href="/differencemakers/" >18 Difference Makers</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-my-israel" href="/community/my_israel/" >My Israel</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-circle-of-life" href="/community/circle_of_life/" >Circle of Life</a>
                                                </li></ul>
                                    </div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-community-one" class="tncms-region "><div id="tncms-block-1181307" class="tncms-block"><section id="block-1181307" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1181307 ">
        <div class="block-title-inner">
            <h4>
                
                Top Story
                
            </h4>
        </div>
    </div></div>
    
    <div class="card-img-md card-compact">
        
                
                <article id="card-summary-1181307-b7e30086-0224-11ed-a9ca-038f341aba45" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-community tnt-sub-section-lifecycles tnt-sub-section-obituaries">
            <div class="card-container">
                
                <div class="card-body">
        <div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/community/lifecycles/obituaries/aronov-yuriy/article_b7e30086-0224-11ed-a9ca-038f341aba45.html" class="tnt-asset-link" aria-label="Aronov, Yuriy">
        

        
            Aronov, Yuriy</a></h3></div>
    
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">Yuriy Aronov, 84, passed away surrounded by his family on July 10, 2022.</p><p>Arrangements under the direction of Cleveland Jewish Funerals.</p>
                            </div>
                        
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div></div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-community-two" class="tncms-region "><div id="tncms-block-1181308" class="tncms-block"><section id="block-1181308" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1181308 ">
        <div class="block-title-inner">
            <h4>
                
                More Headlines
                
            </h4>
        </div>
    </div></div>
    
    <div class="card-img-md card-compact">
        
                
                <article id="card-summary-1181308-f6a026f4-020c-11ed-8974-7b74971f92e3" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-community tnt-sub-section-lifecycles tnt-sub-section-obituaries">
            <div class="card-container">
                
                <div class="card-body"><div class="card-labels">
            
                
                <div class="card-label-section text-muted">
                    <a href="/community/lifecycles/obituaries" class="tnt-section-tag">Obituaries</a>
                </div>
            
            </div>
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/community/lifecycles/obituaries/turner-doris/article_f6a026f4-020c-11ed-8974-7b74971f92e3.html" class="tnt-asset-link" aria-label="Turner, Doris">
        

        
            Turner, Doris</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1181308-d78ca474-015b-11ed-a0ab-1f17296856fe" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-community tnt-sub-section-lifecycles tnt-sub-section-obituaries">
            <div class="card-container">
                
                <div class="card-body"><div class="card-labels">
            
                
                <div class="card-label-section text-muted">
                    <a href="/community/lifecycles/obituaries" class="tnt-section-tag">Obituaries</a>
                </div>
            
            </div>
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/community/lifecycles/obituaries/lewine-betty/article_d78ca474-015b-11ed-a0ab-1f17296856fe.html" class="tnt-asset-link" aria-label="Lewine, Betty">
        

        
            Lewine, Betty</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1181308-2401471c-015a-11ed-be23-eb930f0389b0" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-community tnt-sub-section-lifecycles tnt-sub-section-obituaries">
            <div class="card-container">
                
                <div class="card-body"><div class="card-labels">
            
                
                <div class="card-label-section text-muted">
                    <a href="/community/lifecycles/obituaries" class="tnt-section-tag">Obituaries</a>
                </div>
            
            </div>
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/community/lifecycles/obituaries/jacobson-donald/article_2401471c-015a-11ed-be23-eb930f0389b0.html" class="tnt-asset-link" aria-label="Jacobson, Donald">
        

        
            Jacobson, Donald</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1181308-d66cf894-fdf2-11ec-812e-2b4c3e764ac8" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-community tnt-sub-section-community-scene">
            <div class="card-container">
                
                <div class="card-body"><div class="card-labels">
            
                
                <div class="card-label-section text-muted">
                    <a href="/community/community_scene" class="tnt-section-tag">In the Community</a>
                </div>
            
            </div>
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/community/community_scene/hebrew-academy-of-cleveland-holds-mesiba-siddur/article_d66cf894-fdf2-11ec-812e-2b4c3e764ac8.html" class="tnt-asset-link" aria-label="Hebrew Academy of Cleveland holds Mesiba Siddur">
        

        
            Hebrew Academy of Cleveland holds Mesiba Siddur</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div></div>
                                </div><div id="tncms-region-mega-nav-community-bottom" class="tncms-region "></div></div>
                        </li>
                    </ul></li><li>
                <a href="/community/lifecycles/obituaries/" class="nav-link tnt-section-obituaries" >Obituaries
                </a></li><li class="dropdown yamm-fw events">
                <a class="dropdown-toggle nav-link tnt-section-events" data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250" href="/local-events/" >Events
                        
                            <b class="caret"></b>
                        
                    
                </a><ul class="dropdown-menu">
                        <li>
                            <div class="yamm-content"><div id="tncms-region-mega-nav-local-events-top" class="tncms-region "></div><div class="row">
                                    <div class="col-sm-2">
                                        <ul class="list-unstyled"><li>
                                                    <a class="nav-link tnt-section-events-calendar" href="/local-events/" >Events Calendar</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-promote-your-event" href="https://new.evvnt.com/?with_navbar&amp;force_snap_sell&amp;partner=CLEVELANDJEWISHNEWS&amp;publisher_url:clevelandjewishnews.com#/quick"  target="_blank" rel="noopener">Promote Your Event</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-18-difference-makers" href="/differencemakers/" >18 Difference Makers</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-women-in-leadership" href="/wil/" >Women in Leadership</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-12-under-36" href="/12under36/" >12 Under 36</a>
                                                </li></ul>
                                    </div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-local-events-one" class="tncms-region "></div></div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-local-events-two" class="tncms-region "></div></div>
                                </div><div id="tncms-region-mega-nav-local-events-bottom" class="tncms-region "></div></div>
                        </li>
                    </ul></li><li>
                <a href="https://cjn.newzware.com/ss70v2/cjn/common/template.jsp" class="nav-link tnt-section-current-issue"  target="_blank" rel="noopener">Current Issue
                </a></li><li class="dropdown yamm-fw magazines">
                <a class="dropdown-toggle nav-link tnt-section-magazines" data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250" href="/magazines/" >Magazines
                        
                            <b class="caret"></b>
                        
                    
                </a><ul class="dropdown-menu">
                        <li>
                            <div class="yamm-content"><div id="tncms-region-mega-nav-magazines-top" class="tncms-region "></div><div class="row">
                                    <div class="col-sm-2">
                                        <ul class="list-unstyled"><li>
                                                    <a class="nav-link tnt-section-bar-bat-mitzvah" href="/magazines/bar_bat/" >Bar•Bat Mitzvah</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-jstyle" href="http://jstylemagazine.com"  target="_blank" rel="noopener">Jstyle</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-canvas" href="http://canvascle.com/"  target="_blank" rel="noopener">Canvas</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-balanced-family" href="http://www.balancedmag.com"  target="_blank" rel="noopener">Balanced Family</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-source" href="/source/" >SOURCE</a>
                                                </li></ul>
                                    </div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-magazines-one" class="tncms-region "></div></div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-magazines-two" class="tncms-region "></div></div>
                                </div><div id="tncms-region-mega-nav-magazines-bottom" class="tncms-region "></div></div>
                        </li>
                    </ul></li><li>
                <a href="http://digital.olivesoftware.com/Olive/APA/ClevelandJewishNewsFree/default.aspx" class="nav-link tnt-section-archive"  target="_blank" rel="noopener">Archive
                </a></li><li>
                <a href="/classifieds" class="nav-link tnt-section-classifieds" >Classifieds
                </a></li><li>
                <a href="/cjn_foundation/" class="nav-link tnt-section-cjn-foundation" >CJN Foundation
                </a></li><li>
                <a href="/site/forms/subscription_services" class="nav-link tnt-section-subscribe" >Subscribe
                </a></li></ul>
    </div>
                        </div>
                    </div>
                

                
            </nav>
            
        <div class="visible-xs pull-right article-share-nav" style="background-color: #000000">
            <span>Share This <i class="fas tnt-arrow-right"></i></span>
            
    <ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link">
         
            <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fcolumnists%2Fcliff_savren%2Fisrael-needs-to-look-beyond-netanyahu-in-next-election%2Farticle_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="fb" target="_blank" title="Share on Facebook" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/columnists/cliff_savren/israel-needs-to-look-beyond-netanyahu-in-next-election/article_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":6fb0c844-0214-11ed-8c92-e39f5ec5cd80}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
            
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link">
            <a href="https://twitter.com/intent/tweet?&text=Israel%20needs%20to%20look%20beyond%20Netanyahu%20in%20next%20election&via=CleveJN&url=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fcolumnists%2Fcliff_savren%2Fisrael-needs-to-look-beyond-netanyahu-in-next-election%2Farticle_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tw" target="_blank" title="Tweet" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/columnists/cliff_savren/israel-needs-to-look-beyond-netanyahu-in-next-election/article_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":6fb0c844-0214-11ed-8c92-e39f5ec5cd80}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link">
            <a href="mailto:?subject=%5BCleveland%20Jewish%20News%5D%20Israel%20needs%20to%20look%20beyond%20Netanyahu%20in%20next%20election&body=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fcolumnists%2Fcliff_savren%2Fisrael-needs-to-look-beyond-netanyahu-in-next-election%2Farticle_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="em email-share-link" title="Email" data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":6fb0c844-0214-11ed-8c92-e39f5ec5cd80}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                
                <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/columnists/cliff_savren/israel-needs-to-look-beyond-netanyahu-in-next-election/article_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":6fb0c844-0214-11ed-8c92-e39f5ec5cd80}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li></ul>
    <form method="post" data-uuid="6fb0c844-0214-11ed-8c92-e39f5ec5cd80" class="save-list-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="6fb0c844-0214-11ed-8c92-e39f5ec5cd80" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

        </div>
            
        </div>
        
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "><div id="tncms-block-1164737" class="tncms-block"></div><div id="tncms-block-1219176" class="tncms-block"></div><div id="tncms-block-1227125" class="tncms-block"></div></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12">
                    <div id="tncms-region-asset_container_top" class="tncms-region "></div> 
                </div>
            
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "></div></div>
            
            
            <div class="col-md-9"><div id="tncms-region-global-advertise-container-left" class="tncms-region "><div id="tncms-block-1543627" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1543627" class="tnt-ads dfp-ad" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1543627');
                        googletag.pubads().refresh([gptAdSlots['ad-1543627']]);
                });
            </script>
        </div>
    </div>
</div></div></div>
            <div class="col-md-3"><div id="tncms-region-global-advertise-container-right" class="tncms-region "><div id="tncms-block-1543632" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1543632" class="tnt-ads dfp-ad" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1543632');
                        googletag.pubads().refresh([gptAdSlots['ad-1543632']]);
                });
            </script>
        </div>
    </div>
</div></div></div>
            <div class="col-md-12"><div id="tncms-region-global-advertise-container-bottom" class="tncms-region "><div id="tncms-block-1164779" class="tncms-block"><section id="block-1164779" class="block emphasis-h3   " ><div class="heading card">
    
    
        
        <ol class="breadcrumb  pull-right" itemscope itemtype="https://schema.org/BreadcrumbList"><li itemprop="itemListElement" itemscope
      itemtype="https://schema.org/ListItem">
                    <a href="/" itemprop="item">
                        <span itemprop="name">Home</span>
                    </a>
                    <meta itemprop="position" content="1" />
                </li><li itemprop="itemListElement" itemscope
      itemtype="https://schema.org/ListItem">
                    <a href="/columnists/" itemprop="item">
                        <span itemprop="name">CJN Columnists</span>
                    </a>
                    <meta itemprop="position" content="2" />
                </li><li class="active" itemprop="itemListElement" itemscope
      itemtype="https://schema.org/ListItem">
                    <a href="/columnists/cliff_savren/" itemprop="item">
                        <span itemprop="name">Cliff Savren</span>
                    </a>
                    <meta itemprop="position" content="3" />
                </li></ol>
    
    <div class="clearfix">
    
    <div class="block-title title-1164779 ">
        <div class="block-title-inner">
            <h3>
                
                    <a href="/columnists/cliff_savren">
                
                Cliff Savren
                
                    </a>
                
            </h3>
        </div>
    </div></div>
    
</div></section></div></div></div>
            
        </div><div class="modal fullscreen" id="photo-carousel-6fb0c844-0214-11ed-8c92-e39f5ec5cd80" tabindex="-1" role="dialog" aria-labelledby="photo-carousel-6fb0c844-0214-11ed-8c92-e39f5ec5cd80" aria-hidden="true">
        <div class="modal-dialog modal-lg">
            <div class="modal-content">
                <div class="modal-body">
                    <button type="button" class="close" data-dismiss="modal">
                        <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                        <span class="sr-only">Close</span>
                    </button>
                    
    <div id="carousel-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-photo-modal" class="card photo-carousel    subscriber-hide letterbox-style-default">
            
            <div class="photo-carousel-control-container">
                    <span class="photo-count">
                        <span class="current-count">1</span> of 2
                    </span>
                    <a class="photo-carousel-control left noselect hidden-print"><span class="control-left fas tnt-chevron-left"></span></a>
                    <a class="photo-carousel-control right noselect hidden-print"><span class="control-left fas tnt-chevron-right"></span></a>
            </div>
            
            <div id="gallery-items-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-photo-modal" class="carousel-inner"><div  class="item photo-d2dc9a30-fc54-11ec-bbce-e7560342f71a">
                            <div class="item-container">
                                <div data-track-object='{"title":"Israel needs to look beyond Netanyahu in next election","url":"/columnists/cliff_savren/israel-needs-to-look-beyond-netanyahu-in-next-election/article_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html","uuid":"6fb0c844-0214-11ed-8c92-e39f5ec5cd80","app":"editorial","metric":""}'  data-count="1"  class="photo-container layout-horizontal"><div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                        
                                        
                                        
                                        
                <img
                    src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/d/2d/d2dc9a30-fc54-11ec-bbce-e7560342f71a/62c41f34bd51e.image.jpg"
                    
                    alt="Israeli Prime Minister Yair Lapid"
                    class="img-responsive owl-first-image owl-lazy default"
                    width="880"
                    height="495"
                    data-src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/d/2d/d2dc9a30-fc54-11ec-bbce-e7560342f71a/62c41f34bd51e.image.jpg" />
                                        
                                        
                                </div>
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-photo-modal" data-target=".caption-inner-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-photo-modal">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-photo-modal collapse in"><div class="caption-text"><p>Israeli Prime Minister Yair Lapid addresses the weekly Cabinet session, in Jerusalem, on July 3, 2022. </p></div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                        <li class="credit"><span  class="tnt-byline">Haim Zach/GPO</span></li>
                                    
                                
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        
    <ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link">
         
            <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fisraeli-prime-minister-yair-lapid%2Fimage_d2dc9a30-fc54-11ec-bbce-e7560342f71a.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="fb" target="_blank" title="Share on Facebook" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/israeli-prime-minister-yair-lapid/image_d2dc9a30-fc54-11ec-bbce-e7560342f71a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":d2dc9a30-fc54-11ec-bbce-e7560342f71a}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
            
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link">
            <a href="https://twitter.com/intent/tweet?&text=Israeli%20Prime%20Minister%20Yair%20Lapid&via=CleveJN&url=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fisraeli-prime-minister-yair-lapid%2Fimage_d2dc9a30-fc54-11ec-bbce-e7560342f71a.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tw" target="_blank" title="Tweet" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/israeli-prime-minister-yair-lapid/image_d2dc9a30-fc54-11ec-bbce-e7560342f71a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":d2dc9a30-fc54-11ec-bbce-e7560342f71a}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link">
            <a href="mailto:?subject=%5BCleveland%20Jewish%20News%5D%20Israeli%20Prime%20Minister%20Yair%20Lapid&body=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fisraeli-prime-minister-yair-lapid%2Fimage_d2dc9a30-fc54-11ec-bbce-e7560342f71a.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="em email-share-link" title="Email" data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":d2dc9a30-fc54-11ec-bbce-e7560342f71a}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                
                <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/israeli-prime-minister-yair-lapid/image_d2dc9a30-fc54-11ec-bbce-e7560342f71a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":d2dc9a30-fc54-11ec-bbce-e7560342f71a}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li></ul>
    <form method="post" data-uuid="d2dc9a30-fc54-11ec-bbce-e7560342f71a" class="save-list-d2dc9a30-fc54-11ec-bbce-e7560342f71a-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="d2dc9a30-fc54-11ec-bbce-e7560342f71a" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div><div  class="item photo-9c27d602-4770-11e6-91b0-03bf2e46ff19">
                            <div class="item-container">
                                <div data-track-object='{"title":"Israel needs to look beyond Netanyahu in next election","url":"/columnists/cliff_savren/israel-needs-to-look-beyond-netanyahu-in-next-election/article_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html","uuid":"6fb0c844-0214-11ed-8c92-e39f5ec5cd80","app":"editorial","metric":""}'  data-count="2"  class="photo-container layout-square"><div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                        
                                        
                                        
                                        
                <img
                    src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/9/c2/9c27d602-4770-11e6-91b0-03bf2e46ff19/579919ef04339.image.png?resize=500%2C500"
                    
                    alt="Cliff Savren"
                    class="img-responsive owl-first-image owl-lazy default"
                    width="600"
                    height="600"
                    data-src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/9/c2/9c27d602-4770-11e6-91b0-03bf2e46ff19/579919ef04339.image.png?resize=500%2C500" />
                                        
                                        
                                </div>
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-photo-modal" data-target=".caption-inner-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-photo-modal">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-photo-modal collapse in"><div class="caption-text"><p>Savren </p></div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        
    <ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link">
         
            <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fcliff-savren%2Fimage_9c27d602-4770-11e6-91b0-03bf2e46ff19.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="fb" target="_blank" title="Share on Facebook" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/cliff-savren/image_9c27d602-4770-11e6-91b0-03bf2e46ff19.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":9c27d602-4770-11e6-91b0-03bf2e46ff19}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
            
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link">
            <a href="https://twitter.com/intent/tweet?&text=Cliff%20Savren&via=CleveJN&url=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fcliff-savren%2Fimage_9c27d602-4770-11e6-91b0-03bf2e46ff19.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tw" target="_blank" title="Tweet" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/cliff-savren/image_9c27d602-4770-11e6-91b0-03bf2e46ff19.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":9c27d602-4770-11e6-91b0-03bf2e46ff19}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link">
            <a href="mailto:?subject=%5BCleveland%20Jewish%20News%5D%20Cliff%20Savren&body=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fcliff-savren%2Fimage_9c27d602-4770-11e6-91b0-03bf2e46ff19.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="em email-share-link" title="Email" data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":9c27d602-4770-11e6-91b0-03bf2e46ff19}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                
                <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/cliff-savren/image_9c27d602-4770-11e6-91b0-03bf2e46ff19.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":9c27d602-4770-11e6-91b0-03bf2e46ff19}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li></ul>
    <form method="post" data-uuid="9c27d602-4770-11e6-91b0-03bf2e46ff19" class="save-list-9c27d602-4770-11e6-91b0-03bf2e46ff19-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="9c27d602-4770-11e6-91b0-03bf2e46ff19" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
            </div>
        </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </div>
    </div>
        <script>
            jQuery(document).ready(function($){
                $('#photo-carousel-6fb0c844-0214-11ed-8c92-e39f5ec5cd80').on('show.bs.modal', function(e){
                    $('#fixed-leaderboard-top-container').addClass('overlay-leaderboard');
                });
                $('#photo-carousel-6fb0c844-0214-11ed-8c92-e39f5ec5cd80').on('hide.bs.modal', function(e){
                    $('#fixed-leaderboard-top-container').removeClass('overlay-leaderboard');
                });
            });
        </script><article itemscope itemtype="https://schema.org/Article" id="asset-6fb0c844-0214-11ed-8c92-e39f5ec5cd80" class="asset article-default"  data-url="https://www.clevelandjewishnews.com/columnists/cliff_savren/israel-needs-to-look-beyond-netanyahu-in-next-election/article_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span>
    <meta itemprop="description" content="Israel has a new prime minister, Yair Lapid, who will serve until after elections Nov. 1. If recent experience is any guide, he will also serve well beyond that, either after winning the election or staying in the job if the result is another stalemate. "/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/d/2d/d2dc9a30-fc54-11ec-bbce-e7560342f71a/62c41f34bd51e.image.jpg?crop=880%2C462%2C0%2C16&resize=880%2C462&order=crop%2Cresize">
            <meta itemprop="width" content="880">
            <meta itemprop="height" content="462">
        </div>
        <meta itemprop="name" content="clevelandjewishnews.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.clevelandjewishnews.com/columnists/cliff_savren/israel-needs-to-look-beyond-netanyahu-in-next-election/article_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html" />
    <style>
                .asset-paging .direction {
                    color: #4f6eb5;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.clevelandjewishnews.com\/tncms\/search\/mlt\/?origin=6fb0c844-0214-11ed-8c92-e39f5ec5cd80&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"6fb0c844-0214-11ed-8c92-e39f5ec5cd80","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-6fb0c844-0214-11ed-8c92-e39f5ec5cd80" class="asset-paging">
                <div id="paging-prev-6fb0c844-0214-11ed-8c92-e39f5ec5cd80" class="paging-link prev offset"></div>
                <div id="paging-next-6fb0c844-0214-11ed-8c92-e39f5ec5cd80" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    <div class="tow-wrapper no-flags">
        
        
    </div>
    <h1 itemprop="headline" class="headline">
        <span>
            
            Israel needs to look beyond Netanyahu in next election
        </span>
    </h1>
    <div class="meta">
        <span>
            <ul class="list-inline">
        <li><span id="author-popup-cc783a84-5591-11e6-9b57-e7039d164a0f-asset-6fb0c844-0214-11ed-8c92-e39f5ec5cd80" class="tnt-byline asset-byline" rel="popover" itemprop="author"><a href="https://www.clevelandjewishnews.com/users/profile/Cliff%20Savren">Cliff Savren | CJN Columnist <br />columnists@cjn.org</a></span>
                
                    <div id="author-popup-cc783a84-5591-11e6-9b57-e7039d164a0f-asset-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-content" class="hide">
                        <article class="clearfix card author popup-content card-author-cc783a84-5591-11e6-9b57-e7039d164a0f">
                <div class="card-container">
                    <div class="media-list">
                        <div class="media">
                            
                                <div class="avatar-box pull-left hidden-print">
                                    <a href="https://www.clevelandjewishnews.com/users/profile/Cliff%20Savren" class="tnt-user-profile-link user-profile-link card-image media-object" rel="author">
                                        <img alt="Cliff Savren" src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/avatars/c/c7/83a/cc783a84-5591-11e6-9b57-e7039d164a0f.10279c87c6418977c3c1398436f04e60.png?_dc=1469799659" width="200" height="200" loading="lazy" class="img-responsive lazyload tnt-user-avatar" />
                                    </a>
                                </div>
                            

                            <div class="media-body ">
                                <h4 class="media-heading">
                                    <a href="https://www.clevelandjewishnews.com/users/profile/Cliff%20Savren" rel="author" class="tnt-user-profile-link tnt-user-name">Cliff Savren</a>
                                </h4></div>
                        </div>
                    </div>
                </div>
            </article>
                    </div>
                    <script>
                        $('#author-popup-cc783a84-5591-11e6-9b57-e7039d164a0f-asset-6fb0c844-0214-11ed-8c92-e39f5ec5cd80').popover({
                            content: $('#author-popup-cc783a84-5591-11e6-9b57-e7039d164a0f-asset-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-content').html(),
                            container: 'body',
                            html:true,
                            sanitize: false,
                            trigger:'hover',
                            placement:'top',
                            delay:{ show:100, hide:200 }
                        });
                    </script>
                </li>
        
        
            <li class="visible-print">
        <time datetime="2022-07-13T16:00:00-04:00" class="tnt-date asset-date text-muted">
            Jul 13, 2022
        </time></li>
            <li class="hidden-print">
        <span class="text-muted ">Posted </span>
        <time datetime="2022-07-13T16:00:00-04:00" class="tnt-date asset-date text-muted">43 min ago at 4: 00 PM
        </time></li>
        
        
            <li class="hidden-print"><a href="/columnists/cliff_savren/israel-needs-to-look-beyond-netanyahu-in-next-election/article_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html#comments" class="cm"><span class="fas tnt-comments"></span>
            <span class="sr-only">Comments</span>
        </a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2022-07-13T16:00:00-04:00">
    <meta itemprop="datePublished" content="2022-07-13T16:00:00-04:00">
    <meta itemprop="dateModified" content="2022-07-13T16:00:00-04:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove>
    <ul class="social-share-links hidden-print list-unstyled stacked icon">
        <li class="social-share-link">
         
            <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fcolumnists%2Fcliff_savren%2Fisrael-needs-to-look-beyond-netanyahu-in-next-election%2Farticle_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="fb" target="_blank" title="Share on Facebook" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/columnists/cliff_savren/israel-needs-to-look-beyond-netanyahu-in-next-election/article_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":6fb0c844-0214-11ed-8c92-e39f5ec5cd80}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
            
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link">
            <a href="https://twitter.com/intent/tweet?&text=Israel%20needs%20to%20look%20beyond%20Netanyahu%20in%20next%20election&via=CleveJN&url=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fcolumnists%2Fcliff_savren%2Fisrael-needs-to-look-beyond-netanyahu-in-next-election%2Farticle_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tw" target="_blank" title="Tweet" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/columnists/cliff_savren/israel-needs-to-look-beyond-netanyahu-in-next-election/article_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":6fb0c844-0214-11ed-8c92-e39f5ec5cd80}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link">
            <a href="mailto:?subject=%5BCleveland%20Jewish%20News%5D%20Israel%20needs%20to%20look%20beyond%20Netanyahu%20in%20next%20election&body=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fcolumnists%2Fcliff_savren%2Fisrael-needs-to-look-beyond-netanyahu-in-next-election%2Farticle_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="em email-share-link" title="Email" data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":6fb0c844-0214-11ed-8c92-e39f5ec5cd80}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                
                <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/columnists/cliff_savren/israel-needs-to-look-beyond-netanyahu-in-next-election/article_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":6fb0c844-0214-11ed-8c92-e39f5ec5cd80}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Print">
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li></ul>
    <form method="post" data-uuid="6fb0c844-0214-11ed-8c92-e39f5ec5cd80" class="save-list-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="6fb0c844-0214-11ed-8c92-e39f5ec5cd80" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
        
    </div>

    
        <div class="asset-related-mugshot inline-asset inline-image hover-expand visible-xs" data-photo-target=".photo-9c27d602-4770-11e6-91b0-03bf2e46ff19" data-toggle="modal" data-instance="#gallery-items-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-photo-modal" data-target="#photo-carousel-6fb0c844-0214-11ed-8c92-e39f5ec5cd80">
            <span class="expand">
                    +1&nbsp;<span class="fas tnt-camera"></span>
            </span><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="600">
            <meta itemprop="height" content="600">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/9/c2/9c27d602-4770-11e6-91b0-03bf2e46ff19/579919ef04339.image.png">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/9/c2/9c27d602-4770-11e6-91b0-03bf2e46ff19/579919ef04339.image.png">
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Cliff Savren"
                            class="img-responsive lazyload full default"
                            width="600"
                            height="600"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/9/c2/9c27d602-4770-11e6-91b0-03bf2e46ff19/579919ef04339.image.png?resize=150%2C150 150w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/9/c2/9c27d602-4770-11e6-91b0-03bf2e46ff19/579919ef04339.image.png?resize=200%2C200 200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/9/c2/9c27d602-4770-11e6-91b0-03bf2e46ff19/579919ef04339.image.png?resize=225%2C225 225w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/9/c2/9c27d602-4770-11e6-91b0-03bf2e46ff19/579919ef04339.image.png?resize=300%2C300 300w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/9/c2/9c27d602-4770-11e6-91b0-03bf2e46ff19/579919ef04339.image.png?resize=400%2C400 400w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/9/c2/9c27d602-4770-11e6-91b0-03bf2e46ff19/579919ef04339.image.png?resize=540%2C540 540w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/9/c2/9c27d602-4770-11e6-91b0-03bf2e46ff19/579919ef04339.image.png?resize=600%2C600 640w" />
            </div>
                
                
            </div>
            
                
                
                    <figcaption class="caption">
                            
                                <span class="caption-text">
                                    <p>Savren </p>
                                </span>
                            
                        
                            
                        
                        <span class="clearfix"></span>
                    </figcaption>
                
            
        </figure></div>
    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            <div class="asset-photo card"><figure class="photo layout-horizontal hover-expand letterbox-style-default"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-photo-target=".photo-d2dc9a30-fc54-11ec-bbce-e7560342f71a" 
                    data-instance="#gallery-items-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-photo-modal" 
                    data-target="#photo-carousel-6fb0c844-0214-11ed-8c92-e39f5ec5cd80">
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-photo-target=".photo-d2dc9a30-fc54-11ec-bbce-e7560342f71a" 
                    data-instance="#gallery-items-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-photo-modal" 
                    data-target="#photo-carousel-6fb0c844-0214-11ed-8c92-e39f5ec5cd80">
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="880">
            <meta itemprop="height" content="495">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/d/2d/d2dc9a30-fc54-11ec-bbce-e7560342f71a/62c41f34bd51e.image.jpg">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/d/2d/d2dc9a30-fc54-11ec-bbce-e7560342f71a/62c41f34bd51e.image.jpg"><img
                        src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/d/2d/d2dc9a30-fc54-11ec-bbce-e7560342f71a/62c41f34bd51e.image.jpg?resize=400%2C225"
                        srcset="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/d/2d/d2dc9a30-fc54-11ec-bbce-e7560342f71a/62c41f34bd51e.image.jpg?resize=150%2C84 150w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/d/2d/d2dc9a30-fc54-11ec-bbce-e7560342f71a/62c41f34bd51e.image.jpg?resize=200%2C113 200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/d/2d/d2dc9a30-fc54-11ec-bbce-e7560342f71a/62c41f34bd51e.image.jpg?resize=225%2C127 225w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/d/2d/d2dc9a30-fc54-11ec-bbce-e7560342f71a/62c41f34bd51e.image.jpg?resize=300%2C169 300w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/d/2d/d2dc9a30-fc54-11ec-bbce-e7560342f71a/62c41f34bd51e.image.jpg?resize=400%2C225 400w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/d/2d/d2dc9a30-fc54-11ec-bbce-e7560342f71a/62c41f34bd51e.image.jpg?resize=540%2C304 540w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/d/2d/d2dc9a30-fc54-11ec-bbce-e7560342f71a/62c41f34bd51e.image.jpg?resize=640%2C360 640w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/d/2d/d2dc9a30-fc54-11ec-bbce-e7560342f71a/62c41f34bd51e.image.jpg?resize=750%2C422 750w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/d/2d/d2dc9a30-fc54-11ec-bbce-e7560342f71a/62c41f34bd51e.image.jpg?resize=880%2C495 990w"
                        sizes="(min-width: 1200px) 750px, (min-width: 992px) calc(66.70vw - 60px), calc(100vw - 30px)"
                        
                        width="880"
                        height="495"
                        alt="Israeli Prime Minister Yair Lapid"
                        class="img-responsive full tnt-restrict-img-d2dc9a30-fc54-11ec-bbce-e7560342f71a default" />
            </div><style>
                .tnt-restrict-img-d2dc9a30-fc54-11ec-bbce-e7560342f71a {
                    max-width: 760px;
                }
            </style>
                
                
            </div>
            
                
                
                    <figcaption class="caption">
                            
                                <span class="caption-text">
                                    <p>Israeli Prime Minister Yair Lapid addresses the weekly Cabinet session, in Jerusalem, on July 3, 2022. </p>
                                </span>
                            
                        
                            
                                <span class="credit">
                                    <span  class="tnt-byline">Haim Zach/GPO</span>
                                </span>
                            
                        
                        <span class="clearfix"></span>
                    </figcaption>
                
            
        </figure></div>

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"><div id="tncms-block-1471908" class="tncms-block"><section id="block-1471908" class="block emphasis-h3 dark  " ><div class="card-panel panel">
        <div class="panel-body"><article class="card promo media"><div class="media-body"><h3 class="media-heading">Disclaimer</h3><p>The Cleveland Jewish News does not make endorsements of political candidates and/or political or other ballot issues on any level. Letters, commentaries, opinions, advertisements and online posts appearing in the Cleveland Jewish News, on cjn.org or our social media pages do not necessarily reflect the opinions of the Cleveland Jewish Publication Company, its board, officers or staff.</p></div>
</article></div>
    </div></section></div></div>

            <div id="asset-content" data-asset-uuid="6fb0c844-0214-11ed-8c92-e39f5ec5cd80">
                

                <div class="row">
                    <div class="col-lg-8 col-md-12 col-sm-8 col-lg-push-4 col-md-push-0 col-sm-push-4" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove>
    <ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link">
         
            <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fcolumnists%2Fcliff_savren%2Fisrael-needs-to-look-beyond-netanyahu-in-next-election%2Farticle_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="fb" target="_blank" title="Share on Facebook" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/columnists/cliff_savren/israel-needs-to-look-beyond-netanyahu-in-next-election/article_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":6fb0c844-0214-11ed-8c92-e39f5ec5cd80}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
            
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link">
            <a href="https://twitter.com/intent/tweet?&text=Israel%20needs%20to%20look%20beyond%20Netanyahu%20in%20next%20election&via=CleveJN&url=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fcolumnists%2Fcliff_savren%2Fisrael-needs-to-look-beyond-netanyahu-in-next-election%2Farticle_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tw" target="_blank" title="Tweet" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/columnists/cliff_savren/israel-needs-to-look-beyond-netanyahu-in-next-election/article_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":6fb0c844-0214-11ed-8c92-e39f5ec5cd80}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link">
            <a href="mailto:?subject=%5BCleveland%20Jewish%20News%5D%20Israel%20needs%20to%20look%20beyond%20Netanyahu%20in%20next%20election&body=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fcolumnists%2Fcliff_savren%2Fisrael-needs-to-look-beyond-netanyahu-in-next-election%2Farticle_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="em email-share-link" title="Email" data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":6fb0c844-0214-11ed-8c92-e39f5ec5cd80}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                
                <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/columnists/cliff_savren/israel-needs-to-look-beyond-netanyahu-in-next-election/article_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":6fb0c844-0214-11ed-8c92-e39f5ec5cd80}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li></ul>
    <form method="post" data-uuid="6fb0c844-0214-11ed-8c92-e39f5ec5cd80" class="save-list-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="6fb0c844-0214-11ed-8c92-e39f5ec5cd80" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div id="article-body"  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p>Israel has a new prime minister, Yair Lapid, who will serve until after elections Nov. 1. If recent experience is any guide, he will also serve well beyond that, either after winning the election or staying in the job if the result is another stalemate.</p><p>Lapid, a photogenic former news anchor, newspaper columnist, author and actor, took office July 1 following the collapse of the coalition government led by Prime Minister Naftali Bennett. Although Bennett is still officially “alternate prime minister,” he announced that he would not run in the November election.</p><p>Heading into a fifth election since April 2019, Israeli public opinion is roughly equally divided between supporters of former Prime Minister Benjamin Netanyahu and those who oppose him.</p><div class="tnt-ads-container text-center  " >
        <div id="fixed-big-ad-top-asset" class="tnt-ads dfp-ad" style="min-height:250px; min-width:300px;" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-big-ad-top-asset');
                        googletag.pubads().refresh([gptAdSlots['fixed-big-ad-top-asset']]);
                });
            </script>
        </div>
    </div><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><p>Netanyahu is currently on trial in Jerusalem District Court on corruption charges, and new evidence of his alleged abuses came into full relief recently in court testimony from Hadas Klein. She worked as a personal assistant to the Israeli Hollywood entertainment mogul Arnon Milchan and later for James Packer, an Australian billionaire and former romantic partner of the singer Mariah Carey.</p><p>In great detail, Klein described an arrangement in which Netanyahu and his wife received lavish “gifts” from Milchan and Packer. Over a five-year period, Milchan’s office allegedly delivered more than $75,000 worth of cigars for the prime minister, $50,000 worth of Champagne for his family and specific jewelry that the prime minister’s wife, Sara, allegedly demanded. The prosecution says they were given in return for influence that Netanyahu exerted on Milchan’s behalf, including intervention with American authorities to get Milchan’s residency visa in the United States renewed.</p><p>Nevertheless, according to current polling, the former prime minister and his Likud party appear to be just a couple Knesset seats away from regaining office with a majority coalition. That’s despite concern that if he regained office, he would try passing legislation giving himself immunity from prosecution.</p><p>It’s also possible that new politicians will run in November and gain prominence. Former Israeli army Chief of Staff Gadi Eisenkot is likely one of them. He is being courted by several parties in the anti-Netanyahu bloc. Reportedly one option for him would be to serve as No. 2 to Lapid on Lapid’s Yesh Atid party slate. That could scramble the political deck and shore up the party’s appeal on the issue of defense.</p><div class="tnt-ads-container text-center  " >
        <div id="fixed-big-ad-middle-asset" class="tnt-ads dfp-ad" style="min-height:250px; min-width:300px;" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-big-ad-middle-asset');
                        
                });
            </script>
        </div>
    </div><div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"></div><p>There is also a new candidate for the leadership of the left-wing Meretz party, which I voted for in the last election and am likely to vote for again in November. He’s Yair Golan, a former deputy chief of staff of the Israel Defense Forces. After years of Israeli governments attempting to push the Palestinian issue into the margins, he wants to put it front-and-center, which is a wise move as I see it.</p><p>“I was personally involved with the occupation,” he said in announcing his run for the Meretz party leadership. “I understand what it is to maintain control over a hostile population over a long period. We must separate from the Palestinians by agreement, and that agreement is about two states.”</p><p>Golan will not be the next prime minister, nor will Eisenkot. If an anti-Netanyahu coalition prevails in November, it will likely still be headed by Lapid, which is fine with me.</p><p>Prime Minister Lapid’s first priority between now and Election Day should simply be to act like a prime minister and to show a majority of the voters that the country is better off with him and without Netanyahu. And unfortunately for Netanyahu, there is likely to be more evidence in court of his alleged abuses between now and Nov. 1.</p><hr /><p class="p1"><em>Cliff Savren is a former Clevelander who covers the Middle East from Ra’anana, Israel. He is an editor at the English edition of Haaretz.</em></p><div class="tnt-ads-container text-center  " >
        <div id="fixed-big-ad-bottom-asset" class="tnt-ads dfp-ad" style="min-height:250px; min-width:300px;" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-big-ad-bottom-asset');
                        
                });
            </script>
        </div>
    </div><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    
        
            
                <div id="reaction-wrap" class="reaction-wrapper hidden-print reaction-6fb0c844-0214-11ed-8c92-e39f5ec5cd80 anonymous">
                    <div id="reaction">
                        
                            <h4>How do you feel about this article?</h4>
                        
                        
                            <p>Choose from the options below.</p>
                        
                        <div id="reaction-form-wrapper">
                            
                            <form id="reaction-form" onsubmit="return" data-uuid="6fb0c844-0214-11ed-8c92-e39f5ec5cd80" method="post" action="/tncms/counter/editorial/6fb0c844-0214-11ed-8c92-e39f5ec5cd80/?">
                                <input type="hidden" name="subkey" value="reaction">
                                <input type="hidden" name="action" value="add" id="action">
                                <input type="hidden" name="type" value="" id="hidden-type">
                                <input type="hidden" name="id" value="6fb0c844-0214-11ed-8c92-e39f5ec5cd80" id="asset-id" />
                                <div class="form-icons love" data-user-reaction-emotion="love">
                                               <label class="love-icon reaction-name" data-user-reaction-emotion="love">
                                                   <span class="emotion-name" data-user-reaction-emotion="love">Love</span>
                                                   
                                               </label>
                                               <div class="emotion-container" data-user-reaction-emotion="love">
                                                   <div class="love-icon form-emoji" data-user-reaction-emotion="love"></div>
                                                   <div id="reaction-love-count" 
                                                        class="reaction-count count-love" 
                                                        data-user-reaction-count="0" 
                                                        data-user-reaction-emotion="love">0</div>
                                               </div>
                                           </div><div class="form-icons funny" data-user-reaction-emotion="funny">
                                               <label class="funny-icon reaction-name" data-user-reaction-emotion="funny">
                                                   <span class="emotion-name" data-user-reaction-emotion="funny">Funny</span>
                                                   
                                               </label>
                                               <div class="emotion-container" data-user-reaction-emotion="funny">
                                                   <div class="funny-icon form-emoji" data-user-reaction-emotion="funny"></div>
                                                   <div id="reaction-funny-count" 
                                                        class="reaction-count count-funny" 
                                                        data-user-reaction-count="0" 
                                                        data-user-reaction-emotion="funny">0</div>
                                               </div>
                                           </div><div class="form-icons wow" data-user-reaction-emotion="wow">
                                               <label class="wow-icon reaction-name" data-user-reaction-emotion="wow">
                                                   <span class="emotion-name" data-user-reaction-emotion="wow">Wow</span>
                                                   
                                               </label>
                                               <div class="emotion-container" data-user-reaction-emotion="wow">
                                                   <div class="wow-icon form-emoji" data-user-reaction-emotion="wow"></div>
                                                   <div id="reaction-wow-count" 
                                                        class="reaction-count count-wow" 
                                                        data-user-reaction-count="0" 
                                                        data-user-reaction-emotion="wow">0</div>
                                               </div>
                                           </div><div class="form-icons sad" data-user-reaction-emotion="sad">
                                               <label class="sad-icon reaction-name" data-user-reaction-emotion="sad">
                                                   <span class="emotion-name" data-user-reaction-emotion="sad">Sad</span>
                                                   
                                               </label>
                                               <div class="emotion-container" data-user-reaction-emotion="sad">
                                                   <div class="sad-icon form-emoji" data-user-reaction-emotion="sad"></div>
                                                   <div id="reaction-sad-count" 
                                                        class="reaction-count count-sad" 
                                                        data-user-reaction-count="0" 
                                                        data-user-reaction-emotion="sad">0</div>
                                               </div>
                                           </div><div class="form-icons angry" data-user-reaction-emotion="angry">
                                               <label class="angry-icon reaction-name" data-user-reaction-emotion="angry">
                                                   <span class="emotion-name" data-user-reaction-emotion="angry">Angry</span>
                                                   
                                               </label>
                                               <div class="emotion-container" data-user-reaction-emotion="angry">
                                                   <div class="angry-icon form-emoji" data-user-reaction-emotion="angry"></div>
                                                   <div id="reaction-angry-count" 
                                                        class="reaction-count count-angry" 
                                                        data-user-reaction-count="0" 
                                                        data-user-reaction-emotion="angry">0</div>
                                               </div>
                                           </div>
                            </form>
                        </div>
                    </div>
                    <div id="reaction-form-message" class="hide">
                        <p></p>
                    </div>
                </div>
        
    


                            
                                <div class="share-container content-below" data-subscription-required-remove>
    <ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link">
         
            <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fcolumnists%2Fcliff_savren%2Fisrael-needs-to-look-beyond-netanyahu-in-next-election%2Farticle_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="fb" target="_blank" title="Share on Facebook" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/columnists/cliff_savren/israel-needs-to-look-beyond-netanyahu-in-next-election/article_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":6fb0c844-0214-11ed-8c92-e39f5ec5cd80}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
            
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link">
            <a href="https://twitter.com/intent/tweet?&text=Israel%20needs%20to%20look%20beyond%20Netanyahu%20in%20next%20election&via=CleveJN&url=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fcolumnists%2Fcliff_savren%2Fisrael-needs-to-look-beyond-netanyahu-in-next-election%2Farticle_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tw" target="_blank" title="Tweet" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/columnists/cliff_savren/israel-needs-to-look-beyond-netanyahu-in-next-election/article_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":6fb0c844-0214-11ed-8c92-e39f5ec5cd80}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link">
            <a href="mailto:?subject=%5BCleveland%20Jewish%20News%5D%20Israel%20needs%20to%20look%20beyond%20Netanyahu%20in%20next%20election&body=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fcolumnists%2Fcliff_savren%2Fisrael-needs-to-look-beyond-netanyahu-in-next-election%2Farticle_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="em email-share-link" title="Email" data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":6fb0c844-0214-11ed-8c92-e39f5ec5cd80}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                
                <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/columnists/cliff_savren/israel-needs-to-look-beyond-netanyahu-in-next-election/article_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":6fb0c844-0214-11ed-8c92-e39f5ec5cd80}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li></ul>
    <form method="post" data-uuid="6fb0c844-0214-11ed-8c92-e39f5ec5cd80" class="save-list-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="6fb0c844-0214-11ed-8c92-e39f5ec5cd80" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div><div class="col-lg-4 col-md-12 col-sm-4 col-md-pull-0 col-sm-pull-8 col-lg-pull-8" data-subscription-required-remove>
                            <aside class="related-sidebar default  subscriber-hide">

                                

                                <div id="tncms-region-article_aside_top" class="tncms-region hidden-print"></div>

                                
                                

                                

                                

                                

                                
                                                <div class="asset-related-mugshot inline-asset inline-image hidden-xs">
                                                    <div class="hover-expand" data-toggle="modal" data-photo-target=".photo-9c27d602-4770-11e6-91b0-03bf2e46ff19" data-instance="#gallery-items-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-photo-modal" data-target="#photo-carousel-6fb0c844-0214-11ed-8c92-e39f5ec5cd80">
                                                        <span class="expand">
                                                                +1&nbsp;<span class="fas tnt-camera"></span>
                                                        </span><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="600">
            <meta itemprop="height" content="600">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/9/c2/9c27d602-4770-11e6-91b0-03bf2e46ff19/579919ef04339.image.png">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/9/c2/9c27d602-4770-11e6-91b0-03bf2e46ff19/579919ef04339.image.png">
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Cliff Savren"
                            class="img-responsive lazyload full default"
                            width="600"
                            height="600"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/9/c2/9c27d602-4770-11e6-91b0-03bf2e46ff19/579919ef04339.image.png?resize=150%2C150 150w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/9/c2/9c27d602-4770-11e6-91b0-03bf2e46ff19/579919ef04339.image.png?resize=200%2C200 200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/9/c2/9c27d602-4770-11e6-91b0-03bf2e46ff19/579919ef04339.image.png?resize=225%2C225 225w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/9/c2/9c27d602-4770-11e6-91b0-03bf2e46ff19/579919ef04339.image.png?resize=300%2C300 300w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/9/c2/9c27d602-4770-11e6-91b0-03bf2e46ff19/579919ef04339.image.png?resize=400%2C400 400w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/9/c2/9c27d602-4770-11e6-91b0-03bf2e46ff19/579919ef04339.image.png?resize=540%2C540 540w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/9/c2/9c27d602-4770-11e6-91b0-03bf2e46ff19/579919ef04339.image.png?resize=600%2C600 640w" />
            </div>
                
                
            </div>
            
                
                
                    <figcaption class="caption">
                            
                                <span class="caption-text">
                                    <p>Savren </p>
                                </span>
                            
                        
                            
                        
                        <span class="clearfix"></span>
                    </figcaption>
                
            
        </figure></div></div>
                                            

                                

                                

                                

                                

                                

                                

                                <div id="tncms-region-article_aside_bottom" class="tncms-region hidden-print"><div id="tncms-block-1446361" class="tncms-block"><section id="block-1446361" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1446361 ">
        <div class="block-title-inner">
            <h4>
                
                Recent columns
                
            </h4>
        </div>
    </div></div>
    <div class=""><ul class="card headline-list list-unstyled border border-dotted"><li class="">
            <span class="tnt-headline ">
        
             <a href="/columnists/cliff_savren/israel-needs-to-look-beyond-netanyahu-in-next-election/article_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html" class="tnt-asset-link" aria-label="Israel needs to look beyond Netanyahu in next election">
        

        
            Israel needs to look beyond Netanyahu in next election</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/columnists/cliff_savren/let-s-vote-on-it-when-will-israel-s-next-election-be/article_6e41b747-1bcc-5f03-9e47-6f4e1cf4e47f.html" class="tnt-asset-link" aria-label="Let’s vote on it – when will Israel’s next election be">
        

        
            Let’s vote on it – when will Israel’s next election be</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/columnists/cliff_savren/herzl-the-prophet-his-vision-fulfilled/article_59939a53-cb2e-5bf3-ba11-deb74859cda8.html" class="tnt-asset-link" aria-label="Herzl the prophet, his vision fulfilled">
        

        
            Herzl the prophet, his vision fulfilled</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/columnists/cliff_savren/freedom-to-protest-disagree-is-sign-of-strength/article_91d986ce-be2a-53fc-ac6d-b9a596d5dde0.html" class="tnt-asset-link" aria-label="Freedom to protest, disagree is sign of strength">
        

        
            Freedom to protest, disagree is sign of strength</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/columnists/cliff_savren/new-government-step-forward-challenges-remain/article_b678c461-4f08-54d6-beba-7e96d4c87d53.html" class="tnt-asset-link" aria-label="New government step forward, challenges remain">
        

        
            New government step forward, challenges remain</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/columnists/cliff_savren/this-season-is-the-best-time-to-learn-about-israel/article_1dea5ce2-cb2c-11ec-90af-9bfd67f2b5b9.html" class="tnt-asset-link" aria-label="This season is the best time to learn about Israel">
        

        
            This season is the best time to learn about Israel</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/columnists/cliff_savren/what-s-next-for-israeli-government/article_030c0eb8-ba81-11ec-8d58-1749e26c448d.html" class="tnt-asset-link" aria-label="What’s next for Israeli government?">
        

        
            What’s next for Israeli government?</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/columnists/cliff_savren/there-are-nuances-in-ukraine-story/article_d3985fda-aecb-11ec-9b85-4b500c62d856.html" class="tnt-asset-link" aria-label="There are nuances in Ukraine story">
        

        
            There are nuances in Ukraine story</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/columnists/cliff_savren/refugee-problem-difficult-to-comprehend/article_fc50e80a-a491-11ec-8018-07eb16308d9b.html" class="tnt-asset-link" aria-label="Refugee problem difficult to comprehend">
        

        
            Refugee problem difficult to comprehend</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/columnists/cliff_savren/israel-expects-wave-of-ukranian-jews-to-immigrate-in-coming-weeks/article_b00b591a-9660-11ec-b60d-7b13b89d0d64.html" class="tnt-asset-link" aria-label="Israel expects wave of Ukranian Jews to immigrate in coming weeks">
        

        
            Israel expects wave of Ukranian Jews to immigrate in coming weeks</a></span>
        </li></ul></div></section></div></div>

                                

                                <div id="article-aside-sticky-spacer"><div id="tncms-region-article_aside_sticky" class="tncms-region hidden-print"></div></div>

                            </aside>
                        </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    
                        <div class="asset-tags hidden-print">
                            <h4>Tags</h4>
                            <ul class="list-inline"><li>
                    <a href="/search/?k=%22prime%20minister%22#tncms-source=keyword" class="tag-prime-minister label label-default" data-tncms-track-dmp='search: prime-minister' rel="nofollow">Prime Minister</a>
                </li> <li>
                    <a href="/search/?k=%22yair%20lapid%22#tncms-source=keyword" class="tag-yair-lapid label label-default" data-tncms-track-dmp='search: yair-lapid' rel="nofollow">Yair Lapid</a>
                </li> <li>
                    <a href="/search/?k=%22benjamin%20netanyahu%22#tncms-source=keyword" class="tag-benjamin-netanyahu label label-default" data-tncms-track-dmp='search: benjamin-netanyahu' rel="nofollow">Benjamin Netanyahu</a>
                </li> <li>
                    <a href="/search/?k=%22politics%22#tncms-source=keyword" class="tag-politics label label-default" data-tncms-track-dmp='search: politics' rel="nofollow">Politics</a>
                </li> <li>
                    <a href="/search/?k=%22institutes%22#tncms-source=keyword" class="tag-institutes label label-default" data-tncms-track-dmp='search: institutes' rel="nofollow">Institutes</a>
                </li> <li>
                    <a href="/search/?k=%22ministries%22#tncms-source=keyword" class="tag-ministries label label-default" data-tncms-track-dmp='search: ministries' rel="nofollow">Ministries</a>
                </li> <li>
                    <a href="/search/?k=%22israel%22#tncms-source=keyword" class="tag-israel label label-default" data-tncms-track-dmp='search: israel' rel="nofollow">Israel</a>
                </li> <li>
                    <a href="/search/?k=%22naftali%20bennett%22#tncms-source=keyword" class="tag-naftali-bennett label label-default" data-tncms-track-dmp='search: naftali-bennett' rel="nofollow">Naftali Bennett</a>
                </li> <li>
                    <a href="/search/?k=%22yair%20golan%22#tncms-source=keyword" class="tag-yair-golan label label-default" data-tncms-track-dmp='search: yair-golan' rel="nofollow">Yair Golan</a>
                </li> <li>
                    <a href="/search/?k=%22arnon%20milchan%22#tncms-source=keyword" class="tag-arnon-milchan label label-default" data-tncms-track-dmp='search: arnon-milchan' rel="nofollow">Arnon Milchan</a>
                </li> </ul>
                        </div>
                    

                    

                    

                    
                        
                            <div class="asset-author">
                                <article class="clearfix card author  card-author-cc783a84-5591-11e6-9b57-e7039d164a0f">
                <div class="card-container">
                    <div class="media-list">
                        <div class="media">
                            
                                <div class="avatar-box pull-left hidden-print">
                                    <a href="https://www.clevelandjewishnews.com/users/profile/Cliff%20Savren" class="tnt-user-profile-link user-profile-link card-image media-object" rel="author">
                                        <img alt="Cliff Savren" src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/avatars/c/c7/83a/cc783a84-5591-11e6-9b57-e7039d164a0f.10279c87c6418977c3c1398436f04e60.png?_dc=1469799659" width="200" height="200" loading="lazy" class="img-responsive lazyload tnt-user-avatar" />
                                    </a>
                                </div>
                            

                            <div class="media-body ">
                                <h4 class="media-heading">
                                    <a href="https://www.clevelandjewishnews.com/users/profile/Cliff%20Savren" rel="author" class="tnt-user-profile-link tnt-user-name">Cliff Savren</a>
                                </h4><div class="followed-notify-link hidden-print"><button id="follow-author-cc783a84-5591-11e6-9b57-e7039d164a0f" class="followed-notify-btn btn btn-success btn-sm" disabled data-params="?a=cc783a84-5591-11e6-9b57-e7039d164a0f&amp;s=start_time&amp;sd=desc" data-subject="Cliff Savren" data-description="Whenever Cliff Savren posts new content, you'll get an email delivered to your inbox with a link." data-name="Cliff Savren notification" data-author-id="cc783a84-5591-11e6-9b57-e7039d164a0f" data-user-url="https://www.clevelandjewishnews.com/users/">
        <i class="fas tnt-star"></i> Follow Cliff Savren
    </button><template id="follow-this-modal-logged-in">
            <div class="modal-dialog">
                <div class="modal-content">
                    <div class="modal-header">
                        <button class="close" type="button" data-dismiss="modal">
                            <i class="fas tnt-times-circle"></i>
                            <span class="sr-only">Close</span>
                        </button>
                        <h4 class="modal-title">Get email notifications on {{subject}} daily!</h4>
                    </div>
                    <div class="modal-body">
                        <div class="alert alert-success" style="display:none;">
                            Your notification has been saved.
                        </div>
                        <div class="alert alert-danger" style="display:none;">
                            There was a problem saving your notification.
                        </div>
                        <p class="notification-description">{{description}}</p>
                        <p>Email notifications are only sent once a day, and only if there are new matching items.</p>
                        <form id="follow-notify-form" class="follow-notify-form" action="{{action}}" method="post">
                            <input class="input-notification-name" type="hidden" name="title" value="{{title}}">
                            <div class="row">
                                <div class="col-sm-6">
                                    <button class="btn btn-success btn-block follow-btn" data-tncms-track-dmp='is_followed_notifications_user'>
                                        <i class="fas tnt-spinner tnt-pulse" style="display:none;"></i> Save
                                    </button>
                                </div>
                                <div class="col-sm-6">
                                    <a class="btn btn-default btn-block" href="https://www.clevelandjewishnews.com/users/admin/savedsearch/">Manage followed notifications</a>
                                </div>
                            </div>
                        </form>
                    </div>
                </div>
            </div>
        </template>

        <template id="follow-this-modal-logged-out">
            <div class="modal-dialog modal-sm">
                <div class="modal-content">
                    <div class="modal-header">
                        <button class="close" type="button" data-dismiss="modal">
                            <i class="fas tnt-times-circle"></i>
                            <span class="sr-only">Close</span>
                        </button>
                        <h4 class="modal-title">Followed notifications</h4>
                    </div>
                    <div class="modal-body">
                        <div class="user-login padding-bottom">
                            <h4>Please log in to use this feature</h4>
                            <a class="btn btn-block btn-primary" href="https://www.clevelandjewishnews.com/users/login/?referer_url=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fcolumnists%2Fcliff_savren%2Fisrael-needs-to-look-beyond-netanyahu-in-next-election%2Farticle_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html" rel="nofollow">Log In</a>
                        </div>
                        <div class="user-signup">
                            <strong>Don't have an account?</strong> <a href="https://www.clevelandjewishnews.com/users/signup/?referer_url=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fcolumnists%2Fcliff_savren%2Fisrael-needs-to-look-beyond-netanyahu-in-next-election%2Farticle_6fb0c844-0214-11ed-8c92-e39f5ec5cd80.html" rel="nofollow">Sign Up Today</a>
                        </div>
                    </div>
                </div>
            </div>
        </template>

        <div id="follow-this-modal" class="modal fade follow-this-modal">
            <div class="modal-dialog"></div>
        </div></div></div>
                        </div>
                    </div>
                </div>
            </article>
                            </div>
                        
                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div>

                    <div class="asset-comments hidden-print">
                
                <div id="comments-container" class="comments-container">
                    
                    <div
                        id="comments" 
                        class="fb-comments" 
                        data-href="http://www.clevelandjewishnews.com/tncms/asset/editorial/6fb0c844-0214-11ed-8c92-e39f5ec5cd80/" 
                        data-num-posts="10" 
                        data-width="100%" 
                    ></div>
                    <style>
                        .fb_iframe_widget,
                        .fb_iframe_widget span,
                        .fb_iframe_widget span iframe[style]{
                            min-width:100%!important;
                            width:100%!important;
                        }
                    </style>
                </div>
            
        </div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div>
<div class="row">
    <div class="col-sm-6 col-md-12">
    
    <div id="tncms-region-global-side-attic" class="tncms-region "><div id="tncms-block-1543672" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1543672" class="tnt-ads dfp-ad" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1543672');
                        googletag.pubads().refresh([gptAdSlots['ad-1543672']]);
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-1179857" class="tncms-block"><section id="block-1179857" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1179857 ">
        <div class="block-title-inner">
            <h4>
                
                CJN Most Popular
                
            </h4>
        </div>
    </div></div>
    <div class="card">
        <ul class="list-unstyled list-popular"><li>
                    
                        <h4 class="tnt-headline ">
        
             <a href="/news/local_news/youngstown-area-teen-arrested-planned-to-target-synagogue/article_8d72dbec-fedb-11ec-99af-a7fa7122b837.html" class="tnt-asset-link" aria-label="Youngstown-area teen arrested; planned to target synagogue">
        

        
            Youngstown-area teen arrested; planned to target synagogue</a></h4>
                    
                </li><li>
                    
                        <h4 class="tnt-headline ">
        
             <a href="/news/local_news/kosher-hot-dogs-at-progressive-field-not-certified-kosher/article_5fa7ea04-fdeb-11ec-be85-1f90f4e99761.html" class="tnt-asset-link" aria-label="'Kosher hot dogs' at Progressive Field not certified kosher">
        

        
            'Kosher hot dogs' at Progressive Field not certified kosher</a></h4>
                    
                </li><li>
                    
                        <h4 class="tnt-headline ">
        
             <a href="/news/local_news/rabbi-weiss-pleads-not-guilty-lawyer-hopes-to-avoid-trial/article_ccd02650-fe27-11ec-97d4-3fb3deb72d20.html" class="tnt-asset-link" aria-label="Rabbi Weiss pleads not guilty; lawyer hopes to avoid trial">
        

        
            Rabbi Weiss pleads not guilty; lawyer hopes to avoid trial</a></h4>
                    
                </li><li>
                    
                        <h4 class="tnt-headline ">
        
             <a href="/news/local_news/at-100-tucker-us-oldest-practicing-physician-with-no-sign-of-slowing-down/article_7ccb9156-fe33-11ec-9b7e-d7e7ce5eb6dc.html" class="tnt-asset-link" aria-label="At 100, Tucker US’ oldest practicing physician – with no sign of slowing down">
        

        
            At 100, Tucker US’ oldest practicing physician – with no sign of slowing down</a></h4>
                    
                </li><li>
                    
                        <h4 class="tnt-headline ">
        
             <a href="/news/local_news/rabbi-ungar-to-serve-as-b-nai-jeshurun-adjunct-rabbi/article_3ede2d40-fe38-11ec-9957-bbd5917abad6.html" class="tnt-asset-link" aria-label="Rabbi Ungar to serve as B’nai Jeshurun adjunct rabbi">
        

        
            Rabbi Ungar to serve as B’nai Jeshurun adjunct rabbi</a></h4>
                    
                </li></ul>
    </div>
    
</section></div><div id="tncms-block-1543648" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1543648" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1543648');
                        
                });
            </script>
        </div>
    </div>
</div></div>    
    </div>
 </div>
<div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-1177644" class="tncms-block"></div><div id="tncms-block-1195515" class="tncms-block"><section id="block-1195515" class="block emphasis-h3 dark  " ><div class="card-panel panel">
        <div class="panel-body"><article class="card promo media"><div class="media-body"><h3 class="media-heading">Sign up for e-news</h3><p>Choose from the CJN's informative e-newsletters. </p><a href="/esignup">
                <button type="button" class="btn btn-danger  ">Sign up</button>
            </a></div>
</article></div>
    </div></section></div></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-1543680" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1543680" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1543680');
                        
                });
            </script>
        </div>
    </div>
</div></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "><div id="tncms-block-1543681" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1543681" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1543681');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-1164789" class="tncms-block"><section id="block-1164789" class="block emphasis-h3 light  " ><div class="card-panel panel">
        <div class="panel-body"><article class="card promo media"><div class="media-body"><h3 class="media-heading">Submit your news</h3><p>We're always interested in hearing about news in our community. Let us know what's going on!</p><a href="https://www.clevelandjewishnews.com/site/forms/online_services/submit_news/submit_news/">
                <button type="button" class="btn btn-info  ">Submit news</button>
            </a></div>
</article></div>
    </div></section></div></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-1177945" class="tncms-block"><section id="block-1177945" class="block emphasis-h3   " ><div class="clearfix">
        <ul class="list-inline block-links pos-top ">
            
                
                    <li><a href="/features/multimedia/videos/" class="">Videos</a></li>
                
                    <li><a href="/features/multimedia/photo_gallery/" class="">Photo Galleries</a></li>
                
            
            
        </ul>
    
    <div class="block-title title-1177945 ">
        <div class="block-title-inner">
            <h3>
                
                Don't miss
                
            </h3>
        </div>
    </div></div><div class="card-grid   card-img-md card-bg-color">
        
        
            <div class=" row equal equal-wrap">
        
        <div class=" col-sm-3 ">
                 
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                                
                    <article id="card-summary-1177945-f3502a96-fc97-11ec-80e2-bbfbdb0bb4d8" class="tnt-asset-type-article clearfix card summary has-image image-top inherit letterbox-style-default  tnt-section-news tnt-sub-section-local-news">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-f3502a96-fc97-11ec-80e2-bbfbdb0bb4d8 media-preview article-asset " data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/local_news/175-enjoy-federation-s-yld-summer-soiree/article_f3502a96-fc97-11ec-80e2-bbfbdb0bb4d8.html" class="tnt-asset-link"  aria-label="175 enjoy Federation’s YLD Summer Soiree">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="175 enjoy Federation’s YLD Summer Soiree"
                            class="img-responsive lazyload full default"
                            width="1765"
                            height="993"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/8/53/853a1584-fc98-11ec-8508-1f81a984e9d6/62c490a632b68.image.jpg?crop=1765%2C993%2C0%2C90&resize=150%2C84&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/8/53/853a1584-fc98-11ec-8508-1f81a984e9d6/62c490a632b68.image.jpg?crop=1765%2C993%2C0%2C90&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/8/53/853a1584-fc98-11ec-8508-1f81a984e9d6/62c490a632b68.image.jpg?crop=1765%2C993%2C0%2C90&resize=225%2C127&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/8/53/853a1584-fc98-11ec-8508-1f81a984e9d6/62c490a632b68.image.jpg?crop=1765%2C993%2C0%2C90&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/8/53/853a1584-fc98-11ec-8508-1f81a984e9d6/62c490a632b68.image.jpg?crop=1765%2C993%2C0%2C90&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/8/53/853a1584-fc98-11ec-8508-1f81a984e9d6/62c490a632b68.image.jpg?crop=1765%2C993%2C0%2C90&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/8/53/853a1584-fc98-11ec-8508-1f81a984e9d6/62c490a632b68.image.jpg?crop=1765%2C993%2C0%2C90&resize=640%2C360&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/8/53/853a1584-fc98-11ec-8508-1f81a984e9d6/62c490a632b68.image.jpg?crop=1765%2C993%2C0%2C90&resize=750%2C422&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/8/53/853a1584-fc98-11ec-8508-1f81a984e9d6/62c490a632b68.image.jpg?crop=1765%2C993%2C0%2C90&resize=990%2C557&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/8/53/853a1584-fc98-11ec-8508-1f81a984e9d6/62c490a632b68.image.jpg?crop=1765%2C993%2C0%2C90&resize=1035%2C582&order=crop%2Cresize 1035w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/8/53/853a1584-fc98-11ec-8508-1f81a984e9d6/62c490a632b68.image.jpg?crop=1765%2C993%2C0%2C90&resize=1200%2C675&order=crop%2Cresize 1200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/8/53/853a1584-fc98-11ec-8508-1f81a984e9d6/62c490a632b68.image.jpg?crop=1765%2C993%2C0%2C90&resize=1333%2C750&order=crop%2Cresize 1333w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/8/53/853a1584-fc98-11ec-8508-1f81a984e9d6/62c490a632b68.image.jpg?crop=1765%2C993%2C0%2C90&resize=1476%2C830&order=crop%2Cresize 1476w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/8/53/853a1584-fc98-11ec-8508-1f81a984e9d6/62c490a632b68.image.jpg?crop=1765%2C993%2C0%2C90&resize=1765%2C993&order=crop%2Cresize 2008w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-labels">
            
                
                <div class="card-label-section text-muted">
                    <a href="/news/local_news" class="tnt-section-tag">Local News</a>
                </div>
            
            </div>
        <div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/news/local_news/175-enjoy-federation-s-yld-summer-soiree/article_f3502a96-fc97-11ec-80e2-bbfbdb0bb4d8.html" class="tnt-asset-link" aria-label="175 enjoy Federation’s YLD Summer Soiree">
        

        
            175 enjoy Federation’s YLD Summer Soiree</a></h3></div>
    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
                </div>
                
            
            
            
                
            
            
        <div class=" col-sm-3 ">
                 
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                                
                    <article id="card-summary-1177945-70587fa4-fed0-11ec-8438-af88b8253614" class="tnt-asset-type-article clearfix card summary has-image image-top inherit letterbox-style-default  tnt-section-news tnt-sub-section-local-news">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-70587fa4-fed0-11ec-8438-af88b8253614 media-preview article-asset " data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/local_news/mandel-myers-fellows-inaugural-class-announced/article_70587fa4-fed0-11ec-8438-af88b8253614.html" class="tnt-asset-link"  aria-label="Mandel Myers Fellows inaugural class announced">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="Mandel Myers Fellows inaugural class announced"
                            class="img-responsive lazyload full default"
                            width="1754"
                            height="987"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/7/05/70587fa4-fed0-11ec-8438-af88b8253614/62c84d383e705.preview.jpg?crop=1754%2C987%2C0%2C97&resize=150%2C84&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/7/05/70587fa4-fed0-11ec-8438-af88b8253614/62c84d383e705.preview.jpg?crop=1754%2C987%2C0%2C97&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/7/05/70587fa4-fed0-11ec-8438-af88b8253614/62c84d383e705.preview.jpg?crop=1754%2C987%2C0%2C97&resize=225%2C127&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/7/05/70587fa4-fed0-11ec-8438-af88b8253614/62c84d383e705.preview.jpg?crop=1754%2C987%2C0%2C97&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/7/05/70587fa4-fed0-11ec-8438-af88b8253614/62c84d383e705.preview.jpg?crop=1754%2C987%2C0%2C97&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/7/05/70587fa4-fed0-11ec-8438-af88b8253614/62c84d383e705.preview.jpg?crop=1754%2C987%2C0%2C97&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/7/05/70587fa4-fed0-11ec-8438-af88b8253614/62c84d383e705.preview.jpg?crop=1754%2C987%2C0%2C97&resize=640%2C360&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/7/05/70587fa4-fed0-11ec-8438-af88b8253614/62c84d383e705.preview.jpg?crop=1754%2C987%2C0%2C97&resize=750%2C422&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/7/05/70587fa4-fed0-11ec-8438-af88b8253614/62c84d383e705.preview.jpg?crop=1754%2C987%2C0%2C97&resize=990%2C557&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/7/05/70587fa4-fed0-11ec-8438-af88b8253614/62c84d383e705.preview.jpg?crop=1754%2C987%2C0%2C97&resize=1035%2C582&order=crop%2Cresize 1035w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/7/05/70587fa4-fed0-11ec-8438-af88b8253614/62c84d383e705.preview.jpg?crop=1754%2C987%2C0%2C97&resize=1200%2C675&order=crop%2Cresize 1200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/7/05/70587fa4-fed0-11ec-8438-af88b8253614/62c84d383e705.preview.jpg?crop=1754%2C987%2C0%2C97&resize=1333%2C750&order=crop%2Cresize 1333w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/7/05/70587fa4-fed0-11ec-8438-af88b8253614/62c84d383e705.preview.jpg?crop=1754%2C987%2C0%2C97&resize=1476%2C830&order=crop%2Cresize 1476w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/7/05/70587fa4-fed0-11ec-8438-af88b8253614/62c84d383e705.preview.jpg?crop=1754%2C987%2C0%2C97&resize=1754%2C987&order=crop%2Cresize 2008w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-labels">
            
                
                <div class="card-label-section text-muted">
                    <a href="/news/local_news" class="tnt-section-tag">Local News</a>
                </div>
            
            </div>
        <div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/news/local_news/mandel-myers-fellows-inaugural-class-announced/article_70587fa4-fed0-11ec-8438-af88b8253614.html" class="tnt-asset-link" aria-label="Mandel Myers Fellows inaugural class announced">
        

        
            Mandel Myers Fellows inaugural class announced</a></h3></div>
    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
                </div>
                
            
            
            
                
            
            
        <div class=" col-sm-3 ">
                 
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                                
                    <article id="card-summary-1177945-e859162c-feca-11ec-895f-2f0f82c180ef" class="tnt-asset-type-article clearfix card summary has-image image-top inherit letterbox-style-default  tnt-section-news tnt-sub-section-local-news">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-e859162c-feca-11ec-895f-2f0f82c180ef media-preview article-asset " data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/local_news/leadership-cleveland-class-of-2023-named/article_e859162c-feca-11ec-895f-2f0f82c180ef.html" class="tnt-asset-link"  aria-label="Leadership Cleveland Class of 2023 named">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="Leadership Cleveland Class of 2023 named"
                            class="img-responsive lazyload full default"
                            width="1863"
                            height="1048"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/c/e2/ce2606fa-c85f-11ea-8405-272d26386a6a/5f11f58bcfa93.image.jpg?crop=1863%2C1048%2C57%2C0&resize=150%2C84&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/c/e2/ce2606fa-c85f-11ea-8405-272d26386a6a/5f11f58bcfa93.image.jpg?crop=1863%2C1048%2C57%2C0&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/c/e2/ce2606fa-c85f-11ea-8405-272d26386a6a/5f11f58bcfa93.image.jpg?crop=1863%2C1048%2C57%2C0&resize=225%2C127&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/c/e2/ce2606fa-c85f-11ea-8405-272d26386a6a/5f11f58bcfa93.image.jpg?crop=1863%2C1048%2C57%2C0&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/c/e2/ce2606fa-c85f-11ea-8405-272d26386a6a/5f11f58bcfa93.image.jpg?crop=1863%2C1048%2C57%2C0&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/c/e2/ce2606fa-c85f-11ea-8405-272d26386a6a/5f11f58bcfa93.image.jpg?crop=1863%2C1048%2C57%2C0&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/c/e2/ce2606fa-c85f-11ea-8405-272d26386a6a/5f11f58bcfa93.image.jpg?crop=1863%2C1048%2C57%2C0&resize=640%2C360&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/c/e2/ce2606fa-c85f-11ea-8405-272d26386a6a/5f11f58bcfa93.image.jpg?crop=1863%2C1048%2C57%2C0&resize=750%2C422&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/c/e2/ce2606fa-c85f-11ea-8405-272d26386a6a/5f11f58bcfa93.image.jpg?crop=1863%2C1048%2C57%2C0&resize=990%2C557&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/c/e2/ce2606fa-c85f-11ea-8405-272d26386a6a/5f11f58bcfa93.image.jpg?crop=1863%2C1048%2C57%2C0&resize=1035%2C582&order=crop%2Cresize 1035w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/c/e2/ce2606fa-c85f-11ea-8405-272d26386a6a/5f11f58bcfa93.image.jpg?crop=1863%2C1048%2C57%2C0&resize=1200%2C675&order=crop%2Cresize 1200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/c/e2/ce2606fa-c85f-11ea-8405-272d26386a6a/5f11f58bcfa93.image.jpg?crop=1863%2C1048%2C57%2C0&resize=1333%2C750&order=crop%2Cresize 1333w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/c/e2/ce2606fa-c85f-11ea-8405-272d26386a6a/5f11f58bcfa93.image.jpg?crop=1863%2C1048%2C57%2C0&resize=1476%2C830&order=crop%2Cresize 1476w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/c/e2/ce2606fa-c85f-11ea-8405-272d26386a6a/5f11f58bcfa93.image.jpg?crop=1863%2C1048%2C57%2C0&resize=1863%2C1048&order=crop%2Cresize 2008w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-labels">
            
                
                <div class="card-label-section text-muted">
                    <a href="/news/local_news" class="tnt-section-tag">Local News</a>
                </div>
            
            </div>
        <div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/news/local_news/leadership-cleveland-class-of-2023-named/article_e859162c-feca-11ec-895f-2f0f82c180ef.html" class="tnt-asset-link" aria-label="Leadership Cleveland Class of 2023 named">
        

        
            Leadership Cleveland Class of 2023 named</a></h3></div>
    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
                </div>
                
            
            
            
                
            
            
        <div class=" col-sm-3 last-grid-item">
                 
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                                
                    <article id="card-summary-1177945-7ccb9156-fe33-11ec-9b7e-d7e7ce5eb6dc" class="tnt-asset-type-article clearfix card summary has-image image-top inherit letterbox-style-default  tnt-section-news tnt-sub-section-local-news">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-7ccb9156-fe33-11ec-9b7e-d7e7ce5eb6dc media-preview article-asset " data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/local_news/at-100-tucker-us-oldest-practicing-physician-with-no-sign-of-slowing-down/article_7ccb9156-fe33-11ec-9b7e-d7e7ce5eb6dc.html" class="tnt-asset-link"  aria-label="At 100, Tucker US’ oldest practicing physician – with no sign of slowing down">
                
                
                    <div class="asset-icon"><i class="fas tnt-camera tnt-fw" title="Article with images"></i><span class="hidden-xs icon-count">+5</span></div>
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="At 100, Tucker US’ oldest practicing physician – with no sign of slowing down"
                            class="img-responsive lazyload full default"
                            width="1284"
                            height="722"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/1/97/1974b80c-fe34-11ec-a17a-bf85cb8a3485/62c7432a0be5c.image.jpg?crop=1284%2C722%2C0%2C162&resize=150%2C84&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/1/97/1974b80c-fe34-11ec-a17a-bf85cb8a3485/62c7432a0be5c.image.jpg?crop=1284%2C722%2C0%2C162&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/1/97/1974b80c-fe34-11ec-a17a-bf85cb8a3485/62c7432a0be5c.image.jpg?crop=1284%2C722%2C0%2C162&resize=225%2C127&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/1/97/1974b80c-fe34-11ec-a17a-bf85cb8a3485/62c7432a0be5c.image.jpg?crop=1284%2C722%2C0%2C162&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/1/97/1974b80c-fe34-11ec-a17a-bf85cb8a3485/62c7432a0be5c.image.jpg?crop=1284%2C722%2C0%2C162&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/1/97/1974b80c-fe34-11ec-a17a-bf85cb8a3485/62c7432a0be5c.image.jpg?crop=1284%2C722%2C0%2C162&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/1/97/1974b80c-fe34-11ec-a17a-bf85cb8a3485/62c7432a0be5c.image.jpg?crop=1284%2C722%2C0%2C162&resize=640%2C360&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/1/97/1974b80c-fe34-11ec-a17a-bf85cb8a3485/62c7432a0be5c.image.jpg?crop=1284%2C722%2C0%2C162&resize=750%2C422&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/1/97/1974b80c-fe34-11ec-a17a-bf85cb8a3485/62c7432a0be5c.image.jpg?crop=1284%2C722%2C0%2C162&resize=990%2C557&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/1/97/1974b80c-fe34-11ec-a17a-bf85cb8a3485/62c7432a0be5c.image.jpg?crop=1284%2C722%2C0%2C162&resize=1035%2C582&order=crop%2Cresize 1035w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/1/97/1974b80c-fe34-11ec-a17a-bf85cb8a3485/62c7432a0be5c.image.jpg?crop=1284%2C722%2C0%2C162&resize=1200%2C675&order=crop%2Cresize 1200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/1/97/1974b80c-fe34-11ec-a17a-bf85cb8a3485/62c7432a0be5c.image.jpg?crop=1284%2C722%2C0%2C162&resize=1284%2C722&order=crop%2Cresize 1333w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-labels">
            
                
                <div class="card-label-section text-muted">
                    <a href="/news/local_news" class="tnt-section-tag">Local News</a>
                </div>
            
            </div>
        <div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/news/local_news/at-100-tucker-us-oldest-practicing-physician-with-no-sign-of-slowing-down/article_7ccb9156-fe33-11ec-9b7e-d7e7ce5eb6dc.html" class="tnt-asset-link" aria-label="At 100, Tucker US’ oldest practicing physician – with no sign of slowing down">
        

        
            At 100, Tucker US’ oldest practicing physician – with no sign of slowing down</a></h3></div>
    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
                </div>
                
            
            
            
                
                    <div class="clearfix hidden-xs"></div>
                
            
            
        
        <div class="clearfix hidden-xs"></div>
        
        
        </div>
        </div></section></div><div id="tncms-block-1543684" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1543684" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1543684');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
<!-- code here -->

                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-1164761" class="tncms-block"><section id="block-1164761" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1164761 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link    tnt-section-about-the-cjn"  href="/site/about.html"  tabindex="0" >
                    <span class="nav-label ">About the CJN</span>
                </a></li><li>
                <a class="nav-link    tnt-section-advertise"  href="/site/advertise"  tabindex="0" >
                    <span class="nav-label ">Advertise</span>
                </a></li><li>
                <a class="nav-link    tnt-section-cjn-board-of-directors"  href="/site/cjn_board_of_directors.html"  tabindex="0" >
                    <span class="nav-label ">CJN Board of Directors</span>
                </a></li><li>
                <a class="nav-link    tnt-section-cjn-foundation-board-of-directors"  href="/cjn_foundation/"  tabindex="0" >
                    <span class="nav-label ">CJN Foundation Board of Directors</span>
                </a></li><li>
                <a class="nav-link    tnt-section-cjn-tomorrow"  href="/cjn_tomorrow/"  tabindex="0" >
                    <span class="nav-label ">CJN Tomorrow</span>
                </a></li><li>
                <a class="nav-link    tnt-section-contact-us"  href="/site/contact.html"  tabindex="0" >
                    <span class="nav-label ">Contact Us</span>
                </a></li><li>
                <a class="nav-link    tnt-section-digital-edition"  href="https://cjn.newzware.com/ss70v2/cjn/common/template.jsp"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">Digital Edition</span>
                </a></li><li>
                <a class="nav-link    tnt-section-employment"  href="/employment/"  tabindex="0" >
                    <span class="nav-label ">Employment</span>
                </a></li><li>
                <a class="nav-link    tnt-section-manage-your-subscription"  href="https://cjn.newzware.com/ss70v2/cjn/common/template.jsp"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">Manage Your Subscription</span>
                </a></li><li>
                <a class="nav-link    tnt-section-promote-your-event"  href="https://new.evvnt.com/?with_navbar&amp;force_snap_sell&amp;partner=CLEVELANDJEWISHNEWS&amp;publisher_url:clevelandjewishnews.com#/quick"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">Promote Your Event</span>
                </a></li><li>
                <a class="nav-link    tnt-section-policies"  href="/site/policies.html"  tabindex="0" >
                    <span class="nav-label ">Policies</span>
                </a></li><li>
                <a class="nav-link    tnt-section-sign-up-for-cjn-emails"  href="/esignup"  tabindex="0" >
                    <span class="nav-label ">Sign up for CJN emails</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-1164762" class="tncms-block"><section id="block-1164762" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1164762 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link    tnt-section-news"  href="/news"  tabindex="0" >
                    <span class="nav-label ">News</span>
                </a></li><li>
                <a class="nav-link    tnt-section-features"  href="/features"  tabindex="0" >
                    <span class="nav-label ">Features</span>
                </a></li><li>
                <a class="nav-link    tnt-section-opinion"  href="/opinion"  tabindex="0" >
                    <span class="nav-label ">Opinion</span>
                </a></li><li>
                <a class="nav-link    tnt-section-community"  href="/community/"  tabindex="0" >
                    <span class="nav-label ">Community</span>
                </a></li><li>
                <a class="nav-link    tnt-section-obituaries"  href="/community/lifecycles/obituaries/"  tabindex="0" >
                    <span class="nav-label ">Obituaries</span>
                </a></li><li>
                <a class="nav-link    tnt-section-events"  href="/local-events/"  tabindex="0" >
                    <span class="nav-label ">Events</span>
                </a></li><li>
                <a class="nav-link    tnt-section-magazines"  href="/magazines/"  tabindex="0" >
                    <span class="nav-label ">Magazines</span>
                </a></li><li>
                <a class="nav-link    tnt-section-classifieds"  href="/classifieds"  tabindex="0" >
                    <span class="nav-label ">Classifieds</span>
                </a></li><li>
                <a class="nav-link    tnt-section-the-samuel-h-miller-keeping-our-words-alive-digital-archive-of-the-cleveland-jewish-news"  href="http://digital.olivesoftware.com/Olive/APA/ClevelandJewishNewsFree/default.aspx"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">The Samuel H. Miller Keeping Our Words Alive Digital Archive of the Cleveland Jewish News</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-1164777" class="tncms-block padding-bottom"><section id="block-1164777" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow"  >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/db9d3d76-da4d-11e5-b7df-4319d6ed90dd.gif?resize=150%2C37 150w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/db9d3d76-da4d-11e5-b7df-4319d6ed90dd.gif?resize=200%2C49 200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/db9d3d76-da4d-11e5-b7df-4319d6ed90dd.gif?resize=225%2C55 225w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/db9d3d76-da4d-11e5-b7df-4319d6ed90dd.gif?resize=300%2C73 300w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/db9d3d76-da4d-11e5-b7df-4319d6ed90dd.gif?resize=400%2C98 400w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/db9d3d76-da4d-11e5-b7df-4319d6ed90dd.gif?resize=540%2C132 540w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/db9d3d76-da4d-11e5-b7df-4319d6ed90dd.gif?resize=640%2C156 640w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/db9d3d76-da4d-11e5-b7df-4319d6ed90dd.gif?resize=750%2C183 750w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/db9d3d76-da4d-11e5-b7df-4319d6ed90dd.gif 990w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="757"
                height="185"
                alt=""
                aria-hidden="true"></a></div></section></div><div id="tncms-block-1164767" class="tncms-block"><section id="block-1164767" class="block emphasis-h4   " ><address>
    <strong>cjn.org</strong><br>
    23880 Commerce Park, Suite 1<br>
    Beachwood, OH 44122
    <br>
    
        <span class="fas tnt-phone" title="Phone"></span> 216-454-8300<br>
        <span class="fas tnt-envelope" title="Email address"></span> <a href="mailto:webinfo@cjn.org">webinfo@cjn.org</a><br>
    
</address></section></div><div id="tncms-block-1164786" class="tncms-block padding-bottom"><div class="follow-links-1164786 default">
    
    <section id="block-1164786" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1164786 ">
        <div class="block-title-inner">
            <h4>
                
                Connect with us
                
            </h4>
        </div>
    </div></div><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/ClevelandJewishNews" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/CleveJN" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://www.linkedin.com/company/cleveland-jewish-publication-company" title="LinkedIn" target="_blank" rel="noopener" class="btn btn-md btn-link li" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-linkedin-in"></i>
                    <span class="sr-only">LinkedIn</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://www.youtube.com/user/CleveJN" title="Youtube" target="_blank" rel="noopener" class="btn btn-md btn-link yt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://www.instagram.com/clevejn/" title="Instagram" target="_blank" rel="noopener" class="btn btn-md btn-link is" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.clevelandjewishnews.com",
  "sameAs" : ["https://www.facebook.com/ClevelandJewishNews","https://twitter.com/CleveJN","https://www.linkedin.com/company/cleveland-jewish-publication-company","https://www.youtube.com/user/CleveJN","https://www.instagram.com/clevejn/"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                



<div class="row">
<div class="col-sm-4"><div id="tncms-region-option-footer-upper-left" class="tncms-region "><div id="tncms-block-1279078" class="tncms-block"><div class="option-footer-navigation-container">
<h4><a href="/site/contact.html">Contact Us</a></h4>

<ul class="nav nav-pills nav-stacked"><li><a href="/site/forms/online_services/submit_news/submit_news">Submit News</a></li>
  <li><a href="/site/forms/online_services/letter/letter_editor">Send a Letter to the Editor</a></li>
  <li><a href="https://new.evvnt.com/?with_navbar&amp;force_snap_sell&amp;partner=CLEVELANDJEWISHNEWS&amp;publisher_url:clevelandjewishnews.com#/quick">Promote Your Event</a></li>
  <li><a href="https://cjn.newzware.com/ss70v2/cjn/common/template.jsp" target="_blank">Manage your subscription</a></li>
</ul></div></div></div></div>
<div class="col-sm-4"><div id="tncms-region-option-footer-upper-middle" class="tncms-region "><div id="tncms-block-1279079" class="tncms-block"><div class="option-footer-navigation-container">
<h4><a href="/site/advertise/">Advertising</a></h4>

<ul class="nav nav-pills nav-stacked">
<li><a href="mailto:adsales@cjn.org">Place a Classified ad</a></li>
  <li><a href="mailto:adsales@cjn.org">Display advertising</a></li>
  <li><a href="mailto:adsales@cjn.org">Magazine advertising</a></li>
  <li><a href="mailto:adsales@cjn.org">Custom publishing</a></li>
</ul>
</div></div></div></div>
<div class="col-sm-4"><div id="tncms-region-option-footer-upper-right" class="tncms-region "><div id="tncms-block-1279080" class="tncms-block"><div class="option-footer-navigation-container lifecycles1">
<h4><a href="/site/forms/announcements/">Submit LifeCycles Announcements</a></h4>

<div class="row">
<div class="col-sm-6 lifecycles-left">
<ul class="nav nav-pills nav-stacked ">
<li><a href="/site/forms/announcements/anniversary/anniversaries">Anniversaries</a></li>
  <li><a href="/site/forms/announcements/birth/birth_announcement">Births</a></li>
  <li><a href="/site/forms/announcements/bnai_mitzvah/bnai_mitzvah">B-nai Mitzvah</a></li>
  <li><a href="/site/forms/announcements/engagement_announcements/engagement_announcements">Engagement</a></li>
</ul>
</div>


<div class="col-sm-6 lifecycles-right">
<ul class="nav nav-pills nav-stacked ">
<li><a href="/site/forms/announcements/marriage_announcements/marriage_announcement">Wedding</a></li>
  <li><a href="/site/forms/announcements/obituary/obituaries">Obituary</a></li>
  <li><a href="/site/forms/announcements/unveilings/unveiling">Unveiling</a></li>
</ul>
</div>
</div>
</div></div></div></div>
</div>

<div class="row">
<div class="col-sm-4 col-md-3"><div id="tncms-region-option-footer-lower-left" class="tncms-region "><div id="tncms-block-1180687" class="tncms-block padding-bottom padding-top"><section id="block-1180687" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow"  >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/1a54ec24-e545-11e5-9150-0737937624cb.png?resize=150%2C53 150w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/1a54ec24-e545-11e5-9150-0737937624cb.png 200w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="200"
                height="71"
                alt=""
                aria-hidden="true"></a></div></section></div></div></div>
<div class="col-sm-4 col-md-3"><div id="tncms-region-option-footer-lower-middle" class="tncms-region "><div id="tncms-block-1279085" class="tncms-block"><div class="option-footer-logo-navigation-container">
<ul class="list-unstyled">
<li><a href="http://www.cjn.org">Cleveland Jewish News </a></li>
<li><a href="http://www.columbusjewishnews.com">Columbus Jewish News</a></li>
<li><a href="http://www.akronjewishnews.com">Akron Jewish News</a></li>
</ul>
</div></div></div></div>
<div class="col-sm-4 col-md-6"><div id="tncms-region-option-footer-lower-right" class="tncms-region "><div id="tncms-block-1279086" class="tncms-block"><div class="option-footer-logo-navigation-container">
<ul class="list-unstyled">
  <li><a href="http://jstylemagazine.com" target="_blank">Jstyle</a></li>
  <li><a href="http://canvascle.com" target="_blank">Canvas</a></li>
  <li><a href="/magazines/barbat">Bar-Bat Mitzvah</a></li>
  <li><a href="/magazines/source/">SOURCE</a></li>
</ul>
</div></div></div></div>
</div>

<div class="row">
<div class="col-sm-12"><div id="tncms-region-option-footer-full-bottom" class="tncms-region "></div></div>
</div>




<!-- code here -->
<script type="text/javascript">
$(document).ready(function(){
$('.user-calendar #create-event-form input#website').attr("placeholder","http://www.example.com");
});
</script>

<!-- #603409 -->
<!-- BEGIN PRIVY WIDGET CODE -->
<script type='text/javascript'>
var _d_site = _d_site || '24CCE662028DDE17D7646AB8';
(function(w, d, p, s, s2) {
w[p] = w[p] || function() { (w[p].q = w[p].q || []).push(arguments) };
s = d.createElement('script'); s.async = 1; s.src = '//widget.privy.com/assets/widget.js';
s2 = d.getElementsByTagName('script')[0]; s2.parentNode.insertBefore(s, s2);
})(window, document, 'Privy');
</script>
<!-- END PRIVY WIDGET CODE -->



            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-1164768" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-1164768"><div class="col-xs-12"><small>© Copyright 2022 Cleveland Jewish News, 23880 Commerce Park, Suite 1 Beachwood, OH </small><small>&nbsp;| <a href="/site/terms.html">Terms of Use</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }
        });
    </script>
<script>
        __tnt.trackEvent = function(obj) {
            if( jQuery.type(obj) === 'object' ){
                 
                    if(obj.category && obj.action){
                        __tnt.googleEvent(obj);
                    } else if(obj.network && obj.socialAction){
                        __tnt.googleSocial(obj);
                    } else if(obj.url){
                        __tnt.googlePageView(obj);
                    }
                    if(typeof TNCMS.Tracking != 'undefined' && obj.metric){
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
                
            }
        }
        
        if(__tnt.trackEventLater.length > 0){
            jQuery(__tnt.trackEventLater).each(function(){
                __tnt.trackEvent($(this));
            });
        }
        jQuery('body').on(__tnt.client.clickEvent, '[data-track]', function(){
            var trkObj = jQuery(this).data('track');
            __tnt.trackEvent(trkObj);
        });
        jQuery('body').on(__tnt.client.clickEvent, '[data-tncms-track-event]', function(){
            var trkObj = jQuery(this).data('tncms-track-event');
            __tnt.trackEvent(trkObj);
        });
        jQuery('body').on(__tnt.client.clickEvent, '[data-tncms-track-dmp]', function(){
            var dmpData = jQuery(this).data('tncms-track-dmp');
            _cc10228.add('act', dmpData);_cc10228.bcp();});
    </script>
    

    
    
    
  <script type="text/javascript" charset="utf-8" src="https://www.sefaria.org/linker.js"></script>
	<script>
	    sefaria.link();
	</script>
  
  
    <!-- scc Ticket #639775 -->
    <!-- Begin Constant Contact Active Forms -->
<script> var _ctct_m = "19f8ac0798a1c8655f7c580f30b6c87a"; </script>
<script id="signupScript" src="//static.ctctcdn.com/js/signup-form-widget/current/signup-form-widget.min.js" async defer></script>
<!-- End Constant Contact Active Forms -->


<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script>/*<![CDATA[*/ (function(d) {
        
        var form = d.getElementById('site-search-1164782'),
            query_input = d.getElementById('site-search-1164782-term'),
            search_dropdown = d.getElementById('site-search-1164782-dropdown');
        
        /** Input focus */
        try {
            search_dropdown.onmouseenter = function(){
                setTimeout(function(){
                    query_input.focus();
                }, 700);
            };
        } catch (error) { 
            // No dropdown behavior
        }
        
        /** Submit handler */
        form.onsubmit = function(){
            // Filter query
            var elem = document.querySelector("#site-search-1164782 input[name=q]"),
        sQueryFiltered = elem.value.replace(/\?/g, '');
    elem.value = sQueryFiltered;
    
            // No submit if empty input
            if( query_input.val() ){
                return true;
            } else{
                return false;
            }
        };})(document); /*]]>*/</script>
<script>/*<![CDATA[*/ jQuery(document).ready(function($){
                                    $('#weather_zip_toggle_1164801').click(function(e){
                                        $('#weather-1164801 .zip-update-form').toggle('fast');
                                        return false; 
                                    });
                                }); /*]]>*/</script>
<script>/*<![CDATA[*/ function articleShareSticky(){
                setTimeout(function(){
                    var sMainTop = document.querySelector('#main-body-container').offsetTop,
                        oNavBar = document.querySelector('#site-navbar-container');
                    if (sMainTop < window.scrollY){
                        oNavBar.classList.add('article-share')
                    } else {
                        oNavBar.classList.remove('article-share')
                    }
                }, 150)
            }
            document.addEventListener('scroll', articleShareSticky); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                        !function(t,i,n){var e,a,s,o,c,d={init:function(){a=i.getElementById("site-navbar-container"),n.client.platform.ios?a.classList.add("affix-sticky"):(e=i.getElementById("main-body-container"),s=a.offsetHeight||a.clientHeight,o=!1,c=0,t.addEventListener("scroll",d.navPosition,!1),t.addEventListener("mousewheel",d.navPosition,!1))},navPosition:function(){o||(o=!0,setTimeout(function(){var n=a.getBoundingClientRect(),d=t.pageYOffset||i.documentElement.scrollTop,f=n.top+d;d>=f&&d>c?a.classList.contains("affix")||(c=f,a.classList.add("affix"),a.classList.remove("affix-top"),e.style.marginTop=s+"px"):a.classList.contains("affix-top")||(a.classList.remove("affix"),a.classList.add("affix-top"),e.style.marginTop="0px"),o=!1},25))}};"loading"==i.readyState?i.addEventListener("DOMContentLoaded",d.init,!1):d.init()}(window,document,__tnt);
                    document.addEventListener('DOMContentLoaded', function() {
                        var isIOS = /iPad|iPhone|iPod/.test(navigator.userAgent) && !window.MSStream;
                        if (isIOS) {
                            Array.from(document.querySelectorAll('[data-toggle="offcanvas"]')).forEach(function(drawer) {
                                drawer.addEventListener("mouseover", function(e) {
                                    var drawerCls = drawer.dataset.target === 'left' ? 'active-left' : 'active-right';
                                    document.documentElement.classList.add('drawer-open', drawerCls);
                                })
                            })
                        }
                    }); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.core.eb2d788dd02bb4634ca3eb2ee783cd11.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/owl.carousel.50dc41fa734414148ce4b489fd904c5f.js"></script>
<script>/*<![CDATA[*/ document.addEventListener('DOMContentLoaded',function(){
                    if (document.readyState != 'complete') {
                        document.addEventListener('readystatechange', function(ev) {
                            carouselInit_6fb0c844_0214_11ed_8c92_e39f5ec5cd80_photo_modal();
                        });
                    }  else {
                        carouselInit_6fb0c844_0214_11ed_8c92_e39f5ec5cd80_photo_modal();
                    }
                });// Carousel initialization
            function carouselInit_6fb0c844_0214_11ed_8c92_e39f5ec5cd80_photo_modal() {
                var gallery_ad_6fb0c844_0214_11ed_8c92_e39f5ec5cd80_photo_modal = false;
                var gallery_changed_6fb0c844_0214_11ed_8c92_e39f5ec5cd80_photo_modal = false;
                var sUrl =  window.location.href,
                        sUuid = sUrl.split("_").pop(),
                        sId = sUuid.substring(0, sUuid.indexOf('.')),
                        aInlineImages = document.querySelectorAll('.inline-image .image, .inline-image .expand');
                     for (i = 0; i < aInlineImages.length; ++i) {
                        var oImage = aInlineImages[i],
                            sInstance = oImage.getAttribute('data-instance'),
                            sTarget = oImage.getAttribute('data-target');
                        if (!oImage.classList.contains("tnt-asset-presentation-infographic")) {
                            if (sInstance != null && sTarget != null){
                                if (!sInstance.includes(sId)){
                                    oImage.setAttribute('data-instance', '#gallery-items-' + sId + '-photo-modal');
                                }
                                if (!sTarget.includes(sId)){
                                    oImage.setAttribute('data-target', '#photo-carousel-' + sId);
                                }
                            }
                        }
                     }
                $('#gallery-items-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-photo-modal').owlCarousel({
                    items: 1,
                    autoHeight: true,
                    lazyLoad: true,
                    loop: false,
                    navRewind: true,
                    responsiveRefreshRate: 500,
                    
                    
                    dots : false,
                    
                    onTranslated:function(){
                        
                        
                        
                            __tnt.trackEvent($('#gallery-items-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-photo-modal .photo-container').eq(this._current).data('track-object'));
                        

                        
                        

                        

                    }
                });
                
                var owl = $('#gallery-items-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-photo-modal');
                owl.on('changed.owl.carousel', function(event) {if( !$('#gallery-items-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-photo-modal .photo-container').eq(event.item.index).hasClass('engagement-stage') ){
                            setTimeout(function(){
                                $("#gallery-items-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-photo-modal .owl-stage-outer").height( $('#carousel-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-photo-modal .owl-item.active').height() );
                            }, 300);
                        }
                    
                    
                    

                    
                        var currItem = $('#gallery-items-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-photo-modal .photo-container').eq(event.item.index).data('count');
                        if(currItem){
                            $('#carousel-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-photo-modal .current-count').html(currItem);
                        }
                        $('.modal.in, #carousel-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-photo-modal .item').removeClass('hover');
                    
                    
                });
                
                var photo_carousel_6fb0c844_0214_11ed_8c92_e39f5ec5cd80_photo_modal = $('#gallery-items-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-photo-modal').data('owlCarousel');
                $('#carousel-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-photo-modal .photo-carousel-control.left').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_6fb0c844_0214_11ed_8c92_e39f5ec5cd80_photo_modal.prev();
                });
                $('#carousel-6fb0c844-0214-11ed-8c92-e39f5ec5cd80-photo-modal .photo-carousel-control.right').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_6fb0c844_0214_11ed_8c92_e39f5ec5cd80_photo_modal.next();
                });
            } /*]]>*/</script>
<script>/*<![CDATA[*/ 
                // open photo modal
                jQuery(document).ready(function($){
                    $('[data-photo-target]').on('click', function(e){
                        e.preventDefault();
                        var item_target = $(this).data('target');
                        // get item index
                        var item_index = $(item_target +' '+$(this).data('photo-target')).parent().index();
                        // get current instance of carousel
                        var carousel_instance = $(this).data('instance');
                        var carousel_instance_data = $(carousel_instance).data('owlCarousel');
                        // fix non explict widths at viewports less than 900.
                        if(carousel_instance_data.width() < 320 & carousel_instance_data.viewport() < 900){
                            carousel_instance_data.onThrottledResize();
                        }
                        // load item from index
                        carousel_instance_data.to(item_index, 100, true);
                        // open modal
                        $(item_target).modal({'show':true});
                        __tnt.trackEvent({'category':'tnt-lightbox','action':'carousel-open', 'label':'article', 'value':'1'});
                        return false;
                    });
                    $('.photo-carousel-caption-toggle').on(__tnt.client.clickEvent, function(e){
                        var item_instance = $(this).data('instance');
                        $(item_instance +' .photo-carousel-caption-toggle').find('[data-fa-i2svg]').attr('data-icon', $(item_instance +' .photo-carousel-caption-toggle').find('[data-fa-i2svg]').attr('data-icon') == 'minus-circle' ? 'plus-circle' : 'minus-circle');
                    });
                }); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.reactions.496ef4077c989f2b546ccbd9a5d4e1f9.js"></script>
<script>/*<![CDATA[*/ 
                        function dmpReactionData(){
                            var sReactionData = document.getElementById('hidden-type').value,
                                sReactionKeywords = "'Engage:Prime Minister','Engage:Yair Lapid','Engage:Benjamin Netanyahu','Engage:Politics','Engage:Institutes','Engage:Ministries','Engage:Israel','Engage:Naftali Bennett','Engage:Yair Golan','Engage:Arnon Milchan'";_cc10228.add('act', sReactionData, sReactionKeywords);_cc10228.bcp();} /*]]>*/</script>
<script>/*<![CDATA[*/ 
            jQuery(document).ready(function($){
                var iqLogin = $.cookie('tnt-iq-login') || false;
                if (__tnt.user.loggedIn && iqLogin == false) {
                    if (__tnt.user.services) {
                        var userServices = __tnt.user.services.split(',');
                        for (i = 0; i < userServices.length; i++) { 
                            var serviceData = 'has_subservice: ' + userServices[i];
                            _cc10228.add('act', serviceData);_cc10228.bcp();
                        }
                    }
                    $.cookie('tnt-iq-login', 1);
                }
            });
        
            if (window.location.hash){
                var hashSet = ['tncms_source','utm_source','utm_campaign','utm_medium','utm_content','utm_term'],
                    urlHash = window.location.hash.replace('#','').split('&');
                for (var i = 0; i < urlHash.length; i++) {
                    var data = urlHash[i].split('='),
                        param = data[0].replace('-','_');
                    if (hashSet.indexOf(param) != -1){
                        var dmpData = param + ': ' + data[1];
                        _cc10228.add('act', dmpData);_cc10228.bcp();
                    }
                }
            }
         /*]]>*/</script></body>
</html>