
  

<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.clevelandjewishnews.com/content/tncms/live/" />
<meta name="keywords" content="stephen jackson, desean jackson, sport, politics, sociology, american football, basketball, michael wilbon, jew, stephen a. smith, louis farrakhan, conspiracy theory" />
<meta name="news_keywords" content="stephen jackson, desean jackson, sport, politics, sociology, american football, basketball, michael wilbon, jew, stephen a. smith, louis farrakhan, conspiracy theory" />
<meta name="description" content="(JTA) &mdash; NFL wide receiver DeSean Jackson unleashed an uproar with his tweets over the weekend that featured quotes dubiously attributed to Adolf Hitler &mdash; including claims that &ldquo;white Jews&rdquo;" />
<meta name="author" content="Gabe Friedman" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="google-site-verification" content="&lt;script&gt;   (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){   (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),   m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)   })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');    ga('create', 'UA-26323411-3', 'auto');   ga('send', 'pageview');  &lt;/script&gt;" />
<meta name="msvalidate.01" content="5F21ED69D2FEF30FBDC51E99D287C6D5" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.clevelandjewishnews.com/jta/stephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his/article_900e466f-e431-5248-85a7-dc26e62e9d3e.html" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/7278b38c-b303-11e5-a1a2-a31281943715.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
<meta property="og:title" content="Stephen Jackson said DeSean Jackson is &lsquo;speaking the truth&rsquo; about Jews. Black commentators say his activism is now tainted." />
<meta property="og:description" content="(JTA) &mdash; NFL wide receiver DeSean Jackson unleashed an uproar with his tweets over the weekend that featured quotes dubiously attributed to Adolf Hitler &mdash; including claims that &ldquo;white Jews&rdquo;" />
<meta property="og:site_name" content="Cleveland Jewish News" />
<meta property="og:section" content="JTA" />
<meta property="fb:app_id" content="565068060326266" />
<meta property="article:publisher" content="https://www.facebook.com/ClevelandJewishNews" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@CleveJN" />
<meta property="fb:pages" content="23609471043" />
<meta property="tncms:ads" content="lazyload,refresh" />
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.84b508a1a202c37515b0b42aa96c44ea.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.f5e0209e8fa74e9037c8703df61fdb9c.css"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/live/global/resources/styles/site.css?_dc=1450887859"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/styles/owl.carousel.d631cca58a0d014854c4a6c1815f1da3.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-text-promo.945a2efac4892ce469180c513f411107.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"pattern","style":"default","syndicated":"false","reaction":"true","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"asset":{"author":"Gabe Friedman","id":"900e466f-e431-5248-85a7-dc26e62e9d3e","app":"editorial"},"vendor":{"outbrain":"disabled","taboola":""},"ad":{"vendor":"dfp premium"},"system":{"render_time":358},"client":{"is_bot":"no","is_gdpr":"no"},"google":{"ua":"UA-10028671-1"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl+ '&gtm_auth=UaWpb3d_PDCaIVzoLRLRYA&gtm_preview=env-2&gtm_cookies_win=x';f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="//tags.crwdcntrl.net/c/10228/cc.js?ns=_cc10228" id="LOTCC_10228"></script>
<script>
	if(document.cookie.indexOf('tncms-dmp-id') != -1) {
		_cc10228.add('tp', 'TNNW');
		_cc10228.add('act', ' User Login');
		_cc10228.add('tpid', document.cookie.split( ';' ).map( function( x ) { return x.trim().split( '=' ); } ).reduce(function( a, b ) { a[ b[ 0 ] ] = b[ 1 ]; return a; }, {} )[ "tncms-dmp-id"]);
		document.cookie = 'tncms-dmp-id=;expires=Thu, 01 Jan 1970 00:00:01 GMT';
		sessionStorage.removeItem('tncms.behaviors');
		sessionStorage.removeItem('tncms.dmp.audiences');
	}
	_cc10228.bcp();
</script>

<script src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.c34c594a0128ca26764dd8ecad278707.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script>/*<![CDATA[*/ TNCMS.User.restorePersistentSession(); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.5ee3960b4d37bc106988fa535b393865.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.ac87000c8e1356e20584473075fd0f2e.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.93d1db0a57d520951552a1dcd8fd9aeb.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script async="async" src="https://cdn.districtm.ca/merge/all.townNews.js"></script>
<script src="https://tagan.adlightning.com/townnews/op.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>/*<![CDATA[*/ window.googletag = window.googletag || {cmd: []};
    window.gptAdSlots = window.gptAdSlots || [];

    window.__tnt = window.__tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};
    __tnt.ads.dfp.dmp = __tnt.ads.dfp.dmp || {};
    __tnt.ads.dfp.dmp.audienceCheck = function(settings) {
        if (!__tnt.client.capabilities.supportsLocalStorage() || localStorage.getItem('tncms.dmp.audiences') == null) return false;
        if (settings.block && typeof settings.audience != 'undefined' && settings.audience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), settings.audience.split(','))) return true;
        } else if (typeof __tnt.ads.dfp.dmp.hideAudience != 'undefined' && __tnt.ads.dfp.dmp.hideAudience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), __tnt.ads.dfp.dmp.hideAudience)) return true;
        }
        return false;
    };

    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};
    __tnt.ads.dfp.targeting.k = ["stephen jackson","desean jackson","sport","politics","sociology","american football","basketball","michael wilbon","jew","stephen a. smith"];

    __tnt.ads.dfp.targeting.page = ["asset","article","app-editorial"];
    __tnt.ads.dfp.templates = __tnt.ads.dfp.templates || {};
    __tnt.ads.dfp.templates = {
        interstitial:"https:\/\/bloximages.chicago2.vip.townnews.com\/clevelandjewishnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/interstitial.e2581800cba1f328853618263e9a8b3f.js",
        pageCurl:"https:\/\/bloximages.chicago2.vip.townnews.com\/clevelandjewishnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/page-curl.ca0c1a7372c29272ef1ccf504ced01a9.js",
        parallax:"https:\/\/bloximages.chicago2.vip.townnews.com\/clevelandjewishnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/parallax.562ac43ab5c59b0f315e3f7aabdfac51.js",
        paw:"https:\/\/bloximages.chicago2.vip.townnews.com\/clevelandjewishnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/paw.f2c3f73025b675e671c97fb411b2228d.js",
        pencil:"https:\/\/bloximages.chicago2.vip.townnews.com\/clevelandjewishnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/pencil.7d33f5d95dc0b3cd3fe8f11229d905ca.js",
        reveal:"https:\/\/bloximages.chicago2.vip.townnews.com\/clevelandjewishnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/reveal.e5d561a6b71aa2730a07fa90f5f4f6d6.js",
        video:"https:\/\/bloximages.chicago2.vip.townnews.com\/clevelandjewishnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/video-inline.9b0997ab77d1d69707d283848faeacdd.js",
        wallpaper:"https:\/\/bloximages.chicago2.vip.townnews.com\/clevelandjewishnews.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/wallpaper.dc1c1bace62343a130be3589fe0846f9.js"
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/clevelandjewishnews.com/jta';
            var mapping = googletag.sizeMapping().addSize([320, 0], [[320,90],[320,50]]).addSize([768, 0], [728,90]).addSize([992, 0], [728,90]).addSize([1200, 0], [728,90]).build();
                gptAdSlots['ad-1543627'] = googletag.defineSlot(adUnit, [[320,90],[320,50],[728,90]], 'ad-1543627').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1543627'].setTargeting('pos', ['atf','block-leaderboard-top']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/clevelandjewishnews.com/jta';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [200,90]).addSize([1200, 0], [200,90]).build();
                gptAdSlots['ad-1543632'] = googletag.defineSlot(adUnit, [[200,90]], 'ad-1543632').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1543632'].setTargeting('pos', ['atf','block-leaderboard-tile-top']);
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.f1660ccf5d097410b8b72737d216878c.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/clevelandjewishnews.com/jta';
            
                gptAdSlots['fixed-big-ad-top-asset'] = googletag.defineSlot(adUnit, [300,250], 'fixed-big-ad-top-asset').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-big-ad-top-asset'].setTargeting('pos', ['fixed-big-ad-top-asset','atf']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/clevelandjewishnews.com/jta';
            
                gptAdSlots['fixed-big-ad-middle-asset'] = googletag.defineSlot(adUnit, [300,250], 'fixed-big-ad-middle-asset').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-big-ad-middle-asset'].setTargeting('pos', ['fixed-big-ad-middle-asset','stf']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/clevelandjewishnews.com/jta';
            
                gptAdSlots['fixed-big-ad-bottom-asset'] = googletag.defineSlot(adUnit, [300,250], 'fixed-big-ad-bottom-asset').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-big-ad-bottom-asset'].setTargeting('pos', ['fixed-big-ad-bottom-asset','btf']);
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.facebook.comments.89e3602c68154764e889947868c957c9.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/clevelandjewishnews.com/jta';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [[300,250],[300,600]]).addSize([1200, 0], [[300,250],[300,600]]).build();
                gptAdSlots['ad-1543672'] = googletag.defineSlot(adUnit, [[300,250],[300,600]], 'ad-1543672').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1543672'].setTargeting('pos', ['atf','block-big-ad-top']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/clevelandjewishnews.com/jta';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [[300,250],[300,600]]).addSize([1200, 0], [[300,250],[300,600]]).build();
                gptAdSlots['ad-1543648'] = googletag.defineSlot(adUnit, [[300,250],[300,600]], 'ad-1543648').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1543648'].setTargeting('pos', ['btf','block-rail-middle']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/clevelandjewishnews.com/jta';
            
                gptAdSlots['ad-1543680'] = googletag.defineSlot(adUnit, [300,250], 'ad-1543680').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1543680'].setTargeting('pos', ['stf','block-big-ad-middle']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/clevelandjewishnews.com/jta';
            
                gptAdSlots['ad-1543681'] = googletag.defineSlot(adUnit, [300,250], 'ad-1543681').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1543681'].setTargeting('pos', ['btf','block-big-ad-bottom']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/clevelandjewishnews.com/jta';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320,50]).addSize([768, 0], [728,90]).addSize([992, 0], [728,90]).addSize([1200, 0], [728,90]).build();
                gptAdSlots['ad-1543684'] = googletag.defineSlot(adUnit, [[320,50],[728,90]], 'ad-1543684').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1543684'].setTargeting('pos', ['btf','block-leaderboard-bottom']);
    });
 /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.advertisements.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script>/*<![CDATA[*/ 

    googletag.cmd.push(function() {
        googletag.pubads().setTargeting('browser', __tnt.client.browser.name);
        if (__tnt.ads.dfp.targeting) {
            for (var k in __tnt.ads.dfp.targeting) {
                if (__tnt.ads.dfp.targeting.hasOwnProperty(k)) {
                    googletag.pubads().setTargeting(k,__tnt.ads.dfp.targeting[k]);
                }
            }
        }
            googletag.pubads().disableInitialLoad();
            googletag.pubads().addEventListener('impressionViewable', function(event) {
                for (var key in gptAdSlots) {
                    if (gptAdSlots[key] === event.slot && __tnt.ads.slots[key]) {
                        if (!__tnt.ads.slots[key].viewableImpression) __tnt.ads.slots[key].viewableImpression = true;
                    }
                }
            });

        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
    });
 /*]]>*/</script>

            
            <title>Stephen Jackson said DeSean Jackson is ‘speaking the truth’ about Jews. Black commentators say his activism is now tainted. | JTA | clevelandjewishnews.com</title>
            
    <style>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</style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.clevelandjewishnews.com/content/tncms/site/icon.ico" />
    
        <link rel="apple-touch-icon" href="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/53387046-0cab-11e6-b21d-4f2f1d3b10c9.gif?resize=180%2C180" />
    
        <link rel="preconnect" href="//www.google.com">
    
        <link rel="preconnect" href="//adservice.google.com">
    
        <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    
        <link rel="preconnect" href="//stats.g.doubleclick.net">
    
        <link rel="preconnect" href="//tpc.googlesyndication.com">
    
        <link rel="preconnect" href="//pagead2.googlesyndication.com">
    
        <link rel="preconnect" href="//tagan.adlightning.com">
    
        <link rel="preconnect" href="//cdn.districtm.ca">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    
        <link rel="preconnect" href="//connect.facebook.net">
    
        <link rel="preconnect" href="//bcp.crwdcntrl.net">
    
        <link rel="preconnect" href="//tags.crwdcntrl.net">
    <link rel="alternate" type="application/rss+xml" title="Stephen Jackson said DeSean Jackson is ‘speaking the truth’ about Jews. Black commentators say his activism is now tainted. | JTA | clevelandjewishnews.com" href="http://www.clevelandjewishnews.com/search/?f=rss&amp;t=article&amp;c=jta&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.clevelandjewishnews.com/jta/stephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his/article_900e466f-e431-5248-85a7-dc26e62e9d3e.html" />
            
    <script defer src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.a8c7e0dc594b3a0b53141cdea833eee5.js"></script>
              

<!-- @apittman #tntracking 607134  Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');

fbq('init', '1006756389441491');
fbq('track', "PageView");</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1006756389441491&ev=PageView&noscript=1";;
/></noscript>
<!-- End Facebook Pixel Code -->

<script type="text/javascript">
$(document).ready(function(){



$('#user-main-menu-wrapper > div > div.col-md-9.col-md-push-3 > div.user-dashboard > div:nth-child(1) > div:nth-child(3) > div > a').attr("href","https://cjn.newzware.com/ss70v2/cjn/common/template.jsp?nwmodule=classified&nwpage=woe");
$('#collapse-classifieds > a:nth-child(1)').attr("href","https://cjn.newzware.com/ss70v2/cjn/common/template.jsp?nwmodule=classified&nwpage=woe");
$('#collapse-classifieds > a:nth-child(2)').attr("href","https://cjn.newzware.com/ss70v2/cjn/common/template.jsp?nwmodule=classified&nwpage=woe");


$('#collapse-subscription > a:nth-child(1)').attr("href","https://cjn.newzware.com/ss70v2/cjn/common/template.jsp");
$('#collapse-subscription > a:nth-child(2)').attr("href","https://cjn.newzware.com/ss70v2/cjn/common/template.jsp");
$('#user-main-menu-wrapper > div > div.col-md-9.col-md-push-3 > div.user-dashboard > div:nth-child(2) > div:nth-child(3) > div > a').attr("href","https://cjn.newzware.com/ss70v2/cjn/common/template.jsp");

});
</script>

<script type="text/javascript">
    $(document).ready(function(){
        $('.related-sidebar.default.subscriber-hide div.asset-related-siblings.inline-asset div.asset-related-article.sibling-article.inline-asset h3.inline-heading.text-muted').text("Related Content");
    });
</script>


<script type="text/javascript">
    $(window).load(function() {
        $('.fb_comments_count_zero').each(function( index ) {
            $(this).parent().parent().css('display', 'none');
        });
    });
</script>

<!-- #tntracking @albohall 615925 -->
<!-- Google Code for Remarketing Tag -->
<!--------------------------------------------------
Remarketing tags may not be associated with personally identifiable information or placed on pages related to sensitive categories. See more information and instructions on how to setup the tag on: http://google.com/ads/remarketingsetup
--------------------------------------------------->
<script type="text/javascript">
/* <![CDATA[ */
var google_conversion_id = 942747443;
var google_custom_params = window.google_tag_params;
var google_remarketing_only = true;
/* ]]> */
</script>
<script type="text/javascript" src="//www.googleadservices.com/pagead/conversion.js">
</script>
<noscript>
<div style="display:inline;">
<img height="1" width="1" style="border-style:none;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/942747443/?guid=ON&amp;script=0"/>
</div>
</noscript>


        </head>
        <body class="fixed-scroll-nav app-editorial grid-pattern blox-asset uuid-900e466f-e431-5248-85a7-dc26e62e9d3e section-jta type-article infinity-disabled" data-path="/jta">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.clevelandjewishnews.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&tncms.template.version=3.155.0&tncms.page.grid=pattern&tncms.page.style=default&tncms.page.syndicated=false&tncms.page.reaction=true&tncms.page.app=editorial&tncms.page.theme=flex&tncms.page.skin=flex-editorial&tncms.page.http_status=200&tncms.subscription.required=false&tncms.asset.author=Gabe+Friedman&tncms.asset.id=900e466f-e431-5248-85a7-dc26e62e9d3e&tncms.asset.app=editorial&tncms.vendor.outbrain=disabled&tncms.vendor.taboola=&tncms.ad.vendor=dfp+premium&tncms.system.render_time=358&tncms.client.is_bot=no&tncms.client.is_gdpr=no&tncms.google.ua=UA-10028671-1&tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fb-root"></div>
        
        
        
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container">

    
        
            <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left visible-sm visible-xs">
                <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "></div>
                <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-1" data-target="#mobile-nav-left_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/"  class="nav-link tnt-section-span-class-fas-tnt-home-span"><span class="fas tnt-home"></span></a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a href="/site/about.html"  class="nav-link tnt-section-about-us">About Us</a>
                                </li><li>
                                    <a href="/site/advertise"  class="nav-link tnt-section-advertise">Advertise</a>
                                </li><li>
                                    <a href="/site/contact.html"  class="nav-link tnt-section-contact-us">Contact Us</a>
                                </li><li>
                                    <a href="/site/forms"  class="nav-link tnt-section-lifecycle-and-subscriber-forms">Lifecycle and Subscriber Forms</a>
                                </li><li>
                                    <a href="/esignup/"  class="nav-link tnt-section-sign-up-for-email-newsletters">Sign up for Email Newsletters</a>
                                </li><li>
                                    <a href="/employment/"  class="nav-link tnt-section-employment">Employment</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-2" data-target="#mobile-nav-left_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/news"  class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a href="/news/local_news/"  class="nav-link tnt-section-local-news">Local News</a>
                                </li><li>
                                    <a href="/news/national_news/"  class="nav-link tnt-section-national-news">National News</a>
                                </li><li>
                                    <a href="/news/world_news/"  class="nav-link tnt-section-world-news">World News</a>
                                </li><li>
                                    <a href="/stronger_than_hate/"  class="nav-link tnt-section-stronger-than-hate">Stronger than hate</a>
                                </li><li>
                                    <a href="/news/culture/"  class="nav-link tnt-section-culture">Culture</a>
                                </li><li>
                                    <a href="/news/culture/theater/"  class="nav-link tnt-section-theater">Theater</a>
                                </li><li>
                                    <a href="/news/sports/"  class="nav-link tnt-section-sports">Sports</a>
                                </li><li>
                                    <a href="/news/briefs"  class="nav-link tnt-section-briefs">Briefs</a>
                                </li><li>
                                    <a href="/differencemakers/"  class="nav-link tnt-section-18-difference-makers">18 Difference Makers</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-3" data-target="#mobile-nav-left_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/features"  class="nav-link tnt-section-features">Features</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a href="/features/business"  class="nav-link tnt-section-business">Business</a>
                                </li><li>
                                    <a href="/features/camps/"  class="nav-link tnt-section-camps">Camps</a>
                                </li><li>
                                    <a href="/features/multimedia/"  class="nav-link tnt-section-cjn-tv">CJN TV</a>
                                </li><li>
                                    <a href="/features/special_sections/education/"  class="nav-link tnt-section-education">Education</a>
                                </li><li>
                                    <a href="/features/health/"  class="nav-link tnt-section-health">Health</a>
                                </li><li>
                                    <a href="/features/holidays/"  class="nav-link tnt-section-holidays">Holidays</a>
                                </li><li>
                                    <a href="/features/nosh/"  class="nav-link tnt-section-nosh">Nosh</a>
                                </li><li>
                                    <a href="/features/religious_life/"  class="nav-link tnt-section-religious-life">Religious Life</a>
                                </li><li>
                                    <a href="/features/silver_linings/"  class="nav-link tnt-section-silver-linings">Silver Linings</a>
                                </li><li>
                                    <a href="/features/special_sections/"  class="nav-link tnt-section-special-sections">Special Sections</a>
                                </li><li>
                                    <a href="/unfiltered/"  class="nav-link tnt-section-unfiltered">UNFILTERED</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-4" data-target="#mobile-nav-left_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/opinion"  class="nav-link tnt-section-opinion">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a href="/columnists/"  class="nav-link tnt-section-cjn-columnists">CJN Columnists</a>
                                </li><li>
                                    <a href="/opinion/guest_columns/"  class="nav-link tnt-section-guest-columns">Guest Columns</a>
                                </li><li>
                                    <a href="/opinion/letters_to_editor/"  class="nav-link tnt-section-letters-to-the-editor">Letters to the Editor</a>
                                </li><li>
                                    <a href="/opinion/op-eds/"  class="nav-link tnt-section-op-eds">Op-Eds</a>
                                </li><li>
                                    <a href="/opinion/guest_columns/robin_green/"  class="nav-link tnt-section-cjn-accidental-blogger">CJN Accidental Blogger</a>
                                </li><li>
                                    <a href="/opinion/polls"  class="nav-link tnt-section-polls">Polls</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-5" data-target="#mobile-nav-left_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/community/"  class="nav-link tnt-section-community">Community</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a href="/community/lifecycles/"  class="nav-link tnt-section-lifecycles">Lifecycles</a>
                                </li><li>
                                    <a href="/community/community_scene/"  class="nav-link tnt-section-in-the-community">In the Community</a>
                                </li><li>
                                    <a href="/community/the_city/"  class="nav-link tnt-section-the-city">The City</a>
                                </li><li>
                                    <a href="/differencemakers/"  class="nav-link tnt-section-18-difference-makers">18 Difference Makers</a>
                                </li><li>
                                    <a href="/community/my_israel/"  class="nav-link tnt-section-my-israel">My Israel</a>
                                </li><li>
                                    <a href="/community/circle_of_life/"  class="nav-link tnt-section-circle-of-life">Circle of Life</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/community/lifecycles/obituaries/"  class="nav-link tnt-section-obituaries">Obituaries</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-7" data-target="#mobile-nav-left_menu-child-7">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/calendar"  class="nav-link tnt-section-events">Events</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-7" class="collapse nav navbar-nav"><li>
                                    <a href="/calendar"  class="nav-link tnt-section-events-calendar">Events Calendar</a>
                                </li><li>
                                    <a href="https://www.clevelandjewishnews.com/users/admin/calendar/event/"  target="_blank" rel="noopener" class="nav-link tnt-section-submit-an-event">Submit an event</a>
                                </li><li>
                                    <a href="/differencemakers/"  class="nav-link tnt-section-18-difference-makers">18 Difference Makers</a>
                                </li><li>
                                    <a href="/wil/"  class="nav-link tnt-section-women-in-leadership">Women in Leadership</a>
                                </li><li>
                                    <a href="/12under36/"  class="nav-link tnt-section-12-under-36">12 Under 36</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="https://cjn.newzware.com/ss70v2/cjn/common/template.jsp"  target="_blank" rel="noopener" class="nav-link tnt-section-current-issue">Current Issue</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-9" data-target="#mobile-nav-left_menu-child-9">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/magazines/"  class="nav-link tnt-section-magazines">Magazines</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-9" class="collapse nav navbar-nav"><li>
                                    <a href="/magazines/bar_bat/"  class="nav-link tnt-section-bar-bat-mitzvah">Bar•Bat Mitzvah</a>
                                </li><li>
                                    <a href="http://jstylemagazine.com"  target="_blank" rel="noopener" class="nav-link tnt-section-jstyle">Jstyle</a>
                                </li><li>
                                    <a href="http://canvascle.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-canvas">Canvas</a>
                                </li><li>
                                    <a href="http://www.balancedmag.com"  target="_blank" rel="noopener" class="nav-link tnt-section-balanced-family">Balanced Family</a>
                                </li><li>
                                    <a href="https://issuu.com/cjpc/docs/fullbook-sourceweb"  target="_blank" rel="noopener" class="nav-link tnt-section-source">SOURCE</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="http://digital.olivesoftware.com/Olive/APA/ClevelandJewishNewsFree/default.aspx"  target="_blank" rel="noopener" class="nav-link tnt-section-archive">Archive</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/classifieds"  class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/cjn_foundation/"  class="nav-link tnt-section-cjn-foundation">CJN Foundation</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/site/forms/subscription_services"  class="nav-link tnt-section-subscribe">Subscribe</a>
                        </div>
                    </div></div></div></div>
                
                
                <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "></div>
            </aside>
        
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    

    

    <div id="tncms-region-global-skyline" class="tncms-region "></div>
    

    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-1164775" class="tncms-block"><section id="block-1164775" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/e91f3a62-8eb8-11e9-b593-b7bbc592948c.png?resize=200%2C32 200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/e91f3a62-8eb8-11e9-b593-b7bbc592948c.png?resize=300%2C49 300w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/e91f3a62-8eb8-11e9-b593-b7bbc592948c.png?resize=400%2C65 400w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/e91f3a62-8eb8-11e9-b593-b7bbc592948c.png?resize=540%2C88 540w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/e91f3a62-8eb8-11e9-b593-b7bbc592948c.png?resize=750%2C122 750w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/e91f3a62-8eb8-11e9-b593-b7bbc592948c.png 1200w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div></div></div>
    <div id="masthead-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-1164782" class="tncms-block"><section id="block-1164782" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-1164782" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-1164782" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        <input type="hidden" name="s" value="start_time">
        <input type="hidden" name="sd" value="desc">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group pull-right normal form-control">
        <input id="site-search-1164782-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1164782-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-1164782-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1164782').submit();
        return false;
    });

    $('#site-search-1164782').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-1164782 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-1164782 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-1164782-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div></div>
    <div id="masthead-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-1304428" class="tncms-block"><section id="block-1304428" class="block emphasis-h3   " ><h4 align=right> <a href="/site/forms/subscription_services/" style="color:red"> Subscribe </h4> </a>
<h4 align=right> <a href="/digital/" style="color:blue"> Sign-in or Register </h4> </a>
<h4 align=right> <a href="/site/contact.html"> Contact Us </h4></a></section></div><div id="tncms-block-1487008" class="tncms-block"><div style="float:right;">
<a href="http://www.chabad.org/calendar/candleLighting_cdo/locationId/125/locationType/1/jewish/Candle-Lighting.htm">
Candlelighting times
</a>
</div></div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                
                <div class="navbar-header">
                    
                    
                        <button type="button" class=" visible-sm visible-xs navbar-toggle pull-left" data-toggle="offcanvas" data-target="left">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            
                        </button>
                    
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_left_menu_right_search">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-1164776" class="tncms-block"><section id="block-1164776" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/c650466e-b303-11e5-b98f-7b1efa83337d.png?resize=200%2C34 200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/c650466e-b303-11e5-b98f-7b1efa83337d.png?resize=300%2C51 300w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/c650466e-b303-11e5-b98f-7b1efa83337d.png 400w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div></div>
                            
                        </div>
                    

                    
                        <ul class="hidden-md hidden-lg nav navbar-nav pull-right site-search-full-mobile">
                            <li class="search-form-dropdown dropdown yamm-fw">
                                <a class="dropdown-toggle" data-toggle="dropdown"><span class="fas tnt-search"></span></a>
                                <ul class="dropdown-menu">
                                    <li>
                                        <form action="/search/" method="GET" class="yamm-content">
                                            <input type="hidden" name="l" value="25">
                                            <input type="hidden" name="sd" value="desc">
                                            <input type="hidden" name="s" value="start_time">
                                            <input type="hidden" name="f" value="html">
                                            <input type="hidden" name="t" value="article,video,youtube,collection">
                                            <div class="input-group">
                                                <input name="q" type="text" placeholder="Search..." title="Site Search" class="form-control" autocomplete="off">
                                                <input type="submit" class="hide" value="Search">
                                                <span class="input-group-btn">
                                                    <button class="btn btn-default site-search-btn" type="submit">
                                                        Search
                                                    </button>
                                                </span>
                                            </div>
                                            <div class="clearfix"></div>
                                        </form>
                                    </li>
                                </ul>
                            </li>
                        </ul>
                        <script>
                            $('.site-search-full-mobile button[type="submit"]').on(__tnt.client.clickEvent, function(){
                                $('.site-search-full-mobile form').submit();
                                return false;
                            });
                        </script>
                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-1164801" class="tncms-block weather-min-height"><div id="weather-1164801" class="weather-current size-small pull-right">
    <ul class="list-unstyled">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=44122" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250">
                <span class="icon pull-left">
                    
                        <span class="pull-left btn btn-xs btn-danger weather-alert-btn" data-toggle="tooltip" data-placement="right" title="Weather Alert"><i class="fas tnt-exclamation-triangle"></i></span>
                    
                    <span class="fas tnt-wi-night-clear"></span>
                </span>
                <span class="pull-left temp-desc small">
                    <span class="temp">77&deg;</span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li role="presentation">
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather ZIP Code" value="44122"> <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a href="javascript:;" class="pull-right zip-update-link" aria-label="weather_zip_toggle" onclick="jQuery('#weather-1164801 .zip-update-form').toggle('fast'); return false;"><span class="fas tnt-cog"></span></a>

                            <h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Beachwood, OH
                                
                                 <small>(44122)</small>
                            </h4>
                            <h5>Today</h5>
                            <p>A stray shower or thunderstorm is possible early. Partly cloudy skies. Low 71F. Winds light and variable..</p>
                            <h5>Tonight</h5>
                            <p>A stray shower or thunderstorm is possible early. Partly cloudy skies. Low 71F. Winds light and variable.</p>
                            <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: July 9, 2020 @ 9:58 pm</small></p>
                        </div>
                    </li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem" class="forecast-link text-center"><a href="/weather/?weather_zip=44122"><i class="fas tnt-caret-right"></i> Full Forecast</a></li>
                </ul>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li class="dropdown yamm-fw span-class-fas-tnt-home-span">
                <a class="dropdown-toggle nav-link tnt-section-span-class-fas-tnt-home-span" data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250" href="/" ><span class="fas tnt-home"></span>
                        
                            <b class="caret"></b>
                        
                    
                </a><ul class="dropdown-menu">
                        <li>
                            <div class="yamm-content"><div id="tncms-region-mega-nav-top" class="tncms-region "></div><div class="row">
                                    <div class="col-sm-2">
                                        <ul class="list-unstyled"><li>
                                                    <a class="nav-link tnt-section-about-us" href="/site/about.html" >About Us</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-advertise" href="/site/advertise" >Advertise</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-contact-us" href="/site/contact.html" >Contact Us</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-lifecycle-and-subscriber-forms" href="/site/forms" >Lifecycle and Subscriber Forms</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-sign-up-for-email-newsletters" href="/esignup/" >Sign up for Email Newsletters</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-employment" href="/employment/" >Employment</a>
                                                </li></ul>
                                    </div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-one" class="tncms-region "></div></div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-two" class="tncms-region "></div></div>
                                </div><div id="tncms-region-mega-nav-bottom" class="tncms-region "></div></div>
                        </li>
                    </ul></li><li class="dropdown yamm-fw news">
                <a class="dropdown-toggle nav-link tnt-section-news" data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250" href="/news" >News
                        
                            <b class="caret"></b>
                        
                    
                </a><ul class="dropdown-menu">
                        <li>
                            <div class="yamm-content"><div id="tncms-region-mega-nav-news-top" class="tncms-region "></div><div class="row">
                                    <div class="col-sm-2">
                                        <ul class="list-unstyled"><li>
                                                    <a class="nav-link tnt-section-local-news" href="/news/local_news/" >Local News</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-national-news" href="/news/national_news/" >National News</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-world-news" href="/news/world_news/" >World News</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-stronger-than-hate" href="/stronger_than_hate/" >Stronger than hate</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-culture" href="/news/culture/" >Culture</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-theater" href="/news/culture/theater/" >Theater</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-sports" href="/news/sports/" >Sports</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-briefs" href="/news/briefs" >Briefs</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-18-difference-makers" href="/differencemakers/" >18 Difference Makers</a>
                                                </li></ul>
                                    </div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-news-one" class="tncms-region "><div id="tncms-block-1181303" class="tncms-block"><section id="block-1181303" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1181303 ">
        <div class="block-title-inner">
            <h4>
                
                Top Story
                
            </h4>
        </div>
    </div></div>
    
    <div class="card-img-md card-compact">
        
                
                <article id="card-summary-1181303-a6c191a6-c21f-11ea-8120-bbb0683a79ad" class="tnt-asset-type-article clearfix card summary has-image image-left inherit letterbox-style-default  tnt-section-news tnt-sub-section-briefs">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-a6c191a6-c21f-11ea-8120-bbb0683a79ad media-preview article-asset" data-aspect="original"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/briefs/budish-leland-selected-as-dnc-delegates/article_a6c191a6-c21f-11ea-8120-bbb0683a79ad.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Budish, Leland selected as DNC delegates"
                            class="img-responsive lazyload full default"
                            width="1631"
                            height="1125"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/7/98/798fcf4e-c220-11ea-bda5-8b3f37561a8c/5f077a323a647.image.jpg?resize=200%2C138 200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/7/98/798fcf4e-c220-11ea-bda5-8b3f37561a8c/5f077a323a647.image.jpg?resize=300%2C207 300w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/7/98/798fcf4e-c220-11ea-bda5-8b3f37561a8c/5f077a323a647.image.jpg?resize=400%2C276 400w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/7/98/798fcf4e-c220-11ea-bda5-8b3f37561a8c/5f077a323a647.image.jpg?resize=540%2C372 540w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/7/98/798fcf4e-c220-11ea-bda5-8b3f37561a8c/5f077a323a647.image.jpg?resize=750%2C517 750w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/7/98/798fcf4e-c220-11ea-bda5-8b3f37561a8c/5f077a323a647.image.jpg?resize=1200%2C828 1200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/7/98/798fcf4e-c220-11ea-bda5-8b3f37561a8c/5f077a323a647.image.jpg?resize=1631%2C1125 1700w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/news/briefs/budish-leland-selected-as-dnc-delegates/article_a6c191a6-c21f-11ea-8120-bbb0683a79ad.html" class="tnt-asset-link">
        

        
            Budish, Leland selected as DNC delegates</a></h3></div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">Cuyahoga County Executive Armond Budish and Ohio House Rep. David Leland, D-Columbus, have both been selected among 18 state Democratic Party leaders and elected officials to be Ohio delegates at this year’s Democratic National Convention. </p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div></div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-news-two" class="tncms-region "><div id="tncms-block-1181304" class="tncms-block"><section id="block-1181304" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1181304 ">
        <div class="block-title-inner">
            <h4>
                
                More Headlines
                
            </h4>
        </div>
    </div></div>
    
    <div class="card-img-md card-compact">
        
                
                <article id="card-summary-1181304-70b0a137-6eb6-5adf-86cc-340e1bc6ab71" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-news tnt-sub-section-local-news">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/news/local_news/ohio-state-to-play-only-conference-games-in-fall/article_70b0a137-6eb6-5adf-86cc-340e1bc6ab71.html" class="tnt-asset-link">
        

        
            Ohio State to play only conference games in fall</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1181304-53cd2aa6-c1f6-11ea-ad91-d3e3c21e482b" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-news tnt-sub-section-local-news">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/news/local_news/hertz-enters-final-year-as-cjpc-board-chair-new-board-directors-welcomed/article_53cd2aa6-c1f6-11ea-ad91-d3e3c21e482b.html" class="tnt-asset-link">
        

        
            Hertz enters final year as CJPC board chair; new board directors welcomed</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1181304-3e42e55a-c218-11ea-a185-1bb9a680f0b8" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-news tnt-sub-section-local-news">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/news/local_news/akron-introduces-mask-wearing-legislation/article_3e42e55a-c218-11ea-a185-1bb9a680f0b8.html" class="tnt-asset-link">
        

        
            Akron introduces mask wearing legislation</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1181304-e94d06b2-c216-11ea-9f6e-8b7ec28271d6" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-news tnt-sub-section-local-news">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/news/local_news/beachwood-schools-delay-start-to-aug-24/article_e94d06b2-c216-11ea-9f6e-8b7ec28271d6.html" class="tnt-asset-link">
        

        
            Beachwood schools delay start to Aug. 24</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div></div>
                                </div><div id="tncms-region-mega-nav-news-bottom" class="tncms-region "></div></div>
                        </li>
                    </ul></li><li class="dropdown yamm-fw features">
                <a class="dropdown-toggle nav-link tnt-section-features" data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250" href="/features" >Features
                        
                            <b class="caret"></b>
                        
                    
                </a><ul class="dropdown-menu">
                        <li>
                            <div class="yamm-content"><div id="tncms-region-mega-nav-features-top" class="tncms-region "></div><div class="row">
                                    <div class="col-sm-2">
                                        <ul class="list-unstyled"><li>
                                                    <a class="nav-link tnt-section-business" href="/features/business" >Business</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-camps" href="/features/camps/" >Camps</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-cjn-tv" href="/features/multimedia/" >CJN TV</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-education" href="/features/special_sections/education/" >Education</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-health" href="/features/health/" >Health</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-holidays" href="/features/holidays/" >Holidays</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-nosh" href="/features/nosh/" >Nosh</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-religious-life" href="/features/religious_life/" >Religious Life</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-silver-linings" href="/features/silver_linings/" >Silver Linings</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-special-sections" href="/features/special_sections/" >Special Sections</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-unfiltered" href="/unfiltered/" >UNFILTERED</a>
                                                </li></ul>
                                    </div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-features-one" class="tncms-region "><div id="tncms-block-1181305" class="tncms-block"><section id="block-1181305" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1181305 ">
        <div class="block-title-inner">
            <h4>
                
                Top Story
                
            </h4>
        </div>
    </div></div>
    
    <div class="card-img-md card-compact">
        
                
                <article id="card-summary-1181305-1691225c-c05a-11ea-b601-bfddf3798582" class="tnt-asset-type-article clearfix card summary has-image image-left inherit letterbox-style-default  tnt-section-features tnt-sub-section-religious-life tnt-sub-section-synagogues">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-1691225c-c05a-11ea-b601-bfddf3798582 media-preview article-asset" data-aspect="original"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/features/religious_life/synagogues/synagogue-service-times-week-of-july-10/article_1691225c-c05a-11ea-b601-bfddf3798582.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Synagogue service times: Week of July 10"
                            class="img-responsive lazyload full default"
                            width="1763"
                            height="1175"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/1/69/1691225c-c05a-11ea-b601-bfddf3798582/5d3f47914c4da.preview.jpg?resize=200%2C133 200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/1/69/1691225c-c05a-11ea-b601-bfddf3798582/5d3f47914c4da.preview.jpg?resize=300%2C200 300w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/1/69/1691225c-c05a-11ea-b601-bfddf3798582/5d3f47914c4da.preview.jpg?resize=400%2C267 400w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/1/69/1691225c-c05a-11ea-b601-bfddf3798582/5d3f47914c4da.preview.jpg?resize=540%2C360 540w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/1/69/1691225c-c05a-11ea-b601-bfddf3798582/5d3f47914c4da.preview.jpg?resize=750%2C500 750w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/1/69/1691225c-c05a-11ea-b601-bfddf3798582/5d3f47914c4da.preview.jpg?resize=1200%2C800 1200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/1/69/1691225c-c05a-11ea-b601-bfddf3798582/5d3f47914c4da.preview.jpg?resize=1700%2C1133 1700w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/features/religious_life/synagogues/synagogue-service-times-week-of-july-10/article_1691225c-c05a-11ea-b601-bfddf3798582.html" class="tnt-asset-link">
        

        
            Synagogue service times: Week of July 10</a></h3></div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">Conservative </p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div></div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-features-two" class="tncms-region "><div id="tncms-block-1181306" class="tncms-block"><section id="block-1181306" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1181306 ">
        <div class="block-title-inner">
            <h4>
                
                More Headlines
                
            </h4>
        </div>
    </div></div>
    
    <div class="card-img-md card-compact">
        
                
                <article id="card-summary-1181306-69c14cf4-c154-11ea-8bcb-7fe4f205aa87" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-features tnt-sub-section-health">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/features/health/senior-living-facilities-prepare-for-next-chapter-of-pandemic/article_69c14cf4-c154-11ea-8bcb-7fe4f205aa87.html" class="tnt-asset-link">
        

        
            Senior living facilities prepare for next chapter of pandemic</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1181306-a13c63b8-bfb9-11ea-87cf-0badbdda13fd" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-features tnt-sub-section-special-sections tnt-sub-section-destination">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/features/special_sections/destination/beachwood-to-offer-yoga-tai-chi/article_a13c63b8-bfb9-11ea-87cf-0badbdda13fd.html" class="tnt-asset-link">
        

        
            Beachwood to offer yoga, tai chi</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1181306-d00aa088-c05e-11ea-9b08-1f8e89b3bc18" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-opinion tnt-sub-section-guest-columns tnt-sub-section-mark-roth">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/opinion/guest_columns/mark_roth/covid-19-stress-brings-challenges/article_d00aa088-c05e-11ea-9b08-1f8e89b3bc18.html" class="tnt-asset-link">
        

        
            COVID-19 stress brings challenges</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1181306-3bfd0e86-bfb8-11ea-b05e-0f3add72757e" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-features tnt-sub-section-special-sections tnt-sub-section-destination">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/features/special_sections/destination/beachwood-offering-summer-fun-box/article_3bfd0e86-bfb8-11ea-b05e-0f3add72757e.html" class="tnt-asset-link">
        

        
            Beachwood offering summer fun box</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div></div>
                                </div><div id="tncms-region-mega-nav-features-bottom" class="tncms-region "></div></div>
                        </li>
                    </ul></li><li class="dropdown yamm-fw opinion">
                <a class="dropdown-toggle nav-link tnt-section-opinion" data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250" href="/opinion" >Opinion
                        
                            <b class="caret"></b>
                        
                    
                </a><ul class="dropdown-menu">
                        <li>
                            <div class="yamm-content"><div id="tncms-region-mega-nav-opinion-top" class="tncms-region "></div><div class="row">
                                    <div class="col-sm-2">
                                        <ul class="list-unstyled"><li>
                                                    <a class="nav-link tnt-section-cjn-columnists" href="/columnists/" >CJN Columnists</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-guest-columns" href="/opinion/guest_columns/" >Guest Columns</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-letters-to-the-editor" href="/opinion/letters_to_editor/" >Letters to the Editor</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-op-eds" href="/opinion/op-eds/" >Op-Eds</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-cjn-accidental-blogger" href="/opinion/guest_columns/robin_green/" >CJN Accidental Blogger</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-polls" href="/opinion/polls" >Polls</a>
                                                </li></ul>
                                    </div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-opinion-one" class="tncms-region "><div id="tncms-block-1220932" class="tncms-block"><section id="block-1220932" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1220932 ">
        <div class="block-title-inner">
            <h4>
                
                Top Story
                
            </h4>
        </div>
    </div></div>
    
    <div class="card-img-md card-compact">
        
                
                <article id="card-summary-1220932-57acc39c-c157-11ea-b914-57022621ec66" class="tnt-asset-type-article clearfix card summary has-image image-left inherit letterbox-style-default  tnt-section-columnists tnt-sub-section-les-levine">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-57acc39c-c157-11ea-b914-57022621ec66 media-preview article-asset" data-aspect="original"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/columnists/les_levine/what-s-in-a-name-depends-on-who-you-ask/article_57acc39c-c157-11ea-b914-57022621ec66.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="What’s in a name? Depends on who you ask"
                            class="img-responsive lazyload full default"
                            width="1763"
                            height="1175"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/e/72/e725ad18-c157-11ea-8124-eb891540e8a6/5f0629b2915de.image.jpg?resize=200%2C133 200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/e/72/e725ad18-c157-11ea-8124-eb891540e8a6/5f0629b2915de.image.jpg?resize=300%2C200 300w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/e/72/e725ad18-c157-11ea-8124-eb891540e8a6/5f0629b2915de.image.jpg?resize=400%2C267 400w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/e/72/e725ad18-c157-11ea-8124-eb891540e8a6/5f0629b2915de.image.jpg?resize=540%2C360 540w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/e/72/e725ad18-c157-11ea-8124-eb891540e8a6/5f0629b2915de.image.jpg?resize=750%2C500 750w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/e/72/e725ad18-c157-11ea-8124-eb891540e8a6/5f0629b2915de.image.jpg?resize=1200%2C800 1200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/e/72/e725ad18-c157-11ea-8124-eb891540e8a6/5f0629b2915de.image.jpg?resize=1700%2C1133 1700w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/columnists/les_levine/what-s-in-a-name-depends-on-who-you-ask/article_57acc39c-c157-11ea-b914-57022621ec66.html" class="tnt-asset-link">
        

        
            What’s in a name? Depends on who you ask</a></h3></div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">You knew it was only a matter of time before the Cleveland Indians would either be forced by Major League Baseball or would decide on their own the name Indians must go. </p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div></div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-opinion-two" class="tncms-region "><div id="tncms-block-1220931" class="tncms-block"><section id="block-1220931" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1220931 ">
        <div class="block-title-inner">
            <h4>
                
                More Headlines
                
            </h4>
        </div>
    </div></div>
    
    <div class="card-img-md card-compact">
        
                
                <article id="card-summary-1220931-1eeac4b0-c061-11ea-aa2b-27f36f688303" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-columnists tnt-sub-section-cliff-savren">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/columnists/cliff_savren/it-s-time-for-a-palestinian-lives-matter/article_1eeac4b0-c061-11ea-aa2b-27f36f688303.html" class="tnt-asset-link">
        

        
            It’s time for a Palestinian Lives Matter</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1220931-d00aa088-c05e-11ea-9b08-1f8e89b3bc18" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-opinion tnt-sub-section-guest-columns tnt-sub-section-mark-roth">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/opinion/guest_columns/mark_roth/covid-19-stress-brings-challenges/article_d00aa088-c05e-11ea-9b08-1f8e89b3bc18.html" class="tnt-asset-link">
        

        
            COVID-19 stress brings challenges</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1220931-6e2be918-c120-11ea-9c08-63d0ece12cd1" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-columnists tnt-sub-section-regina-brett">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/columnists/regina_brett/indians-are-going-going-gone/article_6e2be918-c120-11ea-9c08-63d0ece12cd1.html" class="tnt-asset-link">
        

        
            Indians are going, going, gone</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1220931-2ab04fde-c05e-11ea-bd3a-0bcea8b3f9cb" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-opinion tnt-sub-section-guest-columns tnt-sub-section-laura-shefner">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/opinion/guest_columns/laura_shefner/pandemic-hasn-t-been-kind-to-kids-waistlines/article_2ab04fde-c05e-11ea-bd3a-0bcea8b3f9cb.html" class="tnt-asset-link">
        

        
            Pandemic hasn’t been kind to kids’ waistlines</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div></div>
                                </div><div id="tncms-region-mega-nav-opinion-bottom" class="tncms-region "></div></div>
                        </li>
                    </ul></li><li class="dropdown yamm-fw community">
                <a class="dropdown-toggle nav-link tnt-section-community" data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250" href="/community/" >Community
                        
                            <b class="caret"></b>
                        
                    
                </a><ul class="dropdown-menu">
                        <li>
                            <div class="yamm-content"><div id="tncms-region-mega-nav-community-top" class="tncms-region "></div><div class="row">
                                    <div class="col-sm-2">
                                        <ul class="list-unstyled"><li>
                                                    <a class="nav-link tnt-section-lifecycles" href="/community/lifecycles/" >Lifecycles</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-in-the-community" href="/community/community_scene/" >In the Community</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-the-city" href="/community/the_city/" >The City</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-18-difference-makers" href="/differencemakers/" >18 Difference Makers</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-my-israel" href="/community/my_israel/" >My Israel</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-circle-of-life" href="/community/circle_of_life/" >Circle of Life</a>
                                                </li></ul>
                                    </div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-community-one" class="tncms-region "><div id="tncms-block-1181307" class="tncms-block"><section id="block-1181307" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1181307 ">
        <div class="block-title-inner">
            <h4>
                
                Top Story
                
            </h4>
        </div>
    </div></div>
    
    <div class="card-img-md card-compact">
        
                
                <article id="card-summary-1181307-f31cf3c2-c16d-11ea-9f77-6b55f66d74dc" class="tnt-asset-type-article clearfix card summary has-image image-left inherit letterbox-style-default  tnt-section-community tnt-sub-section-lifecycles tnt-sub-section-b-nai-mitzvah">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-f31cf3c2-c16d-11ea-9f77-6b55f66d74dc media-preview article-asset" data-aspect="original"><figure class="photo layout-vertical letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/community/lifecycles/b_nai_mitzvah/james-alexander-rosenberg/article_f31cf3c2-c16d-11ea-9f77-6b55f66d74dc.html" class="tnt-asset-link">
                
                
                
                
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="James Alexander Rosenberg"
                    class="img-responsive lazyload  letterbox default"
                    width="1247"
                    height="1663"
                    data-src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/0/c3/0c3289e4-c16e-11ea-8af6-3b72ab3738d2/5f064f0a63f39.image.jpg?resize=200%2C267" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/community/lifecycles/b_nai_mitzvah/james-alexander-rosenberg/article_f31cf3c2-c16d-11ea-9f77-6b55f66d74dc.html" class="tnt-asset-link">
        

        
            James Alexander Rosenberg</a></h3></div>
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p class="tnt-summary">Mikhail Rosenberg and Katy Dobbins-Bucklad of Chicago happily announce the birth of their son, James Alexander Rosenberg, on July 1, 2020. James joins his sister, Naomi. Paternal grandparents are Alexander and Lydmila Rosenberg of Mayfield. Maternal grandparents are Mary-Carol Dobbins, and M&hellip;</p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div></div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-community-two" class="tncms-region "><div id="tncms-block-1181308" class="tncms-block"><section id="block-1181308" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1181308 ">
        <div class="block-title-inner">
            <h4>
                
                More Headlines
                
            </h4>
        </div>
    </div></div>
    
    <div class="card-img-md card-compact">
        
                
                <article id="card-summary-1181308-5b2a748a-c16e-11ea-9359-035afce89907" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-community tnt-sub-section-lifecycles tnt-sub-section-births">
            <div class="card-container">
                
                <div class="card-body"><div class="card-labels">
            
                <div class="card-label-section text-muted">
                    <a href="/community/lifecycles/births" class="tnt-section-tag">Births</a>
                </div>
            
            </div><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/community/lifecycles/births/samuel-aaron-meckler/article_5b2a748a-c16e-11ea-9359-035afce89907.html" class="tnt-asset-link">
        

        
            Samuel Aaron Meckler</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1181308-3bb05520-c16e-11ea-ab4b-93bf75be7aa2" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-community tnt-sub-section-lifecycles tnt-sub-section-birthdays">
            <div class="card-container">
                
                <div class="card-body"><div class="card-labels">
            
                <div class="card-label-section text-muted">
                    <a href="/community/lifecycles/birthdays" class="tnt-section-tag">Birthdays</a>
                </div>
            
            </div><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/community/lifecycles/birthdays/rabb-celebrates-85th-birthday/article_3bb05520-c16e-11ea-ab4b-93bf75be7aa2.html" class="tnt-asset-link">
        

        
            Rabb celebrates 85th birthday</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1181308-20cc596c-c16d-11ea-ab9c-8be9876f7196" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-community tnt-sub-section-lifecycles tnt-sub-section-engagements">
            <div class="card-container">
                
                <div class="card-body"><div class="card-labels">
            
                <div class="card-label-section text-muted">
                    <a href="/community/lifecycles/engagements" class="tnt-section-tag">Engagements</a>
                </div>
            
            </div><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/community/lifecycles/engagements/roseman-falck/article_20cc596c-c16d-11ea-ab9c-8be9876f7196.html" class="tnt-asset-link">
        

        
            Roseman-Falck</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1181308-968be61e-c16c-11ea-86e1-430be8530a56" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-community tnt-sub-section-lifecycles tnt-sub-section-obituaries">
            <div class="card-container">
                
                <div class="card-body"><div class="card-labels">
            
                <div class="card-label-section text-muted">
                    <a href="/community/lifecycles/obituaries" class="tnt-section-tag">Obituaries</a>
                </div>
            
            </div><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/community/lifecycles/obituaries/shafran-marilyn/article_968be61e-c16c-11ea-86e1-430be8530a56.html" class="tnt-asset-link">
        

        
            Shafran, Marilyn</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div></div>
                                </div><div id="tncms-region-mega-nav-community-bottom" class="tncms-region "></div></div>
                        </li>
                    </ul></li><li>
                <a href="/community/lifecycles/obituaries/" class="nav-link tnt-section-obituaries" >Obituaries
                </a></li><li class="dropdown yamm-fw events">
                <a class="dropdown-toggle nav-link tnt-section-events" data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250" href="/calendar" >Events
                        
                            <b class="caret"></b>
                        
                    
                </a><ul class="dropdown-menu">
                        <li>
                            <div class="yamm-content"><div id="tncms-region-mega-nav-calendar-top" class="tncms-region "></div><div class="row">
                                    <div class="col-sm-2">
                                        <ul class="list-unstyled"><li>
                                                    <a class="nav-link tnt-section-events-calendar" href="/calendar" >Events Calendar</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-submit-an-event" href="https://www.clevelandjewishnews.com/users/admin/calendar/event/"  target="_blank" rel="noopener">Submit an event</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-18-difference-makers" href="/differencemakers/" >18 Difference Makers</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-women-in-leadership" href="/wil/" >Women in Leadership</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-12-under-36" href="/12under36/" >12 Under 36</a>
                                                </li></ul>
                                    </div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-calendar-one" class="tncms-region "><div id="tncms-block-1222745" class="tncms-block"></div></div></div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-calendar-two" class="tncms-region "><div id="tncms-block-1222746" class="tncms-block"><section id="block-1222746" class="block emphasis-h3  heading-color  " ><div class="clearfix">
    
    <div class="block-title title-1222746 ">
        <div class="block-title-inner">
            <h3>
                
                Happening Today
                
            </h3>
        </div>
    </div></div>
    
    <div class="card-img-md ">
        
        
            
               
            
            <article id="card-event-a7d2161e-3d3c-11ea-b9b6-5cb9017b9d1f" class="clearfix card event">
            <div class="card-container">
                
                <div class="card-body">
                    
                    <div class="card-headline">
                        <h3 class="tnt-headline ">
        
             <a href="/calendar/summer-camps-2020/event_a7d2161e-3d3c-11ea-b9b6-5cb9017b9d1f.html" class="tnt-asset-link">
        

        
            Summer Camps 2020</a></h3>
                    </div>
                    <div class="card-date">
                        
                            
        <i class="far tnt-clock tnt-fw"></i>
    

    
        <time datetime="2020-07-09T00:00:00-04:00">
            

            
                Thursday, July 9th, 2020
                
            
        </time>

        
            
                &mdash;
                <time datetime="2020-07-09T23:59:59-04:00">
                    all day
                </time>
            
        
        
                        
                    </div>
                    
                    
                    
                    </div>
            </div>
            <div class="clearfix"></div>
        </article>
            
            
            
            
        
            
               
            
            <article id="card-event-750646ce-a42f-11ea-85dc-5cb9017b770f" class="clearfix card event">
            <div class="card-container">
                
                <div class="card-body">
                    
                    <div class="card-headline">
                        <h3 class="tnt-headline ">
        
             <a href="/calendar/summer-ink-creative-expression-camps/event_750646ce-a42f-11ea-85dc-5cb9017b770f.html" class="tnt-asset-link">
        

        
            Summer Ink: Creative Expression Camps</a></h3>
                    </div>
                    <div class="card-date">
                        
                            
        <i class="far tnt-clock tnt-fw"></i>
    

    
        <time datetime="2020-07-09T10:00:00-04:00">
            

            
                Thursday, July 9th, 2020
                
                    @ 10:00 am
                
            
        </time>

        
            
                &ndash;
                <time datetime="2020-07-09T16:30:00-04:00">
                    4:30 pm
                </time>
            
        
        
                        
                    </div>
                    
                    
                    
                    </div>
            </div>
            <div class="clearfix"></div>
        </article>
            
            
            
            
        
    </div>
    </section></div></div></div>
                                </div><div id="tncms-region-mega-nav-calendar-bottom" class="tncms-region "></div></div>
                        </li>
                    </ul></li><li>
                <a href="https://cjn.newzware.com/ss70v2/cjn/common/template.jsp" class="nav-link tnt-section-current-issue"  target="_blank" rel="noopener">Current Issue
                </a></li><li class="dropdown yamm-fw magazines">
                <a class="dropdown-toggle nav-link tnt-section-magazines" data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250" href="/magazines/" >Magazines
                        
                            <b class="caret"></b>
                        
                    
                </a><ul class="dropdown-menu">
                        <li>
                            <div class="yamm-content"><div id="tncms-region-mega-nav-magazines-top" class="tncms-region "></div><div class="row">
                                    <div class="col-sm-2">
                                        <ul class="list-unstyled"><li>
                                                    <a class="nav-link tnt-section-bar-bat-mitzvah" href="/magazines/bar_bat/" >Bar•Bat Mitzvah</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-jstyle" href="http://jstylemagazine.com"  target="_blank" rel="noopener">Jstyle</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-canvas" href="http://canvascle.com/"  target="_blank" rel="noopener">Canvas</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-balanced-family" href="http://www.balancedmag.com"  target="_blank" rel="noopener">Balanced Family</a>
                                                </li><li>
                                                    <a class="nav-link tnt-section-source" href="https://issuu.com/cjpc/docs/fullbook-sourceweb"  target="_blank" rel="noopener">SOURCE</a>
                                                </li></ul>
                                    </div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-magazines-one" class="tncms-region "></div></div>
                                    <div class="col-sm-5"><div id="tncms-region-mega-nav-magazines-two" class="tncms-region "></div></div>
                                </div><div id="tncms-region-mega-nav-magazines-bottom" class="tncms-region "></div></div>
                        </li>
                    </ul></li><li>
                <a href="http://digital.olivesoftware.com/Olive/APA/ClevelandJewishNewsFree/default.aspx" class="nav-link tnt-section-archive"  target="_blank" rel="noopener">Archive
                </a></li><li>
                <a href="/classifieds" class="nav-link tnt-section-classifieds" >Classifieds
                </a></li><li>
                <a href="/cjn_foundation/" class="nav-link tnt-section-cjn-foundation" >CJN Foundation
                </a></li><li>
                <a href="/site/forms/subscription_services" class="nav-link tnt-section-subscribe" >Subscribe
                </a></li></ul>
    </div>
                        </div>
                    </div>
                

                
            </nav>
            
        <div class="visible-xs pull-right article-share-nav" style="background-color: #000000">
            <span>Share This <i class="fas tnt-arrow-right"></i></span>
            
    <ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link">
         
            <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fjta%2Fstephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his%2Farticle_900e466f-e431-5248-85a7-dc26e62e9d3e.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="fb" target="_blank" title="Share on Facebook" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/jta/stephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his/article_900e466f-e431-5248-85a7-dc26e62e9d3e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":900e466f-e431-5248-85a7-dc26e62e9d3e}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
            
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link">
            <a href="https://twitter.com/intent/tweet?&text=Stephen%20Jackson%20said%20DeSean%20Jackson%20is%20%E2%80%98speaking%20the%20truth%E2%80%99%20about%20Jews.%20Black%20commentators%20say%20his%20activism%20is%20now%20tainted.&via=CleveJN&url=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fjta%2Fstephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his%2Farticle_900e466f-e431-5248-85a7-dc26e62e9d3e.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tw" target="_blank" title="Tweet" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/jta/stephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his/article_900e466f-e431-5248-85a7-dc26e62e9d3e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":900e466f-e431-5248-85a7-dc26e62e9d3e}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link">
            <a href="mailto:?subject=%5BCleveland%20Jewish%20News%5D%20Stephen%20Jackson%20said%20DeSean%20Jackson%20is%20%E2%80%98speaking%20the%20truth%E2%80%99%20about%20Jews.%20Black%20commentators%20say%20his%20activism%20is%20now%20tainted.&body=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fjta%2Fstephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his%2Farticle_900e466f-e431-5248-85a7-dc26e62e9d3e.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="em email-share-link" title="Email" data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":900e466f-e431-5248-85a7-dc26e62e9d3e}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                
                <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/jta/stephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his/article_900e466f-e431-5248-85a7-dc26e62e9d3e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":900e466f-e431-5248-85a7-dc26e62e9d3e}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li></ul>
    <form method="post" data-uuid="900e466f-e431-5248-85a7-dc26e62e9d3e" class="save-list-900e466f-e431-5248-85a7-dc26e62e9d3e-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="900e466f-e431-5248-85a7-dc26e62e9d3e" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

        </div>
            
        </div>
        
            
                
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "><div id="tncms-block-1164737" class="tncms-block"></div><div id="tncms-block-1219176" class="tncms-block"></div><div id="tncms-block-1227125" class="tncms-block"></div><div id="tncms-block-1821180" class="tncms-block"><section id="block-1821180" class="block emphasis-h3 light  " ><div class="clearfix"></div><div class="breaking">
            <div class="breaking-container clearfix">
                <div id="breaking-title-1821180" class="breaking-title text-left light" >
                    <h4><a href="https://www.clevelandjewishnews.com/coronavirus/ohio/" target="_blank">THE LATEST HEADLINES</a></h4>
                </div>
                <div id="breaking-content-1821180" class="breaking-content card-img-sm card-compact card-bg-color">
                    
                        
                            <article id="card-summary-1821180-29f91578-6314-11ea-9da4-8f1feee9c0b8" class="tnt-asset-type-link clearfix card summary light letterbox-style-default ">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h2 class="tnt-headline ">
        
             <a href="https://www.clevelandjewishnews.com/coronavirus/ohio" class="tnt-asset-link" target="_blank" rel="noopener">
        

        
            Click here for full coverage of the coronavirus in Ohio</a></h2></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                        
                    
                </div>
            </div>
        </div></section></div></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12">
                    <div id="tncms-region-asset_container_top" class="tncms-region "></div> 
                </div>
            
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "></div></div>
            
            
            <div class="col-md-9"><div id="tncms-region-global-advertise-container-left" class="tncms-region "><div id="tncms-block-1543627" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1543627" class="tnt-ads dfp-ad" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1543627');
                        googletag.pubads().refresh([gptAdSlots['ad-1543627']]);
                });
            </script>
        </div>
    </div>
</div></div></div>
            <div class="col-md-3"><div id="tncms-region-global-advertise-container-right" class="tncms-region "><div id="tncms-block-1543632" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1543632" class="tnt-ads dfp-ad" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1543632');
                        googletag.pubads().refresh([gptAdSlots['ad-1543632']]);
                });
            </script>
        </div>
    </div>
</div></div></div>
            <div class="col-md-12"><div id="tncms-region-global-advertise-container-bottom" class="tncms-region "><div id="tncms-block-1363613" class="tncms-block"><section id="block-1363613" class="block emphasis-h4 light  " ><div class="clearfix"></div><div class="breaking">
            <div class="breaking-container clearfix">
                <div id="breaking-title-1363613" class="breaking-title text-left light" style="display:none">
                    <h4><a href="/news" target="_blank">Headlines</a></h4>
                </div>
                <div id="breaking-content-1363613" class="breaking-content card-img-sm card-compact card-bg-color">
                    <div id="breaking-carousel-1363613" class="owl-carousel">
                        
                            <article id="card-summary-1363613-ca2aec2b-8548-532d-a48d-a69c0977f7fd" class="tnt-asset-type-article clearfix card summary light letterbox-style-default  tnt-section-jns">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/jns/world-jewish-leaders-the-paradigm-has-shifted-as-israel-emerges-as-pillar-in-corona-crisis/article_ca2aec2b-8548-532d-a48d-a69c0977f7fd.html" class="tnt-asset-link">
        

        
            World Jewish leaders: ‘The paradigm has shifted,’ as Israel emerges as pillar in corona crisis</a></h3></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                        
                            <article id="card-summary-1363613-a31996d2-a26a-5865-a649-e0c8fdb1fb9e" class="tnt-asset-type-article clearfix card summary light letterbox-style-default  tnt-section-jta">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/jta/sen-susan-collins-is-facing-a-major-challenge-in-maine-the-state-s-jewish-voters/article_a31996d2-a26a-5865-a649-e0c8fdb1fb9e.html" class="tnt-asset-link">
        

        
            Sen. Susan Collins is facing a major challenge in Maine. The state’s Jewish voters may be one reason why.</a></h3></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                        
                            <article id="card-summary-1363613-240e3380-b55a-5b34-b597-bc0f35822fcc" class="tnt-asset-type-article clearfix card summary light letterbox-style-default  tnt-section-jta">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/jta/sara-gideon-could-flip-susan-collins-senate-seat-blue-she-s-building-a-wide-base/article_240e3380-b55a-5b34-b597-bc0f35822fcc.html" class="tnt-asset-link">
        

        
            Sara Gideon could flip Susan Collins’ Senate seat blue. She’s building a wide base of Jewish support to do so.</a></h3></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                        
                            <article id="card-summary-1363613-900e466f-e431-5248-85a7-dc26e62e9d3e" class="tnt-asset-type-article clearfix card summary light letterbox-style-default  tnt-section-jta">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/jta/stephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his/article_900e466f-e431-5248-85a7-dc26e62e9d3e.html" class="tnt-asset-link">
        

        
            Stephen Jackson said DeSean Jackson is ‘speaking the truth’ about Jews. Black commentators say his activism is now tainted.</a></h3></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                        
                            <article id="card-summary-1363613-7be70ee6-5b06-5b3b-9b40-2def6532686f" class="tnt-asset-type-article clearfix card summary light letterbox-style-default  tnt-section-jta">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/jta/a-liberal-orthodox-education-organization-certifies-a-female-decisor-of-jewish-law/article_7be70ee6-5b06-5b3b-9b40-2def6532686f.html" class="tnt-asset-link">
        

        
            A liberal Orthodox education organization certifies a female decisor of Jewish law</a></h3></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                        
                            <article id="card-summary-1363613-6b806b32-f948-5748-b8ce-8b0214647e6d" class="tnt-asset-type-article clearfix card summary light letterbox-style-default  tnt-section-jns">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/jns/chief-of-staff-10-000-idf-soldiers-in-quarantine-after-possible-exposure-to-covid/article_6b806b32-f948-5748-b8ce-8b0214647e6d.html" class="tnt-asset-link">
        

        
            Chief of staff, 10,000 IDF soldiers in quarantine after possible exposure to COVID</a></h3></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                        
                            <article id="card-summary-1363613-75e809d7-8f55-56f9-a54e-ceb047ae754a" class="tnt-asset-type-article clearfix card summary light letterbox-style-default  tnt-section-jta">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/jta/roy-moore-s-lawsuit-against-sacha-baron-cohen-can-proceed-judge-rules/article_75e809d7-8f55-56f9-a54e-ceb047ae754a.html" class="tnt-asset-link">
        

        
            Roy Moore’s lawsuit against Sacha Baron Cohen can proceed, judge rules</a></h3></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                        
                            <article id="card-summary-1363613-1b31a60a-ae75-59a1-846b-cbc1776f8d6a" class="tnt-asset-type-article clearfix card summary light letterbox-style-default  tnt-section-jns">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/jns/senators-call-for-kosher-halal-food-in-federal-emergency-coronavirus-programs/article_1b31a60a-ae75-59a1-846b-cbc1776f8d6a.html" class="tnt-asset-link">
        

        
            Senators call for kosher, halal food in federal emergency coronavirus programs</a></h3></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                        
                            <article id="card-summary-1363613-d23b345f-165c-5773-beb0-3638d3f5bb0d" class="tnt-asset-type-article clearfix card summary light letterbox-style-default  tnt-section-jns">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/jns/us-house-subcommittee-passes-250-million-in-funding-for-palestinians/article_d23b345f-165c-5773-beb0-3638d3f5bb0d.html" class="tnt-asset-link">
        

        
            US House subcommittee passes $250 million in funding for Palestinians</a></h3></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                        
                            <article id="card-summary-1363613-dd54261a-aa52-5cec-b4ca-ecf421073d0f" class="tnt-asset-type-article clearfix card summary light letterbox-style-default  tnt-section-jta">
            <div class="card-container">
                
                <div class="card-body"><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/jta/in-the-tobacconist-a-young-austrian-befriends-freud-during-wwii/article_dd54261a-aa52-5cec-b4ca-ecf421073d0f.html" class="tnt-asset-link">
        

        
            In ‘The Tobacconist,’ a young Austrian befriends Freud during WWII</a></h3></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                        
                    </div>
                </div>
            </div>
        </div></section>
    <script>
        $(window).load(function() {
            var owl = $('#breaking-carousel-1363613');
            owl.on('changed.owl.carousel', function(event) {
                $('#breaking-title-1363613').show();
            });
            owl.owlCarousel({
                autoplay: false,
                items: 1,
                autoHeight: false,
                autoplayHoverPause: true,
                mouseDrag: false,
                nav: true,
                navText: ['<i class="fas tnt-chevron-left"></i>','<i class="fas tnt-chevron-right"></i>'],
                dots: false,
                pagination: false,
            });
        });
    </script>
    </div><div id="tncms-block-1164779" class="tncms-block"><section id="block-1164779" class="block emphasis-h3   " ><div class="heading card">
    
    
        
        <ol class="breadcrumb  pull-right" itemscope itemtype="https://schema.org/BreadcrumbList"><li itemprop="itemListElement" itemscope
      itemtype="https://schema.org/ListItem">
                    <a href="/" itemprop="item">
                        <span itemprop="name">Home</span>
                    </a>
                    <meta itemprop="position" content="1" />
                </li><li class="active" itemprop="itemListElement" itemscope
      itemtype="https://schema.org/ListItem">
                    <a href="/jta/" itemprop="item">
                        <span itemprop="name">JTA</span>
                    </a>
                    <meta itemprop="position" content="2" />
                </li></ol>
    
    <div class="clearfix">
    
    <div class="block-title title-1164779 ">
        <div class="block-title-inner">
            <h3>
                
                    <a href="/jta">
                
                JTA
                
                    </a>
                
            </h3>
        </div>
    </div></div>
    
</div></section></div></div></div>
            
        </div><article itemscope itemtype="https://schema.org/Article" id="asset-900e466f-e431-5248-85a7-dc26e62e9d3e" class="asset article-default"  data-url="https://www.clevelandjewishnews.com/jta/stephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his/article_900e466f-e431-5248-85a7-dc26e62e9d3e.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/7278b38c-b303-11e5-a1a2-a31281943715.jpg">
            <meta itemprop="width" content="1200">
            <meta itemprop="height" content="630">
        </div>
        <meta itemprop="name" content="clevelandjewishnews.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.clevelandjewishnews.com/jta/stephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his/article_900e466f-e431-5248-85a7-dc26e62e9d3e.html" />
    <style>
                .asset-paging .direction {
                    color: #4f6eb5;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.clevelandjewishnews.com\/tncms\/search\/mlt\/?origin=900e466f-e431-5248-85a7-dc26e62e9d3e&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"900e466f-e431-5248-85a7-dc26e62e9d3e","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-900e466f-e431-5248-85a7-dc26e62e9d3e" class="asset-paging">
                <div id="paging-prev-900e466f-e431-5248-85a7-dc26e62e9d3e" class="paging-link prev offset"></div>
                <div id="paging-next-900e466f-e431-5248-85a7-dc26e62e9d3e" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            Stephen Jackson said DeSean Jackson is ‘speaking the truth’ about Jews. Black commentators say his activism is now tainted.
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        <li><span itemprop="author" class="tnt-byline">Gabe Friedman</span></li>
        
        
            <li class="visible-print">
        <time datetime="2020-07-09T15:55:22-04:00" class="tnt-date asset-date text-muted">
            Jul 9, 2020
        </time>
    </li>
            <li class="hidden-print"><time datetime="2020-07-09T15:55:22-04:00" class="tnt-date asset-date text-muted">
            Jul 9, 2020
        </time><span class="text-muted">Updated </span><time datetime="2020-07-09T18:00:10-04:00" class="tnt-date asset-date text-muted">4 hrs ago</time>
    </li>
        
        
            <li class="hidden-print"><a href="/jta/stephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his/article_900e466f-e431-5248-85a7-dc26e62e9d3e.html#comments" class="cm"><span class="fas tnt-comments"></span></a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2020-07-09T15:55:22-04:00">
    <meta itemprop="datePublished" content="2020-07-09T15:55:22-04:00">
    <meta itemprop="dateModified" content="2020-07-09T14:00:10-04:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove>
    <ul class="social-share-links hidden-print list-unstyled stacked icon">
        <li class="social-share-link">
         
            <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fjta%2Fstephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his%2Farticle_900e466f-e431-5248-85a7-dc26e62e9d3e.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="fb" target="_blank" title="Share on Facebook" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/jta/stephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his/article_900e466f-e431-5248-85a7-dc26e62e9d3e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":900e466f-e431-5248-85a7-dc26e62e9d3e}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
            
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link">
            <a href="https://twitter.com/intent/tweet?&text=Stephen%20Jackson%20said%20DeSean%20Jackson%20is%20%E2%80%98speaking%20the%20truth%E2%80%99%20about%20Jews.%20Black%20commentators%20say%20his%20activism%20is%20now%20tainted.&via=CleveJN&url=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fjta%2Fstephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his%2Farticle_900e466f-e431-5248-85a7-dc26e62e9d3e.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tw" target="_blank" title="Tweet" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/jta/stephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his/article_900e466f-e431-5248-85a7-dc26e62e9d3e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":900e466f-e431-5248-85a7-dc26e62e9d3e}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link">
            <a href="mailto:?subject=%5BCleveland%20Jewish%20News%5D%20Stephen%20Jackson%20said%20DeSean%20Jackson%20is%20%E2%80%98speaking%20the%20truth%E2%80%99%20about%20Jews.%20Black%20commentators%20say%20his%20activism%20is%20now%20tainted.&body=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fjta%2Fstephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his%2Farticle_900e466f-e431-5248-85a7-dc26e62e9d3e.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="em email-share-link" title="Email" data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":900e466f-e431-5248-85a7-dc26e62e9d3e}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                
                <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/jta/stephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his/article_900e466f-e431-5248-85a7-dc26e62e9d3e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":900e466f-e431-5248-85a7-dc26e62e9d3e}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Print">
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li></ul>
    <form method="post" data-uuid="900e466f-e431-5248-85a7-dc26e62e9d3e" class="save-list-900e466f-e431-5248-85a7-dc26e62e9d3e-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="900e466f-e431-5248-85a7-dc26e62e9d3e" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"><div id="tncms-block-1540760" class="tncms-block"><section id="block-1540760" class="block emphasis-h3   " ><strong><i>Stories appearing in our World pages originate from aggregated news feeds obtained from various subscription news sources.</strong></i><br />
</section></div></div>
            
            

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="900e466f-e431-5248-85a7-dc26e62e9d3e">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                            
                            <div id="share-left-affix" class="share-container content-left hidden-xs" data-subscription-required-remove>
    <ul class="social-share-links hidden-print list-unstyled stacked icon">
        <li class="social-share-link">
         
            <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fjta%2Fstephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his%2Farticle_900e466f-e431-5248-85a7-dc26e62e9d3e.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="fb" target="_blank" title="Share on Facebook" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/jta/stephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his/article_900e466f-e431-5248-85a7-dc26e62e9d3e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":900e466f-e431-5248-85a7-dc26e62e9d3e}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
            
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link">
            <a href="https://twitter.com/intent/tweet?&text=Stephen%20Jackson%20said%20DeSean%20Jackson%20is%20%E2%80%98speaking%20the%20truth%E2%80%99%20about%20Jews.%20Black%20commentators%20say%20his%20activism%20is%20now%20tainted.&via=CleveJN&url=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fjta%2Fstephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his%2Farticle_900e466f-e431-5248-85a7-dc26e62e9d3e.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tw" target="_blank" title="Tweet" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/jta/stephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his/article_900e466f-e431-5248-85a7-dc26e62e9d3e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":900e466f-e431-5248-85a7-dc26e62e9d3e}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link">
            <a href="mailto:?subject=%5BCleveland%20Jewish%20News%5D%20Stephen%20Jackson%20said%20DeSean%20Jackson%20is%20%E2%80%98speaking%20the%20truth%E2%80%99%20about%20Jews.%20Black%20commentators%20say%20his%20activism%20is%20now%20tainted.&body=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fjta%2Fstephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his%2Farticle_900e466f-e431-5248-85a7-dc26e62e9d3e.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="em email-share-link" title="Email" data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":900e466f-e431-5248-85a7-dc26e62e9d3e}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                
                <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/jta/stephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his/article_900e466f-e431-5248-85a7-dc26e62e9d3e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":900e466f-e431-5248-85a7-dc26e62e9d3e}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li></ul>
    <form method="post" data-uuid="900e466f-e431-5248-85a7-dc26e62e9d3e" class="save-list-900e466f-e431-5248-85a7-dc26e62e9d3e-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="900e466f-e431-5248-85a7-dc26e62e9d3e" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                            <script>
                                $(window).load(function() {
                                    window.setTimeout(affixShare, 2000);
                                    function affixShare() {
                                        var sHeight = $('#share-left-affix').outerHeight(true);
                                        var cHeight = $('#share-left-affix').parent().outerHeight(true);
                                        var sTop = $('#share-left-affix').offset().top - 50;
                                        var sBottom = $(document).height() - ($('#share-left-affix').parent().offset().top + cHeight - 50);
                                        if(cHeight > sHeight) {
                                            $('#share-left-affix').affix({
                                                offset: { top: sTop, bottom: sBottom }
                                            });
                                        }
                                    }
                                });
                                $(window).resize(function() {
                                    var sHeight = $('#share-left-affix').outerHeight(true);
                                    var cHeight = $('#share-left-affix').parent().outerHeight(true);
                                    var sTop = $('#share-left-affix').offset().top - 50;
                                    var sBottom = $(document).height() - ($('#share-left-affix').parent().offset().top + $('#share-left-affix').parent().outerHeight(true) - 50);
                                    if(cHeight > sHeight) {
                                        $('#share-left-affix').data('bs.affix').options.offset.top = sTop;
                                        $('#share-left-affix').data('bs.affix').options.offset.bottom = sBottom;
                                    }
                                });
                            </script>
                            
                        
                        <div class="asset-body has-fixed-share" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above visible-xs" data-subscription-required-remove>
    <ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link">
         
            <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fjta%2Fstephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his%2Farticle_900e466f-e431-5248-85a7-dc26e62e9d3e.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="fb" target="_blank" title="Share on Facebook" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/jta/stephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his/article_900e466f-e431-5248-85a7-dc26e62e9d3e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":900e466f-e431-5248-85a7-dc26e62e9d3e}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
            
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link">
            <a href="https://twitter.com/intent/tweet?&text=Stephen%20Jackson%20said%20DeSean%20Jackson%20is%20%E2%80%98speaking%20the%20truth%E2%80%99%20about%20Jews.%20Black%20commentators%20say%20his%20activism%20is%20now%20tainted.&via=CleveJN&url=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fjta%2Fstephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his%2Farticle_900e466f-e431-5248-85a7-dc26e62e9d3e.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tw" target="_blank" title="Tweet" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/jta/stephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his/article_900e466f-e431-5248-85a7-dc26e62e9d3e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":900e466f-e431-5248-85a7-dc26e62e9d3e}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link">
            <a href="mailto:?subject=%5BCleveland%20Jewish%20News%5D%20Stephen%20Jackson%20said%20DeSean%20Jackson%20is%20%E2%80%98speaking%20the%20truth%E2%80%99%20about%20Jews.%20Black%20commentators%20say%20his%20activism%20is%20now%20tainted.&body=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fjta%2Fstephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his%2Farticle_900e466f-e431-5248-85a7-dc26e62e9d3e.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="em email-share-link" title="Email" data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":900e466f-e431-5248-85a7-dc26e62e9d3e}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                
                <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/jta/stephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his/article_900e466f-e431-5248-85a7-dc26e62e9d3e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":900e466f-e431-5248-85a7-dc26e62e9d3e}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li></ul>
    <form method="post" data-uuid="900e466f-e431-5248-85a7-dc26e62e9d3e" class="save-list-900e466f-e431-5248-85a7-dc26e62e9d3e-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="900e466f-e431-5248-85a7-dc26e62e9d3e" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p><span style="font-weight: 400;">(</span><a href="http://jta.org"><span style="font-weight: 400;">JTA</span></a><span style="font-weight: 400;">) — NFL wide receiver DeSean Jackson unleashed an uproar with his tweets over the weekend that featured quotes</span> <a href="https://www.snopes.com/fact-check/hitler-start-wwiii/"><span style="font-weight: 400;">dubiously attributed to Adolf Hitler</span></a> <span style="font-weight: 400;">— including claims that “white Jews” will work to “blackmail” and “extort” America — and that the Nazi leader “was right.”</span></p><p><span style="font-weight: 400;">Now his most prominent defender — former NBA player-turned-podcaster and Black Lives Matter activist Stephen Jackson (no relation) — is facing his own wave of high-profile criticism.</span></p><p><span style="font-weight: 400;">Stephen Jackson took center stage in the controversy after</span> <a href="https://twitter.com/TheNBACentral/status/1280635668700561411"><span style="font-weight: 400;">saying that</span></a> <span style="font-weight: 400;">DeSean Jackson was “speaking the truth.” He proceeded to add several incendiary comments, including a reference to the Rothschilds “owning all the banks.”</span></p><div class="tnt-ads-container text-center  " >
        <div id="fixed-big-ad-top-asset" class="tnt-ads dfp-ad" style="min-height:250px; min-width:300px;" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-big-ad-top-asset');
                        googletag.pubads().refresh([gptAdSlots['fixed-big-ad-top-asset']]);
                });
            </script>
        </div>
    </div><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><p><span style="font-weight: 400;">Among those rebuking Stephen Jackson were two of the country’s leading sports commentators, ESPN’s Stephen A. Smith and Michael Wilbon. The criticism from Smith and Wilbon, both Black, was noteworthy because they have praised Jackson and his emergence as a leading figure in the Black Lives Matter movement.</span></p><p><span style="font-weight: 400;">Both Smith and Wilbon criticized the substance of Stephen Jackson’s remarks, while also arguing that he was damaging his own credibility as an activist and diverting attention from the Black Lives Matter cause.</span></p><p><span style="font-weight: 400;">Wilbon said the series of comments “undermines everything Stephen Jackson said so eloquently on behalf of Black Lives Matter.”</span></p><p><span style="font-weight: 400;">“He has no credibility now, he has undermined all his previous good work with this garbage,” Wilbon</span> <a href="https://www.espn.com/video/clip?id=29431188"><span style="font-weight: 400;">said on his long-running show “Pardon the Interruption.”</span></a></p><p><span style="font-weight: 400;">The rambunctious Smith</span> <a href="https://www.youtube.com/watch?v=808KIXJctJU"><span style="font-weight: 400;">got loud in his repudiation of Stephen Jackson on ESPN’s “First Take” morning show</span></a> <span style="font-weight: 400;">on Wednesday. He also said that many in the Black community respect the Jewish community for their perceived unity and noted the importance of learning about the Holocaust.</span></p><p><span style="font-weight: 400;">“What ‘truth’ are you talking about?” Smith asked, speaking about Stephen Jackson. “We’ve gone from George Floyd getting choked to death essentially, to statues being torn down, to tweets … Here we are talking about some post on Instagram … Know what are we gonna be talking about? We gonna be talking about Adolf Hitler, we gonna be talking about getting educated about the Holocaust and the Jewish community and Jewish history, we gonna be talking about those things, instead of issues that directly involve us as Black people.”</span></p><p><span style="font-weight: 400;">Stephen Jackson was an outspoken and charismatic NBA player, and since last year he has co-hosted a popular</span> <a href="https://www.cbssports.com/nba/news/matt-barnes-stephen-jackson-unfiltered-on-nba-china-the-softer-modern-game-and-overpaid-players/"><span style="font-weight: 400;">podcast</span></a> <span style="font-weight: 400;">called “All the Smoke.” He has emerged as a leading Black Lives Matter activist since the death of George Floyd in May.</span></p><p><span style="font-weight: 400;">Jackson — who played for seven NBA teams and won a championship as a member of the San Antonio Spurs in 2003 — met Floyd in his native Texas at 19, and the two became longtime friends. Jackson often joked that they</span> <a href="https://www.washingtonpost.com/sports/2020/05/27/former-nba-player-stephen-jackson-mourns-twin-george-floyd-who-died-police-custody/"><span style="font-weight: 400;">looked so similar</span></a> <span style="font-weight: 400;">that they could have been twins.</span></p><p><span style="font-weight: 400;">Since Floyd’s killing earlier this year by a Minneapolis police officer, Jackson has been a fixture at Black Lives Matter protests. He was the</span> <a href="https://www.wbur.org/onlyagame/2020/06/05/black-lives-matter-protests-ken-shropshire"><span style="font-weight: 400;">featured speaker</span></a> <span style="font-weight: 400;">at some protests in Minneapolis, and has been noted in</span> <a href="https://www.youtube.com/watch?v=3axydV6lO7c"><span style="font-weight: 400;">numerous</span></a> <a href="https://www.wbur.org/onlyagame/2020/06/05/black-lives-matter-protests-ken-shropshire"><span style="font-weight: 400;">articles</span></a> <span style="font-weight: 400;">and videos on BLM leaders.</span></p><div class="tnt-ads-container text-center  " >
        <div id="fixed-big-ad-middle-asset" class="tnt-ads dfp-ad" style="min-height:250px; min-width:300px;" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-big-ad-middle-asset');
                        
                });
            </script>
        </div>
    </div><div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"></div><p><span style="font-weight: 400;">But Jackson added fuel to the fire of the DeSean Jackson controversy with his insistence that the Philadelphia Eagles player was “speaking the truth.” He then wrote an</span> <a href="https://www.instagram.com/p/CCXdZpzlVEf/"><span style="font-weight: 400;">Instagram post</span></a> <span style="font-weight: 400;">that some took to be aimed at Jews.</span></p><p><span style="font-weight: 400;">“Your races [sic] pain doesn’t hurt more than the next races [sic] pain,” Jackson wrote. “Don’t act like your hardships or [sic] more devastating then [sic] ours.”</span></p><p><span style="font-weight: 400;">Next, in an Instagram live</span> <a href="https://www.youtube.com/watch?v=01WM7kCiwCc"><span style="font-weight: 400;">video</span></a> <span style="font-weight: 400;">discussion with a user whose handle is @kosherwhitewine, Stephen Jackson brought up the Rothschild family, which is featured in many anti-Semitic conspiracy theories about Jewish international financial domination.</span></p><p><span style="font-weight: 400;">“Do you know who the Rothschilds are? They control all the banks, they own all the banks,” Jackson said.</span></p><p><span style="font-weight: 400;">Asked repeatedly if he thought Jews were specifically trying to divide the Black community, Jackson avoided the question. Eventually he said “No, but I don’t think they stand up for us as much as they should.”</span></p><p><span style="font-weight: 400;">Jackson has cited Riley Cooper — a former Eagles player who was fined but not fired for getting caught</span> <a href="https://www.tmz.com/2013/07/31/philadelphia-eagles-riley-cooper-n-word-apology/"><span style="font-weight: 400;">saying the N word on camera</span></a> <span style="font-weight: 400;">— in arguments in recent days.</span></p><p><span style="font-weight: 400;">Stephen Jackson appeared to approach an apology</span> <a href="https://www.cnn.com/2020/07/09/us/stephen-jackson-desean-jackson-anti-semitic-remarks/index.html"><span style="font-weight: 400;">on CNN</span></a><span style="font-weight: 400;">.</span></p><p><span style="font-weight: 400;">“I could’ve changed my words,” he said Wednesday, “but it’s nothing I said that I support any of that.” </span></p><p><span style="font-weight: 400;">“You didn’t hear a word out of my mouth saying I hate Jews. You didn’t hear a word out of my mouth saying I’m supporting Hitler,” he said. “They can twist it how they want. I don’t hate nobody. I’ve been standing for everybody.”</span></p><p><span style="font-weight: 400;">DeSean Jackson has deleted his controversial posts and apologized following a wave of criticism and a meeting with the Eagles Jewish owner, Jeffrey Lurie, saying he has “no hatred” for the Jewish community, and that Jews and Blacks “should be together fighting anti-Semitism and racism.”</span></p><p><span style="font-weight: 400;">In his posts, DeSean Jackson had also urged his followers to listen to the Fourth of July address by Louis Farrakhan in which the Nation of Islam leader defended himself against anti-Semitism accusations. Farrakhan over the years has praised Hitler,</span> <a href="https://www.jta.org/quick-reads/louis-farrakhans-2018-tweet-comparing-jews-to-termites-is-gone-after-twitter-policy-change"><span style="font-weight: 400;">compared Jews to termites</span></a> <span style="font-weight: 400;">and spouted</span> <a href="https://www.splcenter.org/fighting-hate/extremist-files/individual/louis-farrakhan"><span style="font-weight: 400;">conspiracy theories about Jewish power</span></a><span style="font-weight: 400;">.</span></p><p>The post <a rel="nofollow" href="https://www.jta.org/2020/07/09/sports/stephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his-activism-is-now-tainted">Stephen Jackson said DeSean Jackson is ‘speaking the truth’ about Jews. Black commentators say his activism is now tainted.</a> appeared first on <a rel="nofollow" href="https://www.jta.org">Jewish Telegraphic Agency</a>.</p><div class="tnt-ads-container text-center  " >
        <div id="fixed-big-ad-bottom-asset" class="tnt-ads dfp-ad" style="min-height:250px; min-width:300px;" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-big-ad-bottom-asset');
                        
                });
            </script>
        </div>
    </div><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    
        
            
                <div id="reaction-wrap" class="reaction-wrapper hidden-print reaction-900e466f-e431-5248-85a7-dc26e62e9d3e anonymous">
                    <div id="reaction">
                        
                            <h4>How do you feel about this article?</h4>
                        
                        
                            <p>Choose from the options below.</p>
                        
                        <div id="reaction-form-wrapper">
                            
                            <form id="reaction-form" onsubmit="return" data-uuid="900e466f-e431-5248-85a7-dc26e62e9d3e" method="post" action="/tncms/counter/editorial/900e466f-e431-5248-85a7-dc26e62e9d3e/?">
                                <input type="hidden" name="subkey" value="reaction">
                                <input type="hidden" name="action" value="add" id="action">
                                <input type="hidden" name="type" value="" id="hidden-type">
                                <input type="hidden" name="id" value="900e466f-e431-5248-85a7-dc26e62e9d3e" id="asset-id" />
                                <div class="form-icons love" data-user-reaction-emotion="love">
                                               <label class="love-icon reaction-name" data-user-reaction-emotion="love">
                                                   <span class="emotion-name" data-user-reaction-emotion="love">Love</span>
                                                   
                                               </label>
                                               <div class="emotion-container" data-user-reaction-emotion="love">
                                                   <div class="love-icon form-emoji" data-user-reaction-emotion="love"></div>
                                                   <div id="reaction-love-count" 
                                                        class="reaction-count count-love" 
                                                        data-user-reaction-count="0" 
                                                        data-user-reaction-emotion="love">0</div>
                                               </div>
                                           </div><div class="form-icons funny" data-user-reaction-emotion="funny">
                                               <label class="funny-icon reaction-name" data-user-reaction-emotion="funny">
                                                   <span class="emotion-name" data-user-reaction-emotion="funny">Funny</span>
                                                   
                                               </label>
                                               <div class="emotion-container" data-user-reaction-emotion="funny">
                                                   <div class="funny-icon form-emoji" data-user-reaction-emotion="funny"></div>
                                                   <div id="reaction-funny-count" 
                                                        class="reaction-count count-funny" 
                                                        data-user-reaction-count="0" 
                                                        data-user-reaction-emotion="funny">0</div>
                                               </div>
                                           </div><div class="form-icons wow" data-user-reaction-emotion="wow">
                                               <label class="wow-icon reaction-name" data-user-reaction-emotion="wow">
                                                   <span class="emotion-name" data-user-reaction-emotion="wow">Wow</span>
                                                   
                                               </label>
                                               <div class="emotion-container" data-user-reaction-emotion="wow">
                                                   <div class="wow-icon form-emoji" data-user-reaction-emotion="wow"></div>
                                                   <div id="reaction-wow-count" 
                                                        class="reaction-count count-wow" 
                                                        data-user-reaction-count="0" 
                                                        data-user-reaction-emotion="wow">0</div>
                                               </div>
                                           </div><div class="form-icons sad" data-user-reaction-emotion="sad">
                                               <label class="sad-icon reaction-name" data-user-reaction-emotion="sad">
                                                   <span class="emotion-name" data-user-reaction-emotion="sad">Sad</span>
                                                   
                                               </label>
                                               <div class="emotion-container" data-user-reaction-emotion="sad">
                                                   <div class="sad-icon form-emoji" data-user-reaction-emotion="sad"></div>
                                                   <div id="reaction-sad-count" 
                                                        class="reaction-count count-sad" 
                                                        data-user-reaction-count="0" 
                                                        data-user-reaction-emotion="sad">0</div>
                                               </div>
                                           </div><div class="form-icons angry" data-user-reaction-emotion="angry">
                                               <label class="angry-icon reaction-name" data-user-reaction-emotion="angry">
                                                   <span class="emotion-name" data-user-reaction-emotion="angry">Angry</span>
                                                   
                                               </label>
                                               <div class="emotion-container" data-user-reaction-emotion="angry">
                                                   <div class="angry-icon form-emoji" data-user-reaction-emotion="angry"></div>
                                                   <div id="reaction-angry-count" 
                                                        class="reaction-count count-angry" 
                                                        data-user-reaction-count="1" 
                                                        data-user-reaction-emotion="angry">1</div>
                                               </div>
                                           </div>
                            </form>
                        </div>
                    </div>
                    <div id="reaction-form-message" class="hide">
                        <p></p>
                    </div>
                </div>
        
    


                            
                                <div class="share-container content-below" data-subscription-required-remove>
    <ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link">
         
            <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fjta%2Fstephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his%2Farticle_900e466f-e431-5248-85a7-dc26e62e9d3e.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="fb" target="_blank" title="Share on Facebook" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/jta/stephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his/article_900e466f-e431-5248-85a7-dc26e62e9d3e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":900e466f-e431-5248-85a7-dc26e62e9d3e}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
            
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link">
            <a href="https://twitter.com/intent/tweet?&text=Stephen%20Jackson%20said%20DeSean%20Jackson%20is%20%E2%80%98speaking%20the%20truth%E2%80%99%20about%20Jews.%20Black%20commentators%20say%20his%20activism%20is%20now%20tainted.&via=CleveJN&url=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fjta%2Fstephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his%2Farticle_900e466f-e431-5248-85a7-dc26e62e9d3e.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tw" target="_blank" title="Tweet" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/jta/stephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his/article_900e466f-e431-5248-85a7-dc26e62e9d3e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":900e466f-e431-5248-85a7-dc26e62e9d3e}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link">
            <a href="mailto:?subject=%5BCleveland%20Jewish%20News%5D%20Stephen%20Jackson%20said%20DeSean%20Jackson%20is%20%E2%80%98speaking%20the%20truth%E2%80%99%20about%20Jews.%20Black%20commentators%20say%20his%20activism%20is%20now%20tainted.&body=https%3A%2F%2Fwww.clevelandjewishnews.com%2Fjta%2Fstephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his%2Farticle_900e466f-e431-5248-85a7-dc26e62e9d3e.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="em email-share-link" title="Email" data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":900e466f-e431-5248-85a7-dc26e62e9d3e}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                
                <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/jta/stephen-jackson-said-desean-jackson-is-speaking-the-truth-about-jews-black-commentators-say-his/article_900e466f-e431-5248-85a7-dc26e62e9d3e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":900e466f-e431-5248-85a7-dc26e62e9d3e}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li></ul>
    <form method="post" data-uuid="900e466f-e431-5248-85a7-dc26e62e9d3e" class="save-list-900e466f-e431-5248-85a7-dc26e62e9d3e-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="900e466f-e431-5248-85a7-dc26e62e9d3e" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    
                        <div class="asset-tags hidden-print">
                            <h4>Tags</h4>
                            <ul class="list-inline"><li>
                <a href="/search/?k=%22stephen%20jackson%22#tncms-source=keyword" class="tag-stephen-jackson label label-default" data-tncms-track-dmp='search: stephen-jackson'>Stephen Jackson</a>
            </li> <li>
                <a href="/search/?k=%22desean%20jackson%22#tncms-source=keyword" class="tag-desean-jackson label label-default" data-tncms-track-dmp='search: desean-jackson'>Desean Jackson</a>
            </li> <li>
                <a href="/search/?k=%22sport%22#tncms-source=keyword" class="tag-sport label label-default" data-tncms-track-dmp='search: sport'>Sport</a>
            </li> <li>
                <a href="/search/?k=%22politics%22#tncms-source=keyword" class="tag-politics label label-default" data-tncms-track-dmp='search: politics'>Politics</a>
            </li> <li>
                <a href="/search/?k=%22sociology%22#tncms-source=keyword" class="tag-sociology label label-default" data-tncms-track-dmp='search: sociology'>Sociology</a>
            </li> <li>
                <a href="/search/?k=%22american%20football%22#tncms-source=keyword" class="tag-american-football label label-default" data-tncms-track-dmp='search: american-football'>American Football</a>
            </li> <li>
                <a href="/search/?k=%22basketball%22#tncms-source=keyword" class="tag-basketball label label-default" data-tncms-track-dmp='search: basketball'>Basketball</a>
            </li> <li>
                <a href="/search/?k=%22michael%20wilbon%22#tncms-source=keyword" class="tag-michael-wilbon label label-default" data-tncms-track-dmp='search: michael-wilbon'>Michael Wilbon</a>
            </li> <li>
                <a href="/search/?k=%22jew%22#tncms-source=keyword" class="tag-jew label label-default" data-tncms-track-dmp='search: jew'>Jew</a>
            </li> <li>
                <a href="/search/?k=%22stephen%20a.%20smith%22#tncms-source=keyword" class="tag-stephen-a_-smith label label-default" data-tncms-track-dmp='search: stephen-a_-smith'>Stephen A. Smith</a>
            </li> <li>
                <a href="/search/?k=%22louis%20farrakhan%22#tncms-source=keyword" class="tag-louis-farrakhan label label-default" data-tncms-track-dmp='search: louis-farrakhan'>Louis Farrakhan</a>
            </li> <li>
                <a href="/search/?k=%22conspiracy%20theory%22#tncms-source=keyword" class="tag-conspiracy-theory label label-default" data-tncms-track-dmp='search: conspiracy-theory'>Conspiracy Theory</a>
            </li> </ul>
                        </div>
                    

                    

                    

                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div>

                    <div class="asset-comments hidden-print">
                
                <div id="comments-container" class="comments-container">
                    
                    <div
                        id="comments" 
                        class="fb-comments" 
                        data-href="http://www.clevelandjewishnews.com/tncms/asset/editorial/900e466f-e431-5248-85a7-dc26e62e9d3e/" 
                        data-num-posts="10" 
                        data-width="100%" 
                    ></div>
                    <style>
                        .fb_iframe_widget,
                        .fb_iframe_widget span,
                        .fb_iframe_widget span iframe[style]{
                            min-width:100%!important;
                            width:100%!important;
                        }
                    </style>
                </div>
            
        </div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div>
<div class="row">
    <div class="col-sm-6 col-md-12">
    
    <div id="tncms-region-global-side-attic" class="tncms-region "><div id="tncms-block-1543672" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1543672" class="tnt-ads dfp-ad" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1543672');
                        googletag.pubads().refresh([gptAdSlots['ad-1543672']]);
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-1543648" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1543648" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1543648');
                        
                });
            </script>
        </div>
    </div>
</div></div>    
    </div>
 </div>
<div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-1179857" class="tncms-block"><section id="block-1179857" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1179857 ">
        <div class="block-title-inner">
            <h4>
                
                CJN Most Popular
                
            </h4>
        </div>
    </div></div>
    <div class="card">
        <ul class="list-unstyled list-popular"><li>
                    
                        <h4 class="tnt-headline ">
        
             <a href="/news/local_news/beachwood-place-shooting-i-was-crying-i-was-shaking-i-was-scared/article_63f9a2e0-bf82-11ea-88a5-2ba017fffa7b.html" class="tnt-asset-link">
        

        
            Beachwood Place shooting: 'I was crying, I was shaking, I was scared'</a></h4>
                    
                </li><li>
                    
                        <h4 class="tnt-headline ">
        
             <a href="/news/local_news/face-masks-mandatory-in-cleveland-cuyahoga-county-likely-to-be-next/article_96bf4144-bd89-11ea-b568-5b5f4787217a.html" class="tnt-asset-link">
        

        
            Face masks mandatory in Cleveland; Cuyahoga County likely to be next</a></h4>
                    
                </li><li>
                    
                        <h4 class="tnt-headline ">
        
             <a href="/news/local_news/man-shot-at-beachwood-place/article_435072aa-bd8c-11ea-8837-df64a97251da.html" class="tnt-asset-link">
        

        
            Man shot at Beachwood Place</a></h4>
                    
                </li><li>
                    
                        <h4 class="tnt-headline ">
        
             <a href="/news/local_news/beachwood-passes-face-mask-ordinance/article_be04909c-bff0-11ea-83d0-f340ee17d0fb.html" class="tnt-asset-link">
        

        
            Beachwood passes face mask ordinance</a></h4>
                    
                </li><li>
                    
                        <h4 class="tnt-headline ">
        
             <a href="/news/local_news/cuyahoga-county-placed-on-watch-list-in-covid-19-map/article_53577236-c20d-11ea-840e-5ff0e69939ad.html" class="tnt-asset-link">
        

        
            Cuyahoga County placed on 'watch list' in COVID-19 map</a></h4>
                    
                </li></ul>
    </div>
    
</section></div></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "><div id="tncms-block-1543680" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1543680" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1543680');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-1195515" class="tncms-block"><section id="block-1195515" class="block emphasis-h3 dark  " ><div class="card-panel panel">
        <div class="panel-body"><article class="card promo media"><div class="media-body"><h3 class="media-heading">Sign up for e-news</h3><p>Choose from the CJN's informative e-newsletters. </p><a href="/esignup">
                <button type="button" class="btn btn-danger  ">Sign up</button>
            </a></div>
</article></div>
    </div></section></div><div id="tncms-block-1543681" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1543681" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1543681');
                        
                });
            </script>
        </div>
    </div>
</div></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-1177945" class="tncms-block"><section id="block-1177945" class="block emphasis-h3   " ><div class="clearfix">
        <ul class="list-inline block-links pos-top ">
            
                
                    <li><a href="/features/multimedia/videos/" class="">Videos</a></li>
                
                    <li><a href="/features/multimedia/photo_gallery/" class="">Photo Galleries</a></li>
                
            
            
        </ul>
    
    <div class="block-title title-1177945 ">
        <div class="block-title-inner">
            <h3>
                
                Must Read
                
            </h3>
        </div>
    </div></div><div class="card-grid   card-img-md card-bg-color">
        
        
            <div class=" row equal equal-wrap">
        
        <div class=" col-sm-3 ">
                 
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                                
                    <article id="card-summary-1177945-57acc39c-c157-11ea-b914-57022621ec66" class="tnt-asset-type-article clearfix card summary has-image image-top inherit letterbox-style-default  tnt-section-columnists tnt-sub-section-les-levine">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-57acc39c-c157-11ea-b914-57022621ec66 media-preview article-asset" data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/columnists/les_levine/what-s-in-a-name-depends-on-who-you-ask/article_57acc39c-c157-11ea-b914-57022621ec66.html" class="tnt-asset-link">
                
                
                    <div class="asset-icon"><i class="fas tnt-camera tnt-fw" title="Article with images"></i> +2</div>
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="What’s in a name? Depends on who you ask"
                            class="img-responsive lazyload full default"
                            width="1763"
                            height="992"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/e/72/e725ad18-c157-11ea-8124-eb891540e8a6/5f0629b2915de.image.jpg?crop=1763%2C992%2C0%2C91&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/e/72/e725ad18-c157-11ea-8124-eb891540e8a6/5f0629b2915de.image.jpg?crop=1763%2C992%2C0%2C91&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/e/72/e725ad18-c157-11ea-8124-eb891540e8a6/5f0629b2915de.image.jpg?crop=1763%2C992%2C0%2C91&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/e/72/e725ad18-c157-11ea-8124-eb891540e8a6/5f0629b2915de.image.jpg?crop=1763%2C992%2C0%2C91&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/e/72/e725ad18-c157-11ea-8124-eb891540e8a6/5f0629b2915de.image.jpg?crop=1763%2C992%2C0%2C91&resize=750%2C422&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/e/72/e725ad18-c157-11ea-8124-eb891540e8a6/5f0629b2915de.image.jpg?crop=1763%2C992%2C0%2C91&resize=1200%2C675&order=crop%2Cresize 1200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/e/72/e725ad18-c157-11ea-8124-eb891540e8a6/5f0629b2915de.image.jpg?crop=1763%2C992%2C0%2C91&resize=1700%2C956&order=crop%2Cresize 1700w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-labels">
            
                <div class="card-label-section text-muted">
                    <a href="/columnists/les_levine" class="tnt-section-tag">Les Levine</a>
                </div>
            
            </div><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/columnists/les_levine/what-s-in-a-name-depends-on-who-you-ask/article_57acc39c-c157-11ea-b914-57022621ec66.html" class="tnt-asset-link">
        

        
            What’s in a name? Depends on who you ask</a></h3></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
                </div>
                
            
            
            
                
            
            
        <div class=" col-sm-3 ">
                 
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                                
                    <article id="card-summary-1177945-1eeac4b0-c061-11ea-aa2b-27f36f688303" class="tnt-asset-type-article clearfix card summary has-image image-top inherit letterbox-style-default  tnt-section-columnists tnt-sub-section-cliff-savren">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-1eeac4b0-c061-11ea-aa2b-27f36f688303 media-preview article-asset" data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/columnists/cliff_savren/it-s-time-for-a-palestinian-lives-matter/article_1eeac4b0-c061-11ea-aa2b-27f36f688303.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="It’s time for a Palestinian Lives Matter"
                            class="img-responsive lazyload full default"
                            width="600"
                            height="338"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/9/c2/9c27d602-4770-11e6-91b0-03bf2e46ff19/579919ef04339.image.png?crop=600%2C338%2C0%2C131&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/9/c2/9c27d602-4770-11e6-91b0-03bf2e46ff19/579919ef04339.image.png?crop=600%2C338%2C0%2C131&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/9/c2/9c27d602-4770-11e6-91b0-03bf2e46ff19/579919ef04339.image.png?crop=600%2C338%2C0%2C131&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/9/c2/9c27d602-4770-11e6-91b0-03bf2e46ff19/579919ef04339.image.png?crop=600%2C338%2C0%2C131&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/9/c2/9c27d602-4770-11e6-91b0-03bf2e46ff19/579919ef04339.image.png?crop=600%2C338%2C0%2C131&resize=600%2C338&order=crop%2Cresize 750w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-labels">
            
                <div class="card-label-section text-muted">
                    <a href="/columnists/cliff_savren" class="tnt-section-tag">Cliff Savren</a>
                </div>
            
            </div><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/columnists/cliff_savren/it-s-time-for-a-palestinian-lives-matter/article_1eeac4b0-c061-11ea-aa2b-27f36f688303.html" class="tnt-asset-link">
        

        
            It’s time for a Palestinian Lives Matter</a></h3></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
                </div>
                
            
            
            
                
            
            
        <div class=" col-sm-3 ">
                 
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                                
                    <article id="card-summary-1177945-6e2be918-c120-11ea-9c08-63d0ece12cd1" class="tnt-asset-type-article clearfix card summary has-image image-top inherit letterbox-style-default  tnt-section-columnists tnt-sub-section-regina-brett">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-6e2be918-c120-11ea-9c08-63d0ece12cd1 media-preview article-asset" data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/columnists/regina_brett/indians-are-going-going-gone/article_6e2be918-c120-11ea-9c08-63d0ece12cd1.html" class="tnt-asset-link">
                
                
                    <div class="asset-icon"><i class="fas tnt-camera tnt-fw" title="Article with images"></i> +2</div>
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="Indians are going, going, gone"
                            class="img-responsive lazyload full default"
                            width="1726"
                            height="971"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/c/66/c6695faa-e55e-11e9-9045-bb2dc8600c3e/5d951bf77c8e7.image.jpg?crop=1726%2C971%2C0%2C115&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/c/66/c6695faa-e55e-11e9-9045-bb2dc8600c3e/5d951bf77c8e7.image.jpg?crop=1726%2C971%2C0%2C115&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/c/66/c6695faa-e55e-11e9-9045-bb2dc8600c3e/5d951bf77c8e7.image.jpg?crop=1726%2C971%2C0%2C115&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/c/66/c6695faa-e55e-11e9-9045-bb2dc8600c3e/5d951bf77c8e7.image.jpg?crop=1726%2C971%2C0%2C115&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/c/66/c6695faa-e55e-11e9-9045-bb2dc8600c3e/5d951bf77c8e7.image.jpg?crop=1726%2C971%2C0%2C115&resize=750%2C422&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/c/66/c6695faa-e55e-11e9-9045-bb2dc8600c3e/5d951bf77c8e7.image.jpg?crop=1726%2C971%2C0%2C115&resize=1200%2C675&order=crop%2Cresize 1200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/c/66/c6695faa-e55e-11e9-9045-bb2dc8600c3e/5d951bf77c8e7.image.jpg?crop=1726%2C971%2C0%2C115&resize=1700%2C956&order=crop%2Cresize 1700w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-labels">
            
                <div class="card-label-section text-muted">
                    <a href="/columnists/regina_brett" class="tnt-section-tag">Regina Brett</a>
                </div>
            
            </div><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/columnists/regina_brett/indians-are-going-going-gone/article_6e2be918-c120-11ea-9c08-63d0ece12cd1.html" class="tnt-asset-link">
        

        
            Indians are going, going, gone</a></h3></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
                </div>
                
            
            
            
                
            
            
        <div class=" col-sm-3 last-grid-item">
                 
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                                
                    <article id="card-summary-1177945-2a6d72b2-c04b-11ea-9936-07cb7561ad22" class="tnt-asset-type-article clearfix card summary has-image image-top inherit letterbox-style-default  tnt-section-news tnt-sub-section-local-news">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-2a6d72b2-c04b-11ea-9936-07cb7561ad22 media-preview article-asset" data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/local_news/regano-recalled-for-putting-solon-schools-on-the-map/article_2a6d72b2-c04b-11ea-9936-07cb7561ad22.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="Regano recalled for putting Solon schools on the map"
                            class="img-responsive lazyload full default"
                            width="916"
                            height="515"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/f/3e/f3e90850-bf82-11ea-85ee-1fba09f5b1ed/5f0316f612d61.image.jpg?crop=916%2C515%2C6%2C215&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/f/3e/f3e90850-bf82-11ea-85ee-1fba09f5b1ed/5f0316f612d61.image.jpg?crop=916%2C515%2C6%2C215&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/f/3e/f3e90850-bf82-11ea-85ee-1fba09f5b1ed/5f0316f612d61.image.jpg?crop=916%2C515%2C6%2C215&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/f/3e/f3e90850-bf82-11ea-85ee-1fba09f5b1ed/5f0316f612d61.image.jpg?crop=916%2C515%2C6%2C215&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/f/3e/f3e90850-bf82-11ea-85ee-1fba09f5b1ed/5f0316f612d61.image.jpg?crop=916%2C515%2C6%2C215&resize=750%2C422&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/assets/v3/editorial/f/3e/f3e90850-bf82-11ea-85ee-1fba09f5b1ed/5f0316f612d61.image.jpg?crop=916%2C515%2C6%2C215&resize=916%2C515&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-labels">
            
                <div class="card-label-section text-muted">
                    <a href="/news/local_news" class="tnt-section-tag">Local News</a>
                </div>
            
            </div><div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/news/local_news/regano-recalled-for-putting-solon-schools-on-the-map/article_2a6d72b2-c04b-11ea-9936-07cb7561ad22.html" class="tnt-asset-link">
        

        
            Regano recalled for putting Solon schools on the map</a></h3></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
                </div>
                
            
            
            
                
                    <div class="clearfix hidden-xs"></div>
                
            
            
        
        <div class="clearfix hidden-xs"></div>
        
        
        </div>
        </div></section></div><div id="tncms-block-1543684" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1543684" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1543684');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
<!-- code here -->

                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-1279075" class="tncms-block"><h4 class="custom-footer-company-name">Cleveland Jewish News</h4></div><div id="tncms-block-1164767" class="tncms-block"><section id="block-1164767" class="block emphasis-h4   " ><address>
    <strong>cjn.org</strong><br>
    23880 Commerce Park, Suite 1<br>
    Beachwood, OH 44122
    <br>
    
        <span class="fas tnt-phone" title="Phone"></span> 216-454-8300<br>
        <span class="fas tnt-envelope" title="Email address"></span> <a href="mailto:webinfo@cjn.org">webinfo@cjn.org</a><br>
    
</address></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-about-the-cjn"  href="/site/about.html" >
                    <span class="nav-label">About the CJN</span>
                </a></li><li>
                <a class="nav-link  tnt-section-advertise"  href="/site/advertise" >
                    <span class="nav-label">Advertise</span>
                </a></li><li>
                <a class="nav-link  tnt-section-cjn-board-of-directors"  href="/site/cjn_board_of_directors.html" >
                    <span class="nav-label">CJN Board of Directors</span>
                </a></li><li>
                <a class="nav-link  tnt-section-cjn-foundation-board-of-directors"  href="/affiliates/cjn_foundation/cjn-foundation-board-of-directors/article_abe2d03e-ed37-11e1-9bda-0019bb2963f4.html" >
                    <span class="nav-label">CJN Foundation Board of Directors</span>
                </a></li><li>
                <a class="nav-link  tnt-section-cjn-tomorrow"  href="/cjn_tomorrow/" >
                    <span class="nav-label">CJN Tomorrow</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/contact.html" >
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-digital-edition"  href="https://cjn.newzware.com/ss70v2/cjn/common/template.jsp"  target="_blank" rel="noopener">
                    <span class="nav-label">Digital Edition</span>
                </a></li><li>
                <a class="nav-link  tnt-section-employment"  href="/employment/" >
                    <span class="nav-label">Employment</span>
                </a></li><li>
                <a class="nav-link  tnt-section-manage-your-subscription"  href="https://cjn.newzware.com/ss70v2/cjn/common/template.jsp"  target="_blank" rel="noopener">
                    <span class="nav-label">Manage Your Subscription</span>
                </a></li><li>
                <a class="nav-link  tnt-section-policies"  href="/site/policies.html" >
                    <span class="nav-label">Policies</span>
                </a></li><li>
                <a class="nav-link  tnt-section-sign-up-for-cjn-emails"  href="/esignup" >
                    <span class="nav-label">Sign up for CJN emails</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-1164786" class="tncms-block padding-bottom"><div class="follow-links-1164786 default">
    
    <section id="block-1164786" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1164786 ">
        <div class="block-title-inner">
            <h4>
                
                Connect with us
                
            </h4>
        </div>
    </div></div><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/ClevelandJewishNews" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/CleveJN" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://www.linkedin.com/company/cleveland-jewish-publication-company" title="LinkedIn" target="_blank" rel="noopener" class="btn btn-md btn-link li" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-linkedin-in"></i>
                    <span class="sr-only">LinkedIn</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://www.youtube.com/user/CleveJN" title="Youtube" target="_blank" rel="noopener" class="btn btn-md btn-link yt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://www.instagram.com/clevejn/" title="Instagram" target="_blank" rel="noopener" class="btn btn-md btn-link is" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.clevelandjewishnews.com",
  "sameAs" : ["https://www.facebook.com/ClevelandJewishNews","https://twitter.com/CleveJN","https://www.linkedin.com/company/cleveland-jewish-publication-company","https://www.youtube.com/user/CleveJN","https://www.instagram.com/clevejn/"]
}
</script>
<div class="clearfix"></div></div><div id="tncms-block-1164761" class="tncms-block"><section id="block-1164761" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1164761 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-news"  href="/news" >
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-features"  href="/features" >
                    <span class="nav-label">Features</span>
                </a></li><li>
                <a class="nav-link  tnt-section-opinion"  href="/opinion" >
                    <span class="nav-label">Opinion</span>
                </a></li><li>
                <a class="nav-link  tnt-section-community"  href="/community/" >
                    <span class="nav-label">Community</span>
                </a></li><li>
                <a class="nav-link  tnt-section-obituaries"  href="/community/lifecycles/obituaries/" >
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link  tnt-section-events"  href="/calendar" >
                    <span class="nav-label">Events</span>
                </a></li><li>
                <a class="nav-link  tnt-section-magazines"  href="/magazines/" >
                    <span class="nav-label">Magazines</span>
                </a></li><li>
                <a class="nav-link  tnt-section-classifieds"  href="/classifieds" >
                    <span class="nav-label">Classifieds</span>
                </a></li><li>
                <a class="nav-link  tnt-section-the-samuel-h-miller-keeping-our-words-alive-digital-archive-of-the-cleveland-jewish-news"  href="http://digital.olivesoftware.com/Olive/APA/ClevelandJewishNewsFree/default.aspx"  target="_blank" rel="noopener">
                    <span class="nav-label">The Samuel H. Miller Keeping our Words Alive Digital Archive of the Cleveland Jewish News</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-1211528" class="tncms-block"><section id="block-1211528" class="block emphasis-h3   " ><article class="card promo media"><div class="media-body"><h3 class="media-heading">Subscribe to the Cleveland Jewish News</h3><p>Get the award-winning Cleveland Jewish News and our popular magazines delivered directly to you. Prices start at $53.95 per year. Subscribe today!</p><a href="/site/forms/subscription_services/">
                <button type="button" class="btn btn-warning btn-lg">Subscribe</button>
            </a></div>
</article></section></div><div id="tncms-block-1211529" class="tncms-block"><section id="block-1211529" class="block emphasis-h3   " ><article class="card promo media"><div class="media-body"><h3 class="media-heading">Where to Buy</h3><p>Find a copy of the Cleveland Jewish News. View a list of stores and vendors.</p><a href="/site/rack_locations.html">
                <button type="button" class="btn btn-info btn-lg">See List</button>
            </a></div>
</article></section></div><div id="tncms-block-1689436" class="tncms-block"><a href="https://www.bbb.org/us/oh/beachwood/profile/newspaper/the-cleveland-jewish-publication-company-0312-11005457/#sealclick" target="_blank" rel="nofollow"><img src="https://seal-cleveland.bbb.org/seals/blue-seal-200-42-whitetxt-bbb-11005457.png" style="border: 0;" alt="The Cleveland Jewish Publication Company BBB Business Review"></a></div></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                



<div class="row">
<div class="col-sm-4"><div id="tncms-region-option-footer-upper-left" class="tncms-region "><div id="tncms-block-1279078" class="tncms-block"><div class="option-footer-navigation-container">
<h4><a href="/site/contact.html">Contact Us</a></h4>

<ul class="nav nav-pills nav-stacked">
<li><a href="/site/forms/online_services/submit_news/submit_news">Submit News</a></li>
  <li><a href="/site/forms/online_services/letter/letter_editor">Send a Letter to the Editor</a></li>
  <li><a href="/users/admin/calendar/event/">Submit an Event</a></li>
  <li><a href="https://cjn.newzware.com/ss70v2/cjn/common/template.jsp" target="_blank">Manage your subscription</a></li>
</ul>
</div></div></div></div>
<div class="col-sm-4"><div id="tncms-region-option-footer-upper-middle" class="tncms-region "><div id="tncms-block-1279079" class="tncms-block"><div class="option-footer-navigation-container">
<h4><a href="/site/advertise/">Advertising</a></h4>

<ul class="nav nav-pills nav-stacked">
<li><a href="mailto:adsales@cjn.org">Place a Classified ad</a></li>
  <li><a href="mailto:adsales@cjn.org">Display advertising</a></li>
  <li><a href="mailto:adsales@cjn.org">Magazine advertising</a></li>
  <li><a href="mailto:adsales@cjn.org">Custom publishing</a></li>
</ul>
</div></div></div></div>
<div class="col-sm-4"><div id="tncms-region-option-footer-upper-right" class="tncms-region "><div id="tncms-block-1279080" class="tncms-block"><div class="option-footer-navigation-container lifecycles1">
<h4><a href="/site/forms/announcements/">Submit LifeCycles Announcements</a></h4>

<div class="row">
<div class="col-sm-6 lifecycles-left">
<ul class="nav nav-pills nav-stacked ">
<li><a href="/site/forms/announcements/anniversary/anniversaries">Anniversaries</a></li>
  <li><a href="/site/forms/announcements/birth/birth_announcement">Births</a></li>
  <li><a href="/site/forms/announcements/bnai_mitzvah/bnai_mitzvah">B-nai Mitzvah</a></li>
  <li><a href="/site/forms/announcements/engagement_announcements/engagement_announcements">Engagement</a></li>
</ul>
</div>


<div class="col-sm-6 lifecycles-right">
<ul class="nav nav-pills nav-stacked ">
<li><a href="/site/forms/announcements/marriage_announcements/marriage_announcement">Wedding</a></li>
  <li><a href="/site/forms/announcements/obituary/obituaries">Obituary</a></li>
  <li><a href="/site/forms/announcements/unveilings/unveiling">Unveiling</a></li>
</ul>
</div>
</div>
</div></div></div></div>
</div>

<div class="row">
<div class="col-sm-4 col-md-3"><div id="tncms-region-option-footer-lower-left" class="tncms-region "><div id="tncms-block-1180687" class="tncms-block padding-bottom padding-top"><section id="block-1180687" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/content/tncms/custom/image/1a54ec24-e545-11e5-9150-0737937624cb.png" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div></div></div>
<div class="col-sm-4 col-md-3"><div id="tncms-region-option-footer-lower-middle" class="tncms-region "><div id="tncms-block-1279085" class="tncms-block"><div class="option-footer-logo-navigation-container">
<ul class="list-unstyled">
<li><a href="http://www.cjn.org">Cleveland Jewish News </a></li>
<li><a href="http://www.columbusjewishnews.com">Columbus Jewish News</a></li>
  <li><a href="http://jstylemagazine.com" target="_blank">Jstyle</a></li>
  <li><a href="http://canvascle.com" target="_blank">Canvas</a></li>
</ul>
</div></div></div></div>
<div class="col-sm-4 col-md-6"><div id="tncms-region-option-footer-lower-right" class="tncms-region "><div id="tncms-block-1279086" class="tncms-block"><div class="option-footer-logo-navigation-container">
<ul class="list-unstyled">
<li><a href="http://www.balancedmag.com" target="_blank">Balanced Family</a></li>
  <li><a href="/magazines/barbat">Bar-Bat Mitzvah</a></li>
  <li><a href="/magazines/source/">SOURCE</a></li>
</ul>
</div></div></div></div>
</div>

<div class="row">
<div class="col-sm-12"><div id="tncms-region-option-footer-full-bottom" class="tncms-region "></div></div>
</div>




<!-- code here -->
<script type="text/javascript">
$(document).ready(function(){
$('.user-calendar #create-event-form input#website').attr("placeholder","http://www.example.com");
});
</script>

<!-- #603409 -->
<!-- BEGIN PRIVY WIDGET CODE -->
<script type='text/javascript'>
var _d_site = _d_site || '24CCE662028DDE17D7646AB8';
(function(w, d, p, s, s2) {
w[p] = w[p] || function() { (w[p].q = w[p].q || []).push(arguments) };
s = d.createElement('script'); s.async = 1; s.src = '//widget.privy.com/assets/widget.js';
s2 = d.getElementsByTagName('script')[0]; s2.parentNode.insertBefore(s, s2);
})(window, document, 'Privy');
</script>
<!-- END PRIVY WIDGET CODE -->



            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-1164768" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-1164768"><div class="col-xs-12"><small>© Copyright 2020 Cleveland Jewish News, 23880 Commerce Park, Suite 1 Beachwood, OH </small><small>&nbsp;| <a href="/site/terms.html">Terms of Use</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }
        });
    </script>
<script>
        __tnt.trackEvent = function(obj) {
            if( jQuery.type(obj) === 'object' ){
                 
                    if(obj.category && obj.action){
                        __tnt.googleEvent(obj);
                    } else if(obj.network && obj.socialAction){
                        __tnt.googleSocial(obj);
                    } else if(obj.url){
                        __tnt.googlePageView(obj);
                    }
                    if(typeof TNCMS.Tracking != 'undefined' && obj.metric){
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
                
            }
        }
        
        if(__tnt.trackEventLater.length > 0){
            jQuery(__tnt.trackEventLater).each(function(){
                __tnt.trackEvent($(this));
            });
        }
        jQuery('body').on(__tnt.client.clickEvent, '[data-track]', function(){
            var trkObj = jQuery(this).data('track');
            __tnt.trackEvent(trkObj);
        });
        jQuery('body').on(__tnt.client.clickEvent, '[data-tncms-track-event]', function(){
            var trkObj = jQuery(this).data('tncms-track-event');
            __tnt.trackEvent(trkObj);
        });
        jQuery('body').on(__tnt.client.clickEvent, '[data-tncms-track-dmp]', function(){
            var dmpData = jQuery(this).data('tncms-track-dmp');
            	_cc10228.add('act', dmpData);
	_cc10228.bcp();
});
    </script>
    

    
    
    
    
    <!-- scc Ticket #639775 -->
    <!-- Begin Constant Contact Active Forms -->
<script> var _ctct_m = "19f8ac0798a1c8655f7c580f30b6c87a"; </script>
<script id="signupScript" src="//static.ctctcdn.com/js/signup-form-widget/current/signup-form-widget.min.js" async defer></script>
<!-- End Constant Contact Active Forms -->


<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script>/*<![CDATA[*/ function articleShareSticky(){
                setTimeout(function(){
                    var sMainTop = document.querySelector('#main-body-container').offsetTop,
                        oNavBar = document.querySelector('#site-navbar-container');
                    if (sMainTop < window.scrollY){
                        oNavBar.classList.add('article-share')
                    } else {
                        oNavBar.classList.remove('article-share')
                    }
                }, 150)
            }
            document.addEventListener('scroll', articleShareSticky); /*]]>*/</script>
<script>/*<![CDATA[*/ !function(t,i,n){var e,a,s,o,c,d={init:function(){a=i.getElementById("site-navbar-container"),n.client.platform.ios?a.classList.add("affix-sticky"):(e=i.getElementById("main-body-container"),s=a.offsetHeight||a.clientHeight,o=!1,c=0,t.addEventListener("scroll",d.navPosition,!1),t.addEventListener("mousewheel",d.navPosition,!1))},navPosition:function(){o||(o=!0,setTimeout(function(){var n=a.getBoundingClientRect(),d=t.pageYOffset||i.documentElement.scrollTop,f=n.top+d;d>=f&&d>c?a.classList.contains("affix")||(c=f,a.classList.add("affix"),a.classList.remove("affix-top"),e.style.marginTop=s+"px"):a.classList.contains("affix-top")||(a.classList.remove("affix"),a.classList.add("affix-top"),e.style.marginTop="0px"),o=!1},25))}};"loading"==i.readyState?i.addEventListener("DOMContentLoaded",d.init,!1):d.init()}(window,document,__tnt); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.core.5dd2f631c0899403c746c644466933ea.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/owl.carousel.66c591eb93f177b0f59892f361c3b1b4.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/clevelandjewishnews.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.reactions.496ef4077c989f2b546ccbd9a5d4e1f9.js"></script>
<script>/*<![CDATA[*/ 
                        function dmpReactionData(){
                            var sReactionData = document.getElementById('hidden-type').value,
                                sReactionKeywords = "'Engage:Stephen Jackson','Engage:Desean Jackson','Engage:Sport','Engage:Politics','Engage:Sociology','Engage:American Football','Engage:Basketball','Engage:Michael Wilbon','Engage:Jew','Engage:Stephen A. Smith','Engage:Louis Farrakhan','Engage:Conspiracy Theory'";	_cc10228.add('act', sReactionData, sReactionKeywords);
	_cc10228.bcp();
} /*]]>*/</script>
<script>/*<![CDATA[*/ 
            jQuery(document).ready(function($){
                var iqLogin = $.cookie('tnt-iq-login') || false;
                if (__tnt.user.loggedIn && iqLogin == false) {
                    if (__tnt.user.services) {
                        var userServices = __tnt.user.services.split(',');
                        for (i = 0; i < userServices.length; i++) { 
                            var serviceData = 'has_subservice: ' + userServices[i];
                            	_cc10228.add('act', serviceData);
	_cc10228.bcp();

                        }
                    }
                    $.cookie('tnt-iq-login', 1);
                }
            });
        
            if (window.location.hash){
                var hashSet = ['tncms_source','utm_source','utm_campaign','utm_medium','utm_content','utm_term'],
                    urlHash = window.location.hash.replace('#','').split('&');
                for (var i = 0; i < urlHash.length; i++) {
                    var data = urlHash[i].split('='),
                        param = data[0].replace('-','_');
                    if (hashSet.indexOf(param) != -1){
                        var dmpData = param + ': ' + data[1];
                        	_cc10228.add('act', dmpData);
	_cc10228.bcp();

                    }
                }
            }
         /*]]>*/</script></body>
</html>